Jeep Enthusiast Forums banner
1 - 15 of 15 Posts

·
Registered
Joined
·
4,473 Posts
Discussion Starter · #1 ·
My drivers are getting Stuck on the wiper side once they move over. However when I barely move them toward passenger they will move on there on to passenger and back to drivers side to get stuck again. They're not coming into contact with the frame or glass seal. Does anybody recognize this problem ?
 

·
Registered
Joined
·
4,473 Posts
Discussion Starter · #3 ·
Interesting. I dont see any flexing on the outside. I see the arm kinda come out toward the front of the jeep when it stops. Not off the splines - just the in and out play of the pivot . Also interesting is when i block the wipers with my hand from going all the way to the drivers side ; they dont get stuck . My mechanic said motor but now im thinking binding
 

·
Registered
Joined
·
4,473 Posts
Discussion Starter · #5 ·
I'd almost guarantee it's binding. Mine did the same thing you are describing.

Time to take a look at the linkages inside the frame.

Matt
Alright . I'm actually looking forward to it .
 

·
Registered
Joined
·
1,994 Posts
They are parking there or stopping because of a bind?

Insure your "frog eyes" Where the shafts come out are not disfigured, even tilted a little bit. If the wiper shaft is not standing perpendicular all

the way around to the face of the windshield frame---it's asking to bind.

The one on the drivers side of Mr. Jeep was about to tear out, It had creased back and forth so many times as it wobbled,

I cut 2 frog eyes out of a scrap windshield frame and sealed

and riveted them on both sides, over the original frog eyes (keeping it all symmetrical looking).

If I call 'em alligator eyes, I'm referring to the same animal. ---see pic 1)

Yeah, yeah this is a real old pic and I have cut out and fixed the rust under the driver's door, new paint, and new black decals!

Continuing on with possibilities

I labeled this second diagram. Are "A" and "B's levers both pointing down?

Are the rods straight and not bent?

If you take "C" loose and let the drive link dangle---will the motor run unimpaired?

-----JEEPFELLER
 

Attachments

·
Registered
Joined
·
4,473 Posts
Discussion Starter · #7 ·
They are parking there or stopping because of a bind?

Insure your "frog eyes" Where the shafts come out are not disfigured, even tilted a little bit. If the wiper shaft is not standing perpendicular all

the way around to the face of the windshield frame---it's asking to bind.

The one on the drivers side of Mr. Jeep was about to tear out, It had creased back and forth so many times as it wobbled,

I cut 2 frog eyes out of a scrap windshield frame and sealed

and riveted them on both sides, over the original frog eyes (keeping it all symmetrical looking).

If I call 'em alligator eyes, I'm referring to the same animal. ---see pic 1)

Yeah, yeah this is a real old pic and I have cut out and fixed the rust under the driver's door, new paint, and new black decals!

Continuing on with possibilities

I labeled this second diagram. Are "A" and "B's levers both pointing down?

Are the rods straight and not bent?

If you take "C" loose and let the drive link dangle---will the motor run unimpaired?

-----JEEPFELLER
Not parking but they are stopping . What frog 🐸 eyes and alligator eyes are you talking about ?
 

·
Registered
Joined
·
4,473 Posts
Discussion Starter · #10 ·
"grasshopper eye"

------jeepfeller
I cant see pictures on jeep forum 90 percent of the time . Unfortunately I can't see it 😕. You talking about the pivot holes ?
 

·
Registered
Joined
·
1,994 Posts
The raised 2 portions on your windshield frame in which the wiper shafts protrude thru.

Need to get your picture viewing thingee fixed, you are missing out on, not only my stuff, but all of the other wonderful pics/ explanations that are on this site,

-----JEEPFELLER
 

·
Registered
Joined
·
4,473 Posts
Discussion Starter · #12 ·
The raised 2 portions on your windshield frame in which the wiper shafts protrude thru.

Need to get you picture viewing thingee fixed, you are missing out on, not only my stuff, but all of the other wonderful pics/ explanations that ae on this site,

-----JEEPFELLER
Yeah totally. I've tried updating my browser but no luck
Okay well its seems to be working right now . I slid the motor over toward the druvers side as much as possible.
Thanks.
 

·
Registered
Joined
·
4,473 Posts
Discussion Starter · #13 ·
My wipers got stuck again like they were . So im gonna have to try some more. I can t do anything right now because if you loose that clip that holds motor pivot to linkage it will run away . I have a few clips as back ups coming
 

·
Registered
Joined
·
23,358 Posts
I've removed the wiper linkages from my windshield frame several times without losing the clips.

Of course, now that I say that, I'll surely lose a clip the next time I have to mess with the wipers.

Have you tried running the wipers while watching the linkages? It should be fairly obvious where they are binding, and why.

Matt
 

·
Registered
Joined
·
4,473 Posts
Discussion Starter · #15 ·
I've removed the wiper linkages from my windshield frame several times with loosing the clips.

Of course, now that I say that, I'll surely loose a clip the next time I have to mess with the wipers.

Have you tried running the wipers while watching the linkages? It should be fairly obvious where they are binding, and why.

Matt
Not yet I may fo that right now . But you know moving the motor toward drivers hside seemed to helped. Don't know why it messed up again. I'll take a look and follow up. Ty
 
1 - 15 of 15 Posts
Top