Jeep Enthusiast Forums banner
1 - 4 of 4 Posts

· Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
When I start my 2009 Liberty and the key returns to the run position the starter motor will occasionally not disengage and continue to run while engine is started. When I turn the ignition to the off position the engine shuts down but the starter continues to run. Suspecting the ignition switch I bypassed the switch with a remote starter. Turn the ignition switch to the run position and start with the remote. Starter still occasionally wont disengage.
The starter motor has been replaced as it was under warranty and no change. So I think I can rule out the starter and ignition switch.
Today I will check and or replace all related relays in the power box and begin looking for a ground/wiring issue.
I have seen multiple posts in various places regarding similar issues.
Someone had suggested that the starter drive was hanging up on the starter ring but I don’t think that’s the issue as when I remove the positive terminal at the battery the starter disengages.
 

· Registered
Joined
·
13,330 Posts
in TIPM remove starer relay, swap in a like relay to see if the relay has failed or you have a wiring issue.
Scan for codes - likely a 'B" series code may be set.
with a wiring diagram check circuits I find relay a place to check circuitry - attached is SIMPLIFIED dia.
 

Attachments

· Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
in TIPM remove starer relay, swap in a like relay to see if the relay has failed or you have a wiring issue.
Scan for codes - likely a 'B" series code may be set.
with a wiring diagram check circuits I find relay a place to check circuitry - attached is SIMPLIFIED dia.
Thank you for the reply. I’m not a fan of electrical issues. Give me a wrench anyday over electrical.
 
1 - 4 of 4 Posts
Top