Jeep Enthusiast Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hey everyone, I have a 2006 jgc limited hemi that is throwing 4wd service light esp/bas and security lights blink. Occasionally it will say check gauges as well. When it throws these lights the engine will crank and fire up but shut down shortly after firing. It doesn’t stall it shuts down like you turned it off. It will randomly do this and basically if you keep cycling the key until the lights go out on the dash it will fire right up and run fine but when you shut it off it may do it again or it may not. I thank anyone who may have some kind of information on this issue.
 

·
Registered
Joined
·
12,618 Posts
first thing would be to check for codes.
A scanner is the go to tool.
 

·
Registered
Joined
·
47 Posts
Just because the CEL isn't on doesn't mean there's no "codes". Different DTC's can be tripped without the CEL being on, meaning you'd have to have a more versatile scanner. This issue you're having is almost impossible to diagnose correctly without the proper equipment otherwise you'll just be throwing parts at it.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #9 · (Edited)
Interesting thing I figured out is if I crank it as soon as the keys in the ignition it hasn’t done it but if I let everything boot up before cranking it does it. I’m baffled and I understand these things which is why I decided to see if anyone may of had this issue.
 
1 - 9 of 9 Posts
Top