Jeep Enthusiast Forums banner
1 - 20 of 169 Posts

·
Registered
Joined
·
65 Posts
Discussion Starter · #1 ·
If your Jeep's lit cluster/VIC/HVAC controls are dimming by themselves, it's probably due to bad solder joints on the headlight switch. I fixed mine yesterday and took some pics and added in instructions. This was done on a 97 Limited with auto headlights and fogs.

This seems to have become quite a popular thread. Glad it's still helping people out! - Edited 10/27/2015

Big shoutout to: Cerbere for re-uploading these images after Imageshack made off with them.

Tools:
  1. Soldering Iron
  2. Roll of Rosin Core Solder
  3. Phillips screwdriver
  4. Micro screwdriver
  5. Q-tips/swabs
  6. Isopropyl Alcohol
As an addendum (10/2015), I'd recommend also picking up some flux paste as it can make the adhering of the solder to the joints a hell of a lot easier.

Enjoy.
 

Attachments

·
Registered
Joined
·
3,323 Posts
fyi, a radio shack 15/30w soldering iron for ~$7 is your best bet for this. Cheap, and a good overall iron. 15w for the small electronics and 30w for the bigger ones (like ^).
 

·
Registered
Joined
·
3,323 Posts
You need to be a member for I think 30 days and/or have 50 posts to post images. Or you can buy a membership and be able to to it regardless of how long you've been here or posts.
 

·
Registered
Joined
·
7 Posts
SNIPERDUDE! I just did this, and first of you instructions were spot on, AND it worked like a charm. In your other thread you spoke about "bending" where the two pieces meet. I had no idea what you were talking about until I disassembled my switch and sure enough, there was a lot of "bending". Once I resoldered the points there was no more "bending", and sure enough it works like new. This solved my problems with the Auto Headlights and the lights on my guages flickering. Thanks for the help!
 

·
Registered
Joined
·
48 Posts
Thanks for this great post, Sniperdude. I'd have just thrown out my part without doing the repair that you recommend. And it worked perfectly. To your excellent advice, I would just add one item for those with soldering experience. When "resoldering," you should always reheat with new solder. This helps fluxing and also acts as a bit of a heat sink.
 

·
Registered
Joined
·
177 Posts
Sorry to bump an old thread... but thanks for this. I had to subscribe so I can find this later. Thank you for posting this! I thought I was the only one with this problem.
 

·
Registered
Joined
·
704 Posts
if your dash lights are flickering up and down, you can clean the sliding contact switch with PB Blaster. it is a great electrical connection cleaner.
You got to spray it into the slider past the plastic dust flap and work the slider back and forth.
For some reason, my GC 1998 has numerous little electrical connection failures. Switches, sockets, wiring plugs stop working due to all i can guess high resistance corrosion. It is not visible when you look at the metal, but it is there.

for example radio connection plugs in back of radio, abs connection plug for rear wheel sensors under the dash, dash lamp sockets, headlamp switch, turn signal bulbs.
 

·
Registered
Joined
·
1,443 Posts
dumb question why do we need to remove board to resolder the points the pics show all the points are accessable with the white cover removed ?
 

·
Registered
Joined
·
748 Posts
dumb question why do we need to remove board to resolder the points the pics show all the points are accessable with the white cover removed ?
No need to! I was just about to mention this. Just unscrew the white plastic cover and resolder. That's how I fixed mine.

If this alone doesn't fix it, then go ahead and take it apart. But getting the fog light switch plastic piece off is impossible on most of these without breaking something.
 

·
Registered
Joined
·
274 Posts
Tried this out today...

I just re-soldered up the back of the board, after you remove the white plastic and it fixed my problem.

THANK YOU VERY MUCH:tea::cheers:
 

·
Registered
Joined
·
171 Posts
Just did mine! All the instructions were great, I had some trouble getting the panel out, but that was just me. Anyway, its all fixed now, thanks for the pictures!
 

·
Registered
Joined
·
112 Posts
Cool, just did this cant wait to see if it worked when I put it back in. Seriously everyone one of those points from the 1 board to the other were cracked. It was just wobbling.
 

·
Premium Member
Joined
·
235 Posts
done, now just waiting till its dark to make sure everything is good.
 
1 - 20 of 169 Posts
Top