Jeep Enthusiast Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hello all - I got some great advice a couple weeks ago because i had a loud grinding and squeeling coming from the engine.

I was told to replace the water pump. It was wrecked!
I replaced the water pump, thermostat and serpentine belt and the jeep is finally running.

The new issue is that it is running fine without A/C or Heat but as soon as i turn either on there is a screeech like no other.
What now? Alternator? A/C?


98 Jeep Cherokee 4.0 4x4
160k
 

·
Real Jeeps have dents
Joined
·
29,520 Posts
Tighten the serpentine fan belt. XJ Cherokees like the belt really tight.
 

·
Registered
Joined
·
488 Posts
Krikit II! Belt tension is posted around here somewhere as well. Also, a new belt will stretch (there is a tension for a "new" belt [under 15 mins runtime] and another for "used" belts) a little, so what may have been good tension is just on the edge, and running the compressor is enough to make that lovely squeal.
 

·
Registered
Joined
·
54 Posts
You'll be dumbfounded as to how tight the belt needs to be not to squeek when the accessories are on such as loads from A/C, alternator, and power steering.. Good luck.. Dont be Skeered just keep tightening it.
 

·
Registered
Joined
·
606 Posts
You'll be dumbfounded as to how tight the belt needs to be not to squeek when the accessories are on such as loads from A/C, alternator, and power steering.. Good luck.. Dont be Skeered just keep tightening it.
I have a decal on my jeep that says aint skeered :rofl: anyway yeah I am having this same issue so thanks for the helpful info to me to and for getting this up before me. Mine had a new belt when I bought it and does the same thing.
 

·
Registered
Joined
·
22 Posts
Squealing (SCREEEAMING) belt, AFTER belt replacement AND re-tighten. Is WP wonky??

Howdy all!!

I too, am having this "issue." The LAST time that she squealed like this, she threw the Harmonic Balancer (HB.) : / I am wondering if someone would take a look at these pictures.

I replaced the squealing belt and she was fine, for about ~40 miles. After she sat, for a day, she started to squeal again,

I tightened the belt a little more (new belt stretch) and the squeal did not go away. Loud as EVER!!! (I H-A-T-E that noise :p )

I was looking at all of the pulleys and noticed that my Waterpump pulley looks freaking CROOKED. At least in comparison to the HB and my Power Steering Pump Pulley (PSP.) The HB and PSP seem to be aligned as well as the Idler Pulley (IP) ...???

I have never noticed this before, and wonder if someone would take a look and see if this is "normal."

Also, the IP wobbles ABOUT ~0.5mm (front to back [rocking against the bolt as the fulcrum]) This is a "secondary" concern though.

My main concern is the WP and the pulley alignment. If this (again) is a "normal" position for this pulley.

I TRIED to take enough good pictures, from various angles to show the "discrepancy" in its alignment toward the other pulleys. IDK... Maybe it's my PSP that is "crooked???" But the WP it is definitely NOT parallel with the HB pulley.

PLEASE!!! Let me know what y'all think. I just extended this thread as it seems that it still applies. "BELT SQUEALS!!!" : ) Bump!

Thank you so much, in advance on this one, for any answers or directions. : ) -EB

1989 Jeep Cherokee
4.0L 6 Cyl.
HB replaced ~3 years ago.
Everything else is "original"
The front-end equipment (WP, PSP, AC, TS Housing, etc.) have all been removed and re-installed ~5 - 6years ago.

Links to pictures (LOW Res) : P Not sure if I am "qualified" at this point to UL pics. but will try.

http://www.ultraimg.com/image/Gio6
http://www.ultraimg.com/image/GioA
http://www.ultraimg.com/image/GioD
http://www.ultraimg.com/image/Gioc
http://www.ultraimg.com/image/Gioe
http://www.ultraimg.com/image/GioI
http://www.ultraimg.com/image/Giok

IF I am allowed, then HIGH-Res will be attached, below.

Pictures 4, 5 and 6 will show the WP Pulley, in what I think, is a "wonky" position (angled "in" on the right side.) You can see the "wedge" in these pictures. These are direct, Top - Down pictures., you can see, DIRECTLY below serpentine belt. You can see the "offset" of the pulley BELOW the belt... The belt is square, with the camera...

Is this (again) "normal??"
 

Attachments

1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top