Jeep Enthusiast Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
63 Posts
Discussion Starter · #1 ·
Howdy-

I know everybody is going to say "why bother", but I'm one of those weird people who still listens to AM radio sometimes. Well, my aftermarket radio died recently and I just decided to put a stock one back in. Ordered it off eBay, finally got it, installed it, and the FM works fine, but I get nothing on AM. Not even static unless I turn the volume way up.
Contacted the seller who says "there is a separate AM antenna in these vehicles, my best guess is the connection to that is broken.... AM stations worked fine on the bench before it was shipped.."

Separate AM antenna??

Any thoughts on this? The only antenna I know of is already plugged in- and it's working cause I tested it with the FM by unplugging it and plugging it back in- there was a difference in FM reception..

Thanks-
Brady
 

·
Registered
Joined
·
785 Posts
There is no separate AM antenna - what BS. Does the mode/band switch work? e.g. change from FM/AM/CD and does the CD work? If FM & CD work, that rules out the amp. so IMHO the AM subsection of the radio is toast. You can harass the seller and ask him/her where is the AM antenna connection?
j
 

·
Registered
Joined
·
63 Posts
Discussion Starter · #4 ·
There is no separate AM antenna - what BS. Does the mode/band switch work? e.g. change from FM/AM/CD and does the CD work? If FM & CD work, that rules out the amp. so IMHO the AM subsection of the radio is toast. You can harass the seller and ask him/her where is the AM antenna connection?
j
Here is the latest response:

The AM antenna splits off in the vehicle. I think it's in the rear quarter window of the vehicle?
 

·
Mopar Nut
Joined
·
586 Posts
 

·
Registered
Joined
·
63 Posts
Discussion Starter · #6 ·
Seems like this is for Euro-spec vehicles only. My antenna is on the passenger fender. No grid in either of the back windows...
 
1 - 6 of 6 Posts
Top