Jeep Enthusiast Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
101 Posts
What you're describing isn't an ignition switch problem, it's a problem of power not getting into the fuse block inside if nothing works in the interior. Check the fuses and connections labeled JB Power, if those are fine look at the BCM, and if that's fine look at the connections for the fuses behind the block. If there's something going on in the interior, the pcm might not supply power to the ignition switch, causing your problem. Electrical issues are always a pain, good luck.
 

·
Registered
Joined
·
101 Posts
Ignition switch power should come from that 40a fuse under the hood that's good. If the accessories work automatically when you turn the key, that should rule out the BCM as well as a short in the ignition switch circuit, that would give the PCM clearance to start the car from the BCM. However if you can't get the accessories working without manually putting power to them, the BCM might be your culprit. Also it could be a matter of communication between the ignition switch and the computers, possibly a short circuit if there's no voltage at the switch and before there was. If you turn the key but the computers don't know you did, the accessories won't turn on. If the BCM was bad you would likely have to bring it to the dealer to get reflashed or buy a used one.
 

·
Registered
Joined
·
101 Posts
I don't believe there's anything in between, if I remember there's no relay for the ignition switch. Did you also check fuses 21, 22 and 31 for ignition run/start? They're three 10 amp red fuses. It seems like everything is working just that nothing happens when you turn the key. If it's not this then I don't know, you might have to start pulling apart individual wires to find a short. Also bad grounds can cause weird things but I don't know if it would cause this
 

·
Registered
Joined
·
101 Posts
There's a mod you can do to fabricate the doors and their hinges out of metal, I've heard it's pretty easy, but I don't know much about it. The AZC system is great...when it works, my right side blows cold air but putting it on recirculation usually fixes that it just takes a long time to heat up.
 
  • Like
Reactions: InTitusville
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top