Jeep Enthusiast Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
124 Posts
Discussion Starter · #1 ·
Ok, didn't find much in searching so here is my situation.
I drive it only on weekends. Start it up 3 times a week to keep battery up.
Drive it all over and no problem. Then, it wont start sometimes.
I mean like once every 2-3 months,works great, then does not start. Wait for a day, then it starts and does the whole sequence over.
I have done all 5 of cruisers first 5 tips from his website except for #2 which i don't have the C101 connector.

Ok, i have replaced the cps sensor with a new Durolast one from auto zone.

When i use my 12 volt tester i have power from the battery to the + side of the primary coil.
When i install the spark-plug tester, i had no power to the plugs, or from the coil secondary, to the cap.

So, i go inside to read the Haynes manual again to diagnose.
I come back out, turn it over and it starts, go figure.
Friday night i started it, let it come to operating temp, then shut down.
So i get up Saturday morning to go to alignment shop after installing 4.5 inch lift. Months ago.
No start. So im messing around with it this weekend. All i did was clean the coil.I cleaned all the connections from the coil, and the box it sits into.
The testing from my coil are as the book shows,
Positive lead to ground====0 or no resistance.
Positive lead to negative lead===0 or no resistance
Negative lead to High voltage terminal =====7.23 K ohms
So as per testing i believe the coil is good.

So go to turn it over, and it starts.
So maybe cleaning the coil did it.
What im asking is, any suggestions as to why some thing works for months, then does not start, then an hour or so later, starts, and this is electrical because my fuel pump always comes on and i smell gas when it does not start.

Just in case this does this again. Maybe bad ign switch?
 

·
Registered
Joined
·
124 Posts
Discussion Starter · #3 ·
CKP, does this mean CPS, or crankshaft sensor?

I also forgot to add after cleaning the coil contacts, it did not start right away, took 3 different on off key switches to start.
 

·
Registered
Joined
·
124 Posts
Discussion Starter · #5 ·
Went to your page last night. Going to buy from napa and keep in vehicle.
Next time it does this will check.
Can my Klein digital tester work or should i use an analog for all measurements.
For instance, i dont have a hi or low setting for resistance.
I have also completed your top 5 tips, minus the c101, and done the blower fan, then next doing the under dash ground.
I have purchased the rebuilt and flow tested injectors also.
Distributor indexing is next also, since i replaced the cap and rotor a few months back.
Thanks for your website.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top