Jeep Enthusiast Forums banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-20 of 139 Results
  1. XJ Cherokee Technical Forum
    So my Jeep has a long crank issue and I can only get it to start when I press the gas. I have had the fuel pump replaced twice in the last three months. Most recently 2 days ago. At that time the car would not start at all, regardless of what I tried. I towed it to the shop and I was advised...
  2. ZJ Grand Cherokee Forum
    I have a 1994 jeep grand Cherokee limited with the 5.2l v8 and it won’t start. I’m getting fuel pressure but no spark. I’m not getting any code related to the issue and I’ve already replaced the coil and the crankshaft position sensor and the camshaft position sensor seems to test good. I also...
  3. ZJ Grand Cherokee Forum
    We have a 95 zj and about 2 months ago when we were getting on the highway the rpms dropped to almost zero sputtered and almost died so we pulled off the highway turned the ignition off waited about 5 min then it started right up and ran fine 4 a couple weeks then it did it again except this...
  4. YJ Wrangler Technical Forum
    If anyone can help would appreciate it. Did the nutter on my automatic 1990 YJ. Started fine, let it warm and then cut out. Did this about three times before I took it to the mechanic next door for the timing (8 degrees btdc). Next day when he tried to start it to adjust timing, nothing. Now it...
  5. JK Wrangler Technical Forum
    I don't drive my jeep daily so sometimes the battery is dead if I don't start it for a few weeks. Last week I went to start it , battery was weak, and it wouldn't crank so I jumped it. It started but only ran for a second then died . Now it won't start at all . When you turn the key forward the...
  6. JK Wrangler Technical Forum
    Hey everyone, I have a 2015 JKU Sahara. I have had a recent issue with the Jeep displaying a “Hot Oil” Warning, but on a cold start. I know it pertains to trans fluid, but the fluid has no way of being hot on a cold start, after not driving for days. I have done some reading and tried a few...
  7. TJ Wrangler Technical Forum
    I have a 2006 Jeep LJ Rubicon. I am experiencing the dreaded No Crank/No Start/NoGauges/No Fuel Pump/No OBDII Scanner connection issue. I’m at the end of my rope and unsure what to do. I feel like I’ve checked everything. Good Battery, all grounds checked, all fuses and relays checked...
  8. WJ Grand Cherokee Forum
    Cranks just fine, good battery good voltage. Seems to have fuel at the fuel rail. Crank and cam sensor seem to be working (scan tool looking at the counts). Scan tool says pulse width is zero to the injectors. I think the computer has convinced itself that the engine is flooded. I know my...
  9. YJ Wrangler Technical Forum
    In a bizarre turn of events, I was replacing the thermostat and the thermostat housing. The jeep sat un-started for about four days. When I went to start the car there was no power in the vehicle. This threw me for a loop as it occurred unrelated to the job I was doing. The issue seen was a...
  10. WK Grand Cherokee & XK Commander Forum
    2007 Jeep GC, 3.7l. After doing some work on this Jeep, it was running great. New coil packs, new radiator, new plugs and couple new O2 sensors. One day, a flash of the Check Engine Light, not staying on, made me pull the code which was a Random Misfire, P300. I checked/cleaned everything and...
  11. YJ Wrangler Technical Forum
    Please Help! I recently bought the Jeep and it ran great for a month or so, I left it for 7 weeks and came back to a dead battery. I found out that the battery was toast and got a new one... No start still. I discovered that I have no spark, replaced the ignition coil then realized that the...
  12. YJ Wrangler Technical Forum
    I am in the process of swapping a 1993 cherokee 4.0 motor into a 1990 yj which previously had the 4.2 liter. It is a pretty rough jeep and only going to be used on trails and around the property so I am fine leaving it pretty rough around the edges as far as wiring and look. What I know...
  13. New Members/Introductions
    I have a huge problem and i’m stumped. So I bought 2 Jeep Grand Cherokees, both 95s, both have the 5.2, both automatics. One was a woods toy, body looked absolutely trashed, ran fine started fine. The other looks beautiful, only problem was the motor was ripped apart and the guy never put it...
  14. Engines & Drivetrain
    I was leaving down town when my jeep died after leaving work. Sputtered, then would not start. There was a few seconds where it sounded like it was going to try to fire, or back fire...then nothing. Towed it home. $120 Thought it was fuel pump. Changed it. $120. Still no spark. (needed to change...
  15. XJ Cherokee Technical Forum
    Out of nowhere yesterday go to start my jeep to run some errands after I get home from work and I get a no start no crank. Break light comes on in the console when I turn the key and all the lights come on no problem. Not sure whats going on and I've tried anything I can think of to get it to...
  16. TJ Wrangler Technical Forum
    Hello all, been a lurker on here for years but I can't seem to find anything on this problem. 1999 stock TJ auto trans, with a very intermittent no crank no start. First time turning the key you get nothing, no solenoid click or anything. Dash, lights and all other electrical works fine. Cycle...
  17. XJ Cherokee Technical Forum
    Hello all, first post here so hoping I did this right. Been reading similar problems but mine seems different than the one's I've been able to find. Key will not turn.. Gear shift will not move. Button on Gear shift knob will not depress. Steering wheel moves freely - not locked. My spare key...
  18. XJ Cherokee Technical Forum
    Worked fine one start then broke on next. I managed to get it started by jumping the starter relay. First thought was to change the starter relay and I did to no effect. After further examination, I realized that when turning key no voltage appeared at the starter relay coil from the ignition...
  19. TJ Wrangler Technical Forum
    New to the Site. I just bought a used 06 Wrangler, and it drove great for the first few days, but was having some weird electrical problems. I pulled the battery and had it tested and it was found to be a bad battery (had corrosion and such also). I cleaned the battery ports etc, and it...
  20. WK Grand Cherokee & XK Commander Forum
    Hey Guys and Gals, I recently bought a 2007 Jeep Grand Cherokee with a 3.7L engine on it. I haven't heard great things about these engines but it was a really good price and the car was well taken care of. Well, it was running perfectly until one morning it just cranked, and cranked and...
1-20 of 139 Results
Top