Jeep Enthusiast Forums banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-11 of 11 Results
  1. Jeep Grand Cherokee & Commander Forums
    Hey guys and girls, I’d like some feedback as to if my diagnosis is on the right track. I have a 2014 Grand Cherokee with the 3.6 pentastar, I had a cel for bank 2 sensor 1 o2 sensor, changed it but didn’t get genuine sensor a month in I had a code for bank two running lean that kept coming up...
  2. TJ Wrangler Technical Forum
    I’m having an issue with the TJ I picked up this week with a lean to the drivers side. I measured the fenders from ground and it’s a half inch difference. I adjusted the track bar and don’t change at all. Only thing I can think of is the lower control arms are not adjusted right. The lift only...
  3. TJ Wrangler Technical Forum
    My TJ had a rough idle and low mpg for about a month with no code. I changed the spark plugs and that did not fix anything. Plugs 4-6 were dirty when I changed them. Once I drove the Jeep on the highway for about 45 min I got a flashing check engine light. The light came on for P0174 and P0306...
  4. ZJ Grand Cherokee Forum
    Thought I would pass this one along for those of us (probably all) who enjoy chasing ZJ gremlins all over the place. My Niner had the random high-idle, immediate reset upon restart a few times last year, cleaning and resetting the MAP sensor connector took care of it. Couple days ago I ran down...
  5. ZJ Grand Cherokee Forum
    hey guys, I just moved to va from ohio and about 2 months ago I replaced my fuel pump with a gmb assembly unit off amazon ($60 shipped to my door:thumbsup:), when I replaced it I did drop the tank and cleaned it out completely. now i just started having a hesitation start yesterday, once I back...
  6. YJ Wrangler Technical Forum
    Hey guys I am having a huge problem with my jeep. This is the first jeep I have owned so I am kinda in the dark about them. My problems I am having is after a year a driving without any problems all the sudden it died while going about 40 MPH then it cranked right up after that it start back...
  7. YJ Wrangler Technical Forum
    Jeep failed smog, because it was running too lean. Tested the fuel pressure and it's down at 22 psi. With the regulator disconnected, it jumps to 31 psi and the vacuum line leading to it is free of fuel and dry. When revving the engine, the psi jumps from 22 to about 27psi. Fuel filter is brand...
  8. Jeep CJ Forum
    Hey guys, I have a question to pose to the 258/Carter BBD experts out there, so here it goes. Jeep Background: 1985 CJ7, 258, Carter BBD, T5, 31's. Nutter'ed & Rush'ed. Rebuilt Jasper about 5k on it. I'm doing the typical tune-up this weekend and the next. I wanted to try and work smarter...
  9. Jeep CJ Forum
    Having trouble with 86 cj7 Idle. When I start it cold everything is normal. Runs at about 1500 rpms for a few minutes, drops to about 800 for a while. Then after reaching running temp, the rpms shoot up to anywhere from 1800 to 2500... 2800ish after driving for a while. I usually only drive...
  10. TJ Wrangler Technical Forum
    I went through water last weekemd jeep died so I had to dry out the distribter it runs now but is still throuwing 51 and 12 cel I changed the oil and air. Filter and still burnt a quarter tank of gas in 25 miles any suggestions
  11. XJ Cherokee Technical Forum
    Hi, I did a few mods now I am stumbling from idle to about 2900rpm. Its not terribly slow but you can feel/hear it has a small stumble, like if it may be lean, until 2900 and then it pulls all the way up. Just looking to see if anyone here has any ideas. Rig: 89 XJ Rebuilt motor about 60k on...
1-11 of 11 Results
Top