Jeep Enthusiast Forums banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-19 of 127 Results
  1. XJ Cherokee Technical Forum
    Greeting Jeepers; RE: 2000 Cherokee Sport w/66877 miles, No engine codes, in garage @ 30deg F, 1/4 tank of gas. Yesterday started w/remote, then died several times. Started manually w/foot on go pedal @ 1000 RPM, released foot & RPM fell sharply to 500, stumbled a tad, then increased to its...
  2. YJ Wrangler Technical Forum
    Hey all, Been a good while since I've been on since my WJ's and couldn't recover my old acct for some reason so starting new. Found myself a 2.5l 5sp 1990 YJ in pretty decent condition a few weeks back. ~84000Km/~52000miles on the dial, brought down from Canada at some point. Pretty stock from...
  3. XJ Cherokee Technical Forum
    I know I know... There are a million "XJ overheating" threads but I'm really at a loss here even after reading every forum I could find... I have a 1991 4.0, AX-15, XJ... I overheat while idling, but here's the catch... Everything is new on that car! Motor has 3k miles on it, entire cooling...
  4. TJ Wrangler Technical Forum
    How it started: took the car to the shop for a metallic sound which I suspected was from a worn out pulley bearing. Turns out it was the connection between the exhaust manifold and the exhaust pipe, the mechanic tightened it. He also loosened up a bit the accessory belt as it was a bit too...
  5. Jeep CJ Forum
    So, I have been crawling through the forum and I had a issue with my jeep having a strong strong fuel smell. So I read up that it can happen with clogged jets on the Carter BBD. So I took it off, cleaned it up and rebuilt it. The strong smell went away, but I still have a light fuel smell. I am...
  6. YJ Wrangler Technical Forum
    Working on a new YJ (1995 4cyl automatic) that wasn't running when I bought it. Previous owners said it ran but really rough, and it was due to the distributor being 180deg off. I popped off the valve cover, set to TDC (double checking the #1 valves were correct), reinstalled the distributor...
  7. ZJ Grand Cherokee Forum
    I ran into an issue a few months ago that has me confused. Here's the story from the top (sorry in advance for the novel): August '18: I replaced the intake plenum plate/gasket on the engine (using the Hughes engine kit). The intake was removed and the coolant system was drained. When refilling...
  8. TJ Wrangler Technical Forum
    I accidentally drained my battery last night by leaving my aftermarket heated seats plugged in the power outlet for a few hours. Needed a AC battery charger to jump it back to life. Now, my idle seems quite weak. As if it is about to stall when at idle. Any ideas why this is happening and...
  9. Engines & Drivetrain
    I'm no mechanic and this 4 cyl. 2.4 L 2003 wrangler has some ghosts, so it should be a fun project. I just towed it back to Salt Lake from the desert where a small shop and dealer both looked at it shortly without figuring it out. Any input is much appreciated :) Symptoms... 1) Won't start...
  10. ZJ Grand Cherokee Forum
    A few months ago my 1996 Grand Cherokee Laredo with the 4.0 I6 randomly stalled out on me. Took it to the closest mechanic as my personal one wasn't available. He said Crankshaft Position Sensor. Had it replaced at my personal mechanic along with my power steering hose and signal switch for...
  11. XJ Cherokee Technical Forum
    XJ starts normally then when starting to move it does some "coughfs"and after that apparently everything is fine, but idle misbehaves, sometimes it gets accelerated others simply completely stalls, last drive whenever I got to complete stop the engine died, it starts back again normally until I...
  12. Jeep CJ Forum
    OK. So I have an 86 CJ-7, 258 w/ Carter BBD. Typical setup. It acts like the carburetor is plugging off as has been described in many posts. So I removed and cleaned the venturi tubes, idle tubes, nozzles, etc. It runs fine for 5-10 miles, then starts to run rougher and rougher at idle, until it...
  13. YJ Wrangler Technical Forum
    Hey guys. It's been a while since I was last here asking for the blessing of the Jeep gods. I looked through some of the older rough idle posts and none of them really describes the problem I'm having exactly, but I got some tips of what to look at next. Here's the scoop: Started the Jeep this...
  14. Engines & Drivetrain
    First time poster, long-time reader of the site. Had to make an account because i couldn't find anyone else with the same problem. Background: I bought my '87 YJ from the original owner. he had a brand new Carter BBD carb put on it months before he sold it. I performed the Nutter bypass, and...
  15. ZJ Grand Cherokee Forum
    So my problem is that when i start the jeep cold it will run fine for a few minutes but then it will spit and sputter then even out again. Sometimes it will stall and it wont start without me holding the throttle down. This also happens while im in drive occasionally, ill give it gas to go but...
  16. XJ Cherokee Technical Forum
    So I have a 91 xj and the distributor started screaming at me last week. Bought a duralast gold that ended up being defective, returned it, got another, finally got it installed and the jeep fires right up. Sitting there idling it sounds like its gonna stall out, then seems to recover. Driving...
  17. XJ Cherokee Technical Forum
    Hey guys, I've looked everywhere trying to determine the cause of the sound my Jeep is making. Unfortunately the term "knock" always brings up the worst case scenarios and finding the correct result is pretty challenging. Anyways, here is the sound it is making: If I start it up cold, there...
  18. TJ Wrangler Technical Forum
    So I've had the jeep about a month now, upgraded from a TJ, I know jeeps make noises but some don't sound right. I have a chhh, chhh, chhh, chhh, chhh type noise and sometimes a little clank coming from my oil pan/ tranny area. I can BARELY hear it from the top but when riding around with the...
  19. Engines & Drivetrain
    I have a 1988 Jeep Cherokee XJ Laredo and I have been struggling with this cutting off issue a lot lately. Whenever I start it it cranks right up, but after I drive it or even move it a little bit, it starts to sputter and it completely shuts off on me. It starts right back up afterwords though...
1-19 of 127 Results
Top