Jeep Enthusiast Forums banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-17 of 17 Results
  1. WJ Grand Cherokee Forum
    Hey y’all First post & I’m need of some advice. The problem Got a 04’ 4.0l Cherokee hard start, have to crank engine about 5 seconds sometimes starts sometimes it starts and dies if I press the pedal once it fires it usually stays running. Also after a little drive the next start up seems...
  2. Engines & Drivetrain
    Okay, so i recently had my check engine light come on, i hooked my scanner up and it showed P0132. So i ordered a NTK Upstream Oxygen Sensor and replaced it. At the same time, I went ahead and took off the throttle body and cleaned the IAC and throttle body itself. I cleared the code and took it...
  3. TJ Wrangler Technical Forum
    Hey everyone, New to fixing my own jeeps, and looking for some advice. I have an 02 2.5L Wrangler. I've been having a problem with it idling high. At stop lights after it warms up, it kind of revs itself up to 2000 and goes back to 1500 at a constant up and down. Today I had to drive longer...
  4. KJ Liberty Forum
    My 2006 Jeep Liberty, 3.7L V6 had a battery die. I replaced the battery and then a few days later left something on that drained it. Didn't notice it for a few weeks because I was traveling. When I returned I tried to jump it and had to use ether to get it to start. I had a large back fire and...
  5. XJ Cherokee Technical Forum
    So I've been battling with my starting/stalling problem for months now. The issue is most of the time when I try and start it, I need to push the gas pedal all the way down for a few seconds in order to get her to start. Then shifting from park to reverse the idle becomes rough dropping to 200...
  6. ZJ Grand Cherokee Forum
    Greetings everyone! I've been meaning to register for a while now, so here we go. Picked up a 96 ZJ a month or so ago and so far so good besides a busted brake line. About 160,000 miles. V8 5.2L, automoatic. First Jeep so go easy on me! So here's my issue... About a week or two ago I was...
  7. ZJ Grand Cherokee Forum
    Hey guys I was experiencing the dreaded rough idle issue and took advice on how to address the issue. Cleaned the throttle body, replaced with brand new IAC and TPS. Upon startup after installation, my idle was REALLY high. Like 2000 rpm high:confused: it took a minute to settle down and then...
  8. ZJ Grand Cherokee Forum
    Howdy. to start off, im a bit new here, been scrolling thru all the zj forums, and thought I could use some insight. First off, I have a 95 zj 5.2L Just replaced plenum and had some EGR issues. before I replaced plenum gasket, jeep ran acceptably, i cleaned everything; iac, tps etc, during the...
  9. ZJ Grand Cherokee Forum
    Hi all! Does anyone out there know how to replace/rewire the tps and/or iac wiring? Are there any wiring kits anyone knows about? I have a 1998 ZJ 4.0L. Any help will be appreciated:)
  10. ZJ Grand Cherokee Forum
    96 Grand Cherokee V8: So I am having a combination of issues. A few weeks ago I blew a 20 amp fuse in the engine fuse compartment for the ignition system. A few days later the check engine light pops on and was reading P0155 02 htr code. I cleared the code and then yesterday the same fuse blew...
  11. ZJ Grand Cherokee Forum
    Okay my jeep idles rough when I put it into reverse or drive, the RPMS do drop.... When it is park or neutral it idles fine. So I replaced the IACV and it seems to have more get up and go going down the highway but did not fix the rough idle. I also cleaned the throttle body and all that good...
  12. XJ Cherokee Technical Forum
    I'm having a strange issue with a newly acquired 99 xj. Its a 4.0 and a auto. It is throwing two codes related to the downstream oxygen sensor, but it runs and drives perfectly fine otherwise. It starts, idles, shifts, drives normally with one exception. If I let off of the gas, and coast in...
  13. ZJ Grand Cherokee Forum
    1996 Zj 4.0 stock with 140,000 miles. I am not throwing any codes. About a year ago my Jeep sat for 7 months. I started it up twice a week give or take during the 7 months. I didn't drive it because I blew gears in my dana 35 ( I don't off road) learned my lesson about changing diff fluid...
  14. TJ Wrangler Technical Forum
    I've got a '99 4.0 and I've already replaced the IAC and cleaned the throttle body spotless. I know I have a crack in my manifold and I'm replacing it now, but I've had a crack in there for a LONG time and never had this issue. Could it be any other issues? I even disconnected the battery to...
  15. YJ Wrangler Technical Forum
    I just replaced the exhaust manifold gasket this morning. Had a high idle prior to replacement but now the idle seems slightly higher (about 2500-2800)....good news is no apparent exhaust leaks now. Help please! how do i check for vacuum leaks? Where is the IAC located on this jeep...
  16. XJ Cherokee Technical Forum
    My 98' Cherokee sport( 4wd, manual trans., 4.0L, 142k miles) has the strangest idle symptoms. When I start the car when the engine is cold, it kicks right over. It idles like normal for about 45secs, then at about 800rpm, the engine goes into this stumbling idle. It does this rough idle for...
  17. XJ Cherokee Technical Forum
    I recently replaced a transmission cooler line after the old one got a hole in it. When I replaced it and crank the vehicle it would not stay cranked. After I restart it a few times and give gas it will stay running. It is almost like it is idled too low.
1-17 of 17 Results
Top