Jeep Enthusiast Forums banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-20 of 493 Results
  1. YJ Wrangler Technical Forum
    Water pump exploded in a really bad part around where I lived so I had to drive an extra 3 miles overheated - I know, very stupid but I'd rather have a ****ed up motor than be robbed or dead so there's that Little rough and High idle RPMs - 1000 minimum but really around 1200-1500rpms Little...
  2. YJ Wrangler Technical Forum
    Water pump exploded in a really bad part around where I lived so I had to drive an extra 3 miles overheated - I know, very stupid but I'd rather have a ****ed up motor than be robbed or dead so there's that Little rough and High idle RPMs - 1000 minimum but really around 1200-1500rpms Little...
  3. Jeep CJ Forum
    Hello Friends, I was given this CJ in 2020 by my Father-in-Law. I have used it lightly for the last 2 years, mostly taking it out on nice days, or days when a bikini-top jeep made sense. My Father-in-Law got it a while back, and it was sitting covered for maybe 3 years prior to my ownership...
  4. WJ Grand Cherokee Forum
    My ongoing project has given me yet another issue (I live in Chicagoland- we get a lot of cancer here). '04 Grand Cherokee, 4.0L, in the middle of attempting an NP247 to an NP242J. Today I tried to remove my transfer case for 6+ hours. I had two other people with me and this thing has not...
  5. XJ Cherokee Technical Forum
    A couple days ago I started rolling the back window down and realized I was rolling the wrong one since I needed the front passenger window but when I tried to roll the back passenger window up, there was nothing. There was no noise or vibrating or anything. It was almost like the window was...
  6. WJ Grand Cherokee Forum
    I recently ordered an OME 2in Heavy Load Lift Kit, my stock drivers front shock has died. My front shocks from the order have showed up but the springs and the rear shocks have been delayed by quite a bit. Wondering if it's okay to replace the front shocks now to fix my issue, then replace...
  7. ZJ Grand Cherokee Forum
    Hey yall I have a 98 zj with a 5.9 magnum and it idles fines but when driving it will loose the gas pedal after about 25 yards if you push all the way down itll bog and wanna die but you can use the top of the pedal and it'll jerk any ideas? Already replaced throttle and crankshaft position...
  8. XJ Cherokee Technical Forum
    I got a 01 recently that kept losing power randomly on the previous owner. He also removed the lock cylinder for some reason (don’t have it). Replaced the battery ground to core support, and ground from the head to the body at the back of the the engine. Then we jumped the plug-in for the lock...
  9. Jeep CJ Forum
    Is there a write up already on the operation of this system. I don’t want to tear it if I can get it to work. The 85cj7 I just bought ( my first one) is in very rough shape but has more options than I have ever seen( ps,pb,ac,cruise, factory hardtop, side steps. But I think the were all...
  10. JK Wrangler Technical Forum
    So recently my wife's JK has been throwing codes for oil pressure high, oil pressure low. Recently replaced the oil cooler with an aluminum "upgrade" from a 2014/15 and replaced the oil pump and oil pump pressure solenoid. Keep getting codes for the sensor, even though it's a new mopar sensor...
  11. YJ Wrangler Technical Forum
    We’re installing an arb locker in the front axle (Dana 30) and I was wondering what I should do with the vacuum line for the 4wd? If anyone knows it’d be much appreciated.
  12. WJ Grand Cherokee Forum
    I I unbolted the overflow tank not taking note of where the hoses go. I know ofcourse one goes to the radiator by the cap. But as to top or bottom I don't know as there's also another hose on the overlfow tank I have no idea where it goes!
  13. Jeep CJ Forum
    Changed the fuel filter, oil and transmission fluid started running a little better after that, got a bds 2.5” suspension kit on the way because the current set up is completely shot but I’m really concerned about the idle issues I’ve been having when giving it gas it sounds pretty good but when...
  14. Jeep Wrangler Forums
    Hi...I did a super stupid thing yesterday and accidentally dropped the gold bracelet my boyfriend got me down the front defrost vent. We tried for about an hour last night to try and get it out, but no luck. We heard it move once, but nothing since I drove it to school today. I have a 2021...
  15. WK Grand Cherokee & XK Commander Forum
    Okay so I bought new thermostat, 18 psi rad cap (previous owner had 10psi cap on), and thermostat sensor. U0404 and both 'possible problems' codes popped up today after a two min drive. Any thoughts?
  16. Jeep Cherokee & Comanche Forums
    Just bought a 1988 Jeep Cherokee yesterday, today the driver's side seatbelt buckle broke. It won't click in. My question is if I can swap it out with one in the backseat? Or if there's a way to fix it. I've called all the junkyards in my area no one has a replacement. Checked on line and...
  17. Jeep Engineering - Q&A Archive
    Hi does any one know what else todo to fix low beam head lights on 06 Jeep Wrangler LJ. I have replace the lights assembly and fuse on glove compartment also check fuse Andre the hood and looks ok but low beam lights still don’t work everything el work Need help please .
  18. TJ Wrangler Technical Forum
    Recently picked up a 97 Wrangler SE. I swapped all the body lights with LEDs and learned about the hyperflash issue. I did the YouTube university dive and picked up an EP26 relay on Amazon popped it in and boom problem solved no hyperflash…. Except for now the relay simply won’t disengage. It...
  19. ZJ Grand Cherokee Forum
    Hello, I just purchased a Jeep Grand Cherokee Laredo 4.0 three weeks ago from a private seller. It has 91k on the odometer, and the transmission was replaced 7 years ago at 81k. The owner kept this thing in his garage and daily drove something else, so it's in awesome shape cosmetically but I...
  20. TJ Wrangler Technical Forum
    I have replaced injectors, coil packs, plugs, flushed my rad, and replaced my thermostat and temp sensor and I still can’t find the problem causing my misfire. It’s only a specific cylinder 1 misfire. Also I just replaced the 02 sensors and I’m getting the current codes.P0442, P0155, P0135, and...
1-20 of 493 Results
Top