Jeep Enthusiast Forums banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

41-59 of 200 Results
  1. Audio, CB & Ham Radios, GPS, & Electrical
    I have a 2003 tj sport that came with the sub in the sender console. A little while after purchasing the vehicle I notice the sub was blown (bunch of crackling and popping etc.) And I replaced it with one of the quadratec bolt in one's for $90. That one lasted about 6 months before it quit...
  2. WK Grand Cherokee & XK Commander Forum
    List of issues that started at the same time in my '07: 1) Driver side door controls do not function including front windows, side mirrors, window and door locks. 2) Interior dome light does not function 3) Stereo must be manually shut off after ignition is turned off and key removed Any ideas?
  3. ZJ Grand Cherokee Forum
    I was driving down the road and my ZJ had a stroke. All electronics shut down. No guages, no spark, fuel pump not shutting off, no CEL. Brought it to my mechanic and he tested every sensor and replaced napa computer under warranty. 3 weeks pass by and still no solution. The mechanic is running...
  4. XJ Cherokee Technical Forum
    I have a 99 cherokee XJ with 31x10.50 tires and a few other mods. Ive been able to fix nearly everything on it thats gone wrong such as, problems with misfiring, grinding rear end, extreme vibration and the driveshaft shooting out from under the jeep, problems with the A/C and so much more but...
  5. YJ Wrangler Technical Forum
    Here Goes Driving down the road and my 1988 jeep dies. Nothing at the ignition switch. Seemed like the battery was dead but lights were bright. I can bump the starter at the starter relay and it turns over perfectly. Found a burnt wire on the starter relay ( centre top ). Fixed the...
  6. Jeep CJ Forum
    Howdy, this is tyler. I bought my cj about 3-4 months ago and have only now been forced to start working on the wiring. the vehicle is cranked via a button under the dash that is wired to the starter solenoid. (the starter solenoid has been used as a junction by previous owners and is festooned...
  7. ZJ Grand Cherokee Forum
    Hello. I have had my 95 Grand Cherokee for about 8 months now. This morning I went out to head to work and the Jeep started up just fine. I had to run back in for a few minutes so I turned off for a few minutes. When I came back out and tried to start it I had no response from the starter. The...
  8. XJ Cherokee Technical Forum
    Hi! This is my first time posting on this forum, so forgive me for any messups or anything. Anyways, I just got my brothers old 1998 Jeep Cherokee Sport, and I love it. It works fine, although the only current problem right now is the Instrument Cluster. Most of the time it doesn't work, and...
  9. TJ Wrangler Technical Forum
    newbie.......restored the jeep, having problems with the wipers activating when I turn on headlights. When brights are on, the left turn signal indicator is dimly lit up. Checked grounds, replaced multi function light switch, also clock spring( another issue). Any help greatly appreciated!
  10. Engines & Drivetrain
    My engine starts and runs perfectly and doesn't have any change when I have my CB radio, FM radio, or windshield wipers on. As soon as I turn on my headlights though, the engine starts to cough constantly and runs really rough. It doesn't stall out but I'd like to fix it. Any ideas on what is...
  11. WK Grand Cherokee & XK Commander Forum
    Hi everyone, Here's the lowdown... A couple years ago, I replaced the climate control unit with one with new bulbs. All was good in the land of Jeeping. The only other electrical related work I've done is that I replaced the ignition switch back in December because I'd randomly get all my...
  12. YJ Wrangler Technical Forum
    Hiya, Long time listener, first time caller.... by that I mean I've often skimmed these forums over the years (as I'm a long time Jeep enthusiast) but never really signed up till today. Although to get down to business I'm curious if anyone has any insight on an issue I've been having with my...
  13. YJ Wrangler Technical Forum
    Hey guys, I just replaced the heater core on my jeep yesterday, everything went swimmingly, but now for some unknown reason the jeep won't start. I turn the ignition and the starter doesn't even click now. The jeep had absolutely no problems running pre-Heater Core exchange, and I didn't touch...
  14. ZJ Grand Cherokee Forum
    Hi guys, I've owned my '98 grand Cherokee for 10+ years. It has been trouble free until 2013 winter. It started stalling out of nowhere but would usually start right back up. Diggin on the internet I found instructions to resolder contacts in the PCM. This fixed the issue and all has been great...
  15. YJ Wrangler Technical Forum
    So I changed out my water pump and the oil and left it in the garage. The next day i took it for a 20 leisurely drive and parked it again no problems. 20 min later i tried to start it again and it wouldnt start. I poked around and found there is no spark no fuel. The fuel pump doesnt even prime...
  16. Audio, CB & Ham Radios, GPS, & Electrical
    Its a 50" curved LED off ebay and works great but when the engines on its has a faint whistling/buzzing i can hear even inside when driving. But when the engines off its silent. Is it something with the alternator? Power wire? A buddy said i needed maybe a power filter inline of the power wire...
  17. ZJ Grand Cherokee Forum
    Hello, I bought a ’98 Grand Cherokee this summer (Limited, automatic). It has an electrical leak which is a huge problem. A previous owner installed a switch on the battery, so every night I have to pop the hood and disconnect the battery. It seems to be temperature-dependent - I didn’t have...
  18. XJ Cherokee Technical Forum
    Have a 99 xj 4.0. Went to start and no power at all no lights radio. Took out and checked all fuses, they were fine and started fine only radio reset. Drove to work fine. On the way home volts went to 19 made it home would not restart. Went out the next morning started right up. Been reading...
  19. Jeep CJ Forum
    I am having a problem with my 84 CJ wiper motor. The motor will not work. I am getting 9 volts to the switch and 9 volt to the motor. If I jump it straight from the battery it work fine. I am assuming I am not getting enough voltage. Any suggestions?
41-59 of 200 Results
Top