Jeep Enthusiast Forums banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-15 of 15 Results
  1. WJ Grand Cherokee Forum
    Ok so this is a new one to me but my 04 laredos interior lights seem to have connection or something loose in the ceiling making my dome lights turn on. whenever i hit a bump of even start my car they get stuck on and i have to repeatedly hit different areas above the drivers side front and rear...
  2. XJ Cherokee Technical Forum
    Having problems with 2001 Laredo. Had issues about a month ago with stalling out while driving and when stopped. Replaced fuel filter which seemed to do the trick. When it started getting cold started having the same issue. Finally took it to a mechanic and had spark plugs and wires, ignition...
  3. ZJ Grand Cherokee Forum
    Got a 1993 zj with the 5.2l, beater with a heater. Replaced the fuel pump only to have it quit out 2 blocks down the road. Confused and embarrassed, I had it pulled home and started chasing the gremlin. After jumpering the relay and wiggling wires, I found the 30 dollar fuel pump I put in it had...
  4. JK Wrangler Technical Forum
    2015 heavily modded JKUHR with 99,000 miles. I’m running a genesis dual battery setup with 2 group 34 odyssey batteries. The batteries were installed in 2020. In the last few months I’ve noted a couple of issues such as: 1)The Carobotor aftermarket dash constantly flashes between light and...
  5. KL Cherokee 2014 & up
    I’ve been having a slew of problems with my 2016 Jeep Cherokee, but the alligator closest to the boat is a battery drain. After the engine is off and key is removed, something is sending a signal to turn on the lights on my Instrument Cluster. Right before it turns on I hear a “tick tick tick...
  6. Advanced Jeep Tech
    I’ve been a long time lurker on these forums. Y’all are lifesavers considering the amount of free and useful advice I’ve snagged from this site. Now it’s my turn to ask a question. I’ll try to keep this as brief and to the point as I can but I apologize for the overflow of information coming. Im...
  7. WK2 Grand Cherokee Forum
    I'm having a strange problem with my WK2 2013, I was driving from work and stopped at a shop, as I was getting out of the car I was distracted and for some reason pressed the start button without thinking, which shouldn't have been a problem but as I did it I heard a loud thud, almost like the...
  8. ZJ Grand Cherokee Forum
    Hello group, need desperate help! All my center counsel doesn't work anymore. This includes the radio, VIC, air controls, and also the instrument cluster lights also doesn't turn on! I can not figure it out. I wouldn't mind if the others didn't work but I need the air controls working for the...
  9. ZJ Grand Cherokee Forum
    Alright, I have a 98 5.2 zj that will start fine, run for about 2-3 secs then die out. I've tried replacing damn near every sensor. New battery, leads, fuel pump, crankshaft position sensor, IAC, BCM, PCM, MAP sensor, spark plugs and cables, cleaned out tank and fuel lines, throttle body clean...
  10. Jeep CJ Forum
    So I finally have my 304 all back together. After head gaskets and valve stem seal replacement. I feel confident that everything is sealed and back together correctly. I rebuilt the motorcraft 2 barrel new cap and rotor. Battery and coil test good. I’m at tdc on compression stroke lined up with...
  11. ZJ Grand Cherokee Forum
    I am at a loss because I cannot seem to find the right info. Alternator correct and good. Battery charged and good. Starter correct and good. Every single time I try to start this 1996 ZJ 5.2, it clicks once, sometimes twice, and then all power is cut. I let it rest for sometimes 2 minutes, and...
  12. XJ Cherokee Technical Forum
    I recently replaced the battery on my 92' Cherokee after it ultimately died, but now that it's back up and running again my stereo seems to have no power. I checked my fuses and all of them seem to be fine. The only thing that was odd to me was the fact that the "Power Clock" fuse seemed to be...
  13. WJ Grand Cherokee Forum
    Hi, i know this has been covered before but i appear to have a strange gremlin in my Wj left indicator wasnt working, right and hazards were fine. pulled out the relay found a couple of cracks so re-soldered all connections, placed back into slot, nothing. No hazards or indicators (still flash...
  14. JK Wrangler Technical Forum
    Hi everyone, I've been having some issues with the audio cutting in and out every three seconds (on 3, off 3, on 3, off 3 etc). This pattern repeats across all inputs from radio, CD, bluetooth including when I take calls over bluetooth My audio system is still the factory Alpine premium system...
  15. WJ Grand Cherokee Forum
    I have a 2002 Jeep Grand Cherokee with 162,000 Miles. It was have a problem shifting from 1st to 2nd. It shifted but delayed. I pulled the pan, and found a busted accumulator spring. I replaced the spring, the governor pressure solenoid, the governor pressure sensor and put on a new filter. I...
1-15 of 15 Results
Top