Jeep Enthusiast Forums banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-20 of 32 Results
  1. WK Grand Cherokee & XK Commander Forum
    From what I read there is no straightup solution for this particular problem. Hence i'm here for a meeting of the minds, and to somewhat document the journey. Spark: Yes (spraying fluid through the intake gets the jeep to run for a few seconds). Pulse: Yes *updated* Crank: YES Start/Run: NO...
  2. WK Grand Cherokee & XK Commander Forum
    Hello Everyone, about 2 months ago my 2008 CRD wouldn't start after stopping to fill up tank. Dash lights on but no crank at all... I removed the key and tried starting again successfully but very strong electric smell started permeating from the air vents for a while. This morning, same thing...
  3. Engines & Drivetrain
    Hello all, I need help I have a Jeep Liberty 2002, the engine was bad so I bought a 2004 engine, I swap the reluctor ring and the timing chain set (I keep using the 2002), I swap all sensor using 2002. And the engine works well in the beginning, but when I took a highway to test the Jeep...
  4. TJ Wrangler Technical Forum
    2004 TJ, 4.0, NV3550. Jeep starts up and runs great for several minutes but then begins to sputter and die. Codes are as follows: P0353 IGNITION COIL 3 CIRCUIT, P0352 IGNITION COIL 2 CIRCUIT, P0351 IGNITION COIL PRIMARY CIRCUIT, P1391 LOSS OF CAMSHAFT CRANK. I can disconnect the battery and...
  5. TJ Wrangler Technical Forum
    Hey guys, so i have an 02 TJ and over the last month or so, it hasnt been cranking over sometimes. Sometimes i get in the jeep and it starts up just fine. Yesterday, it started just fine, went to jump in it today and it just clicks and does nothing. All the gauges come on and the radio comes on...
  6. XJ Cherokee Technical Forum
    So ever since i bought this 2000 Jeep Cherokee, 4.0L 6 cylinder engine, It's been an absolute nightmare. everything has gone wrong. This time, the car will not start. i just got an oil change. The engine is not turning over. There's just a click. We already replaced the starter so thats not the...
  7. XJ Cherokee Technical Forum
    I've noticed within the last 2 weeks if I let my '96 XJ sit for more than a few hours, if I go to start it, it will take longer to turn over. However it doesnt sit and crank and crank. It takes a few more seconds than if I had just parked and started again. I wonder if this is a problem with my...
  8. YJ Wrangler Technical Forum
    Hopefully someone here can provide me with some clarifications on my problem. I started hearing some faint "chirping" sound coming from the distributor cap area about 2 weeks ago when my Jeep is idling. The chirping will increase as I press the throttle. Then today, the chirping became more of...
  9. ZJ Grand Cherokee Forum
    Ive been trolling these forums for all my jeep repair needs. However I am now in dire need of assistance. My Jeep, 96 ZJ, V8, 5.2L, automatic, all stock I'm sure, will not start. I was driving home from work, Thursday night, luckily sort of, my truck dies when I was about four houses away from...
  10. XJ Cherokee Technical Forum
    So, started pulling off the balancer like normal, and the balancer cracked off. Literally the center is still stuck on the crank, at this point I have no idea what to do. :brickwall If anyone can help that'd be great, this is gonna end up being a real pita.
  11. XJ Cherokee Technical Forum
    I can hear the fuel pump but there's no pressure. Got it to fire up using starter fluid in the throttle body. The pump runs the entire time the key is in, and stood when I crank it. There is about a quarter tank of fuel.
  12. TJ Wrangler Technical Forum
    After replacing my crank position sensor 3 times, it still won't start. I had a bad wire in the connector and the sensor is now hard-wired. The signal wire gets 5vdc output even when I hand crank the engine. (All the way to the PCM). Do I need to look for a HZ signal in the 5vdc? I read where...
  13. WK Grand Cherokee & XK Commander Forum
    2008 WK laredo v6 with similar issue as Joe93 http://www.jeepforum.com/forum/f67/weird-06-grand-starting-problem-1001116/ I drove the jeep home from work on monday with no problems, parked it and went on a short vacation to the shore. Came back today (3 days later) Jeep wont start.:thumbdown...
  14. XJ Cherokee Technical Forum
    All, My 2001 Cherokee has not started since December of 2013. I got the "No Bus" indication on the odometer screen, and I replaced the CPS or crankshaft position sensor. I purchased the CPS from the Jeep dealer, so I know it's a quality part. I replaced it, connected it, and cranked it. Still...
  15. YJ Wrangler Technical Forum
    I've learned a lot from this forum, and just wanted to post this in case it helps someone in the future. I was having intermittent starting issues. Some days the engine would start right up, some days I would get no crank at all. I thought the starter motor was bad, because I could knock the old...
  16. TJ Wrangler Technical Forum
    Ok first off, I don't know much about mechanical work, but I'm working on it. But recently my Jeep started acting up. It only ever happens when I'm initially cranking it up, most of the time it does 2 turns and then has a short lag before it finishes turning to crank up...which wasn't too big of...
  17. XJ Cherokee Technical Forum
    Hi to all, im new at this and don´t know much about mechanics, so I think some of you guys can help me with this strange startup issue. My XJ 93 cranks and it tries to start, but goes off, after the second try it stays on for a few seconds at no more de 500RPM and then goes off, at the third try...
  18. XJ Cherokee Technical Forum
    Jeep started up fine today, drove it around a lot, but when I started it up for about the 5 time today, with the engine warm, it struggled to start and when it finally did fire up, it died immediately. I tried it again and held the throttle open for about 30 seconds. THEN it would stay running...
  19. XJ Cherokee Technical Forum
    So my old battery was gone. I got a new one with 750 cold cranking amps. It worked okay when just installed the battery, I suppose this was because of the pre charge. I drove it around a little bit. That night, I tried to start it again. The gauges all turned on but as soon as I tried to crank...
  20. Engines & Drivetrain
    my jeep is a 2002 wrangler with a 4.0 and 5-speed, has 100k miles. so my jeep started off with a misfire-type knock. i finally decided to get into the engine's internals and found that a valve lifter was damaged, causing the pushrod to not work. this did not allow an intake valve to open...
1-20 of 32 Results
Top