Jeep Enthusiast Forums banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-18 of 58 Results
  1. YJ Wrangler Technical Forum
    Hi Everyone, Here is the issue: I have an 85 CJ-7 with the 258 with the MOPAR EFI kit and 5 speed (that's why I'm in the YJ forum). The jeep was running great one day, and wouldn't start the next. I checked the CEL codes and had an 11 code. I replaced both CPS and CAM sensors, but nothing...
  2. TJ Wrangler Technical Forum
    Hello. I have a 2001 TJ, 4L automatic. Engine has 125K miles. Lot's of stuff has been replaced, including a rebuilt transmission about 20K miles ago. Symptoms About a year ago the engine started throwing p0300 codes. Crankshaft Position Sensor (CPS) problem or misfires on various cylinders (300...
  3. XJ Cherokee Technical Forum
    I've seen plenty of threads where diagnosing a bad crank position sensor is the topic. I've got the diagnostic part down cold. The CPS on my 2000 XJ 4.0 automatic has gone bad FOUR TIMES in ONE YEAR. That's no typo. FOUR TIMES. It's starting to drive me nuts. Not just because it's such a...
  4. XJ Cherokee Technical Forum
    Been trying to figure this thing out on my own and by looking through other posts, which have been extremely helpful in steering me in the right direction so far. Any help would be greatly appreciated! Before it totally stopped running, it would sometimes die on me after running for awhile. I...
  5. YJ Wrangler Technical Forum
    Ive recently replaced the frame on a 1981 CJ5.. It has a mopar EFI fuel injection conversion kit installed.. The jeep was running great before the frame restore.. However, now when i try to start the jeep, it turns over, but will not fire.. i hear the fuel pump, fuel pressure is at the...
  6. Jeep Buying Forum
    This is just a heads up. The crank position sensor on my 2013 JKUR was not covered under the 7-year drivetrain warranty. Here's a quote from the email I received from FCA about my out of pocket expense. "...the crank position sensor is an electrical component as it does not run through the...
  7. ZJ Grand Cherokee Forum
    ***HUGE UPDATE*** It started today and STAYED running! I am posting an update reply explaining the details. Let me start off by saying, any help will be appreciated... Okay...a few weeks ago my 1998 Laredo Special - 4.0 Straight 6 started to drive pretty rough. From a stop I would have to put...
  8. XJ Cherokee Technical Forum
    So I have searched the internet until my eyes started bleeding over this: How does one test - and I mean definitively test - an IAC and a TPS on a 1999 (late model) 4.0L - those threads on renix 4.0L's are all wrong for me - not the right wire count, different sensors, etc. I don't want to...
  9. ZJ Grand Cherokee Forum
    I've a '96 ZJ with a 5.2. The transmission is out for overhaul and I note the crank position sensor gasket/grommet is wildly mangled ( I thought it felt weird when I replaced the CPS). I'd like to close that hole up. Does anyone know a source for that bit of rubber? The last two evenings of...
  10. XJ Cherokee Technical Forum
    I had some issues with an intake gasket not sealing. All of those issues have been resolved. However in my haste to test things after reassembly I cranked it over with the CPS unplugged and it messed up my timing. The distributor has been undisturbed and the timing chain has also been...
  11. XJ Cherokee Technical Forum
    Have a 99 xj been running great. Parked it after driving went to restart and just cranked and cranked. After about 5 tries it started. No issues for a week,or so then the same thing happened. Then a few days later just stalled at a red light. Restarted after a few attempts. Last one was running...
  12. ZJ Grand Cherokee Forum
    I've done hours of research and can't confirm if my problem is actually the cps. My jeep has been running great and today all of a sudden it dies as I'm driving. Now I have no gauges working, cranks with no start, no fuel pump prime, no spark. All the signs of a bad cps sensor but when I...
  13. XJ Cherokee Technical Forum
    I have to drive from Florida to Pennsylvania in two weeks and as of right now my jeep does not run. It all started 2 months ago when I let a friend drive it and he came back and said it had over-heated. Sure enough, it had, so I went about replacing the t-stat, water pump, and ALL fluids. I...
  14. TJ Wrangler Technical Forum
    Hey everyone, I've been reading here for a while but just joined up in the hopes of some diagnostic help. I've read through a number of posts detailing similar issues but after testing/replacing a few different components I thought it was time to post for some specific advice. I have a 1997 TJ...
  15. ZJ Grand Cherokee Forum
    Recently my 98 4.0 started dying out at stop signs and when sitting in parking lots etc... The RPMs go from 700 to 1200 then to 400 and it dies. The code it pulled when it died was P0340 -Camshaft Position Sensor. I looked at all parts stores and its like this part doesnt exist. I went and...
  16. TJ Wrangler Technical Forum
    OK Jeepers, I've been beating my brains out with this one for 3 MONTHS now...Ugh... Sounds like a simple CPS problem right? Negative Johansen. I have replaced the CPS, CKP, Ignition coil, PCM, and Ohmed out every wire at the PCM that has anything to do with igniton, and checked all my...
  17. XJ Cherokee Technical Forum
    Hey guys, I know there are a ton of posts about CPS issues, I have read a bunch of them on here, but I believe this is a little different. I know that both my Crankshaft Position Sensor and my Camshaft Position Sensors are shorted out. I tested them, they failed, I replaced them with brand new...
  18. XJ Cherokee Technical Forum
    So here goes, key ignition switch snapped I had to hot wire it to get it home, then my gf had to drive to work next thing I know it's 4 months later before I break down and get the key switch problem is it was too late, I f ed it up by hard wiring it for so long. I got the new key In , guess...
1-18 of 58 Results
Top