Jeep Enthusiast Forums banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-20 of 21 Results
  1. General Jeep & Off-Road Equipment
    So I just bought a 2003 Jeep Wrangler TJ SE 2.4L 4-cylinder and after a couple days of driving, I noticed the check engine light came on. There are multiple codes that come up during testing, which include 0340, 0123, 0320, 0352, and 1391. It runs fine for the most part. The check engine light...
  2. Engines & Drivetrain
    So I just bought a 2003 Jeep Wrangler TJ SE 2.4L 4-cylinder and after a couple days of driving, I noticed the check engine light came on. There are multiple codes that come up during testing, which include 0340, 0123, 0320, 0352, and 1391. It runs fine for the most part. The check engine light...
  3. TJ Wrangler Technical Forum
    This one's been a month's long doozy. I'll try and make it quick: Starting Aug. 2019, my 2000 Jeep Wrangler Sport MT 4.0L went dead on the highway while I was going about 40 mph. Immediately, a check engine light threw a P0340 code for the camshaft position sensor. I replaced the sensor, all...
  4. General Discussion
    Hello, I am looking to see if anyone knows the location for the camshaft position sensor on a 2012 Grand Cherokee Laredo. I had my check engine light code read at a local shop. The code is P000B (Bank 1 Camshaft 2 position slow response). The code recommends changing the camshaft position...
  5. TJ Wrangler Technical Forum
    2005 Jeep TJ X 4.0 My Jeep is my daily driver and last week when I went to leave work my Jeep would not start. We were able to narrow the problem down in the parking garage to the fuel pump. Had to loosen the fuel rail as the 05 does not have a schrader valve. We were able to get the jeep to...
  6. WK Grand Cherokee & XK Commander Forum
    Hey Guys and Gals, I recently bought a 2007 Jeep Grand Cherokee with a 3.7L engine on it. I haven't heard great things about these engines but it was a really good price and the car was well taken care of. Well, it was running perfectly until one morning it just cranked, and cranked and...
  7. XJ Cherokee Technical Forum
    My jeep has been running good but one day I go out to start it and it starts right up. Then after like 20 seconds of idling it just shut off. Didn't bogg out or anything. Did some research and everyone said replace the crankshaft position sensor, so I did. Still didn't start. The pcm tests good...
  8. XJ Cherokee Technical Forum
    Hey everyone, So I just got a check engine code reading P1391. It is for either the Camshaft or the Crankshaft position sensors. About 6 months ago I changed out the Crankchaft position sensor myself, with a mopar part, so it shouldn't have failed already... I looked up the camshaft position...
  9. Engines & Drivetrain
    Hi. My xj was initially sputtering on acceleration, to the point where the CEL was reading the apparantly common crankshaft/camshaft or coil code. If I drove it a bit, turned it off and on, it would eventually run smooth. I decided to replace the camshaft sensor since it seemed easy...
  10. XJ Cherokee Technical Forum
    Hi all, just bought my first Jeep, 98 XJ cherokee. After first time on interstate, check engine light came on, trouble starting etc. I cant remember the code, but its the crankshaft position sensor. Question, how long before this problem leaves me stranded. Since then, 3 days ago, no trouble...
  11. YJ Wrangler Technical Forum
    I've had my jeep sitting out at some weekend property and between visits recently some mice chewed up some wires under the hood causing the engine (94 2.5L) to not fire. I believe I've pinpoined the problem down to the camshaft position sensor wire coming out of the distributor being chewed...
  12. TJ Wrangler Technical Forum
    Howdy! I've been chasing down a misfire issue with my '01 TJ 4.0 (I have the blinking/flashing CEL), and I've got a question for you fine folks...but first, a bit of background story. I went to the beach back in July, drove in the TJ in 2wd & 4wd Hi through sand, mud, some 2-3 foot water, etc...
  13. ZJ Grand Cherokee Forum
    Back again guys, I hope this isn't a useless new thread but here goes.... Going to pull out of the driveway in my 98zj 5.2 and it died. tried starting again and no go. it turns over but no start. i checked the fuel pump and fuel bar and its got good pressure and fuel at the injectors. One...
  14. TJ Wrangler Technical Forum
    my 05 wrangler is acting up something terrible....its the 4.0 litre 6speed. while driving at any random speed sometimes it will stutter a couple times and keep running or it will shut shut off completely. keeps throwing a camshaft position sensor code. already replaced it and checked my...
  15. XJ/MJ Cherokee Non-Technical Forum
    I know little to nothing about auto repair so please read with patience. I just purchased 1999 Jeep Cherokee Sport 4x4 4.0 Liter Inline 6 Cylinder 82,500 miles. My jeep normally takes 3 times to start. I had the engine light go on a day after I passed smog. (kind of lucky) I replaced the...
  16. XJ Cherokee Technical Forum
    I'm pretty overwhelmed at the amount of stuff I've done to get this car to start, and looked over the formns here for the past few months, so I've decided to join and once I get this thing started post up some tutorial on how to do basic car fixes with my specific model of Jeep Cherokee. So I...
  17. TJ Wrangler Technical Forum
    I've got a repetitive problem that I CAN NOT solve. The errors for the check engine light gives me misfires on 4 out of 6 cylinders, a bad ignition coil pack, and an error with the CMP sensor. I've changed the coil pack and plugs 3 times. It runs great for a little while, then I experience...
  18. TJ Wrangler Technical Forum
    It all began when my '04 Wrangle wouldn't start at the mall. I called AAA and they came out and the guy looked at it and had me crank it over. At the same time he rapped the skid plate under the gas tank three times and had me try again. It started! He said it was the fuel pump. Made sense...
  19. TJ Wrangler Technical Forum
    I'm on my phone so please forgive. I threw a code 12 and 54. I thought it was a bad crankshift sensor cause would run great until hot. Thought maybe it wad a bad connection. But code 54 is cam shaft sensor isn't it?
  20. TJ Wrangler Technical Forum
    so i was driving home yesterday and my jeep died at a red light. it cranked back up but did not want to stay cranked without giving it gas continuously. tried to crank it today and it turns over and over but wont crank. i checked the fuel at the pressure port under the hood and it was getting...
1-20 of 21 Results
Top