JeepForum.com - Search Results
Advanced Search
Showing results 1 to 20 of 43
Search took 0.01 seconds.
Search: Posts Made By: DonBC
Jeep Forums: MJ Comanche Technical Forum   04-24-2016, 06:34 PM
Replies: 5
Views: 1,826
Posted By DonBC
I just had my valve cover off to replace the...

I just had my valve cover off to replace the gasket so I did cut off the fluted tubes as suggested in above posting. The tubes already had a hole drilled in them. I don't have a lot of blow over to...
Jeep Forums: MJ Comanche Technical Forum   01-23-2016, 05:28 PM
Replies: 7
Views: 1,191
Posted By DonBC
This was an old post but it came up when I did a...

This was an old post but it came up when I did a search for "water inside the cab" and I thought I should bump it up. It described my problem exactly. Wet floor on the driver's side and problems with...
Jeep Forums: MJ Comanche Technical Forum   11-24-2015, 12:52 PM
Replies: 17
Views: 1,596
Posted By DonBC
Sorry Tex06, I missed that. Mine has been running...

Sorry Tex06, I missed that. Mine has been running great lately and my stutter may have been caused by bad terminals in my fuse block in the cab. Many of my fuses were corroded and not making contact....
Jeep Forums: MJ Comanche Technical Forum   11-22-2015, 01:42 PM
Replies: 17
Views: 1,596
Posted By DonBC
I still say to try a new coil. They are not that...

I still say to try a new coil. They are not that expensive and can produce similar symptoms if they are going bad.
Jeep Forums: MJ Comanche Technical Forum   11-19-2015, 11:29 AM
Replies: 17
Views: 1,596
Posted By DonBC
Sorry that no one had responded sooner. I hadn't...

Sorry that no one had responded sooner. I hadn't checked the site for a while. I was experiencing similar problems with my 89 Comanche. Was it fuel or electrical? I too suspected the TPS but they are...
Jeep Forums: MJ Comanche Technical Forum   08-05-2015, 06:16 PM
Replies: 7
Views: 1,251
Posted By DonBC
I finally had time to see what was wrong with the...

I finally had time to see what was wrong with the turn signals, brake lights, radio, etc. All my problems were caused by very corroded fuses. Three even left the blades behind when I pulled them out...
Jeep Forums: MJ Comanche Technical Forum   05-23-2015, 05:01 PM
Replies: 7
Views: 1,251
Posted By DonBC
Blower still works. My radio is also not working...

Blower still works. My radio is also not working but it stopped work long before the brake and turn signal lights quit. I have to start checking grounds and fuses. I will probably pull the drivers...
Jeep Forums: MJ Comanche Technical Forum   04-30-2015, 11:32 AM
Replies: 7
Views: 1,251
Posted By DonBC
I am having the same problem. No brake lights and...

I am having the same problem. No brake lights and no turn signal lights. I haven't had time to try and trouble shoot the problem. I will post a solution when I sort out the problem.
Jeep Forums: MJ Comanche Technical Forum   03-09-2015, 02:41 PM
Replies: 6
Views: 1,197
Posted By DonBC
I have had a similar problem with my 89 Comanche....

I have had a similar problem with my 89 Comanche. My problem is usually in the fuse block on the fire wall in the cab. The fuse that affects the instrument panel and the buzzer related to the...
Jeep Forums: MJ Comanche Technical Forum   08-15-2014, 06:07 PM
Replies: 5
Views: 1,465
Posted By DonBC
You might get off lucky. I did my front brakes...

You might get off lucky. I did my front brakes (rotors, calipers, pads, flex hoses) and then went to bleed the brakes. The bleed screws for the rear cylinders would not break free. I did get the...
Jeep Forums: MJ Comanche Technical Forum   07-06-2014, 05:09 PM
Replies: 6
Views: 1,348
Posted By DonBC
I would expect that it is not the fuel pump. When...

I would expect that it is not the fuel pump. When they quit they usually don't restart. Try the relay swap first. You don't have to drop the tank or skid plate (if you have one) to remove and replace...
Jeep Forums: MJ Comanche Technical Forum   06-10-2014, 09:53 PM
Replies: 1
Views: 1,245
Posted By DonBC
This sounds like the problem that I had with my...

This sounds like the problem that I had with my 89, 4.0L. My problem was the EGR valve solenoid. It is mounted on the left fender and has electrical connections and vacuum connections on it. If you...
Jeep Forums: MJ Comanche Technical Forum   05-21-2014, 10:20 PM
Replies: 1
Views: 798
Posted By DonBC
Have you checked your rear 'U' joint? A bad 'U'...

Have you checked your rear 'U' joint? A bad 'U' joint can make some noise and is a lot cheaper to fix than a rear dif.
Jeep Forums: MJ Comanche Technical Forum   05-12-2014, 10:01 PM
Replies: 5
Views: 4,480
Posted By DonBC
I just picked up a set of bucket seats from a 2dr...

I just picked up a set of bucket seats from a 2dr Cherokee to replace the bench seat in my Comanche. My butt was getting closer to the floor and my headroom was getting greater so it is time for a...
Jeep Forums: MJ Comanche Technical Forum   04-15-2014, 01:54 PM
Replies: 3
Views: 1,336
Posted By DonBC
Mine is set up that way. There is a indentation...

Mine is set up that way. There is a indentation on the front of the bench seat to allow the seat to move forward at the shifter console area. The frame of the seat back broke on mine and I picked up...
Jeep Forums: MJ Comanche Technical Forum   03-20-2014, 06:51 PM
Replies: 5
Views: 3,109
Posted By DonBC
I picked up a solenoid valve for $20 and it...

I picked up a solenoid valve for $20 and it solved the problem. $135 new. I had to visit 5 salvage yards before I found a salvage yard that had a Cherokee of that vintage with the correct part. The...
Jeep Forums: MJ Comanche Technical Forum   03-16-2014, 05:18 PM
Replies: 5
Views: 3,109
Posted By DonBC
Unplugging the connector does not change...

Unplugging the connector does not change anything, there is still vacuum at the output of the solenoid valve. Until I can get a new or replaement solenoid valve I have been running with the vacuum...
Jeep Forums: MJ Comanche Technical Forum   03-12-2014, 11:18 PM
Replies: 5
Views: 3,109
Posted By DonBC
EGR valve solenoid

I have been having problems with my 89 Comanche 4.0 not wanting to idle and stalling when I put in the clutch when driving. From the various threads this appears to be an EGR problem. Today I pulled...
Jeep Forums: MJ Comanche Technical Forum   02-20-2014, 09:34 PM
Replies: 8
Views: 1,671
Posted By DonBC
Jake, 2WD?, 4X4?. It might not be a big gamble if...

Jake, 2WD?, 4X4?. It might not be a big gamble if you can talk the owner down $2-300 more and the rest is in good shape. I use to have a Dodge Ram 50 with a 2.2L Mitsubishi turbo diesel and really...
Jeep Forums: MJ Comanche Technical Forum   11-24-2013, 06:37 PM
Replies: 1
Views: 548
Posted By DonBC
4 X 4 front hubs

I have dismantled most of my front axle to replace brake calipers, pads and rotors and to replace the U joints. I noticed that one of the hubs feels rough as if a bearing is going out of it or it is...
Showing results 1 to 20 of 43

 
Forum Jump
 
For the best viewing experience please update your browser to Google Chrome