JeepForum.com - Search Results
Advanced Search
Showing results 1 to 6 of 6
Search took 0.01 seconds.
Search: Posts Made By: aerick79
Jeep Forums: ZJ Grand Cherokee Forum   09-27-2012, 02:54 PM
Replies: 4
Views: 652
Posted By aerick79
Thanks for the advice.

Thanks for the advice.
Jeep Forums: ZJ Grand Cherokee Forum   09-27-2012, 10:57 AM
Replies: 4
Views: 652
Posted By aerick79
98 ZJ No audio from aftermarket headunit

Hi, everyone, I have a 98 ZJ laredo,with no audio. I do get audio from the sub but that's about it. I did tons of searches. So now its time to ask for help. I have a Alpine Headunit, cde 1333bt,...
Jeep Forums: ZJ Grand Cherokee Forum   07-10-2010, 08:07 PM
Replies: 7
Views: 1,260
Posted By aerick79
Wow that sucks. Hopefully that's not the case...

Wow that sucks. Hopefully that's not the case with me.
Jeep Forums: ZJ Grand Cherokee Forum   07-10-2010, 12:03 PM
Replies: 7
Views: 1,260
Posted By aerick79
Yea I thought it was the Head gasket too, but no...

Yea I thought it was the Head gasket too, but no no white smoke out of the exhaust and no coolant in the oil. sorry for the lateness
Jeep Forums: ZJ Grand Cherokee Forum   07-04-2010, 11:50 AM
Replies: 7
Views: 1,260
Posted By aerick79
Good idea, I'm planning to pull some plugs. ...

Good idea, I'm planning to pull some plugs. Hopefully its just a plug, not a bad rings.
Jeep Forums: ZJ Grand Cherokee Forum   07-04-2010, 11:30 AM
Replies: 7
Views: 1,260
Posted By aerick79
Poor Idle after Overheating.

Hey everyone,

My 98 ZJ is running poorly after overheating, due to a bad water pump. After the water pump was replaced, now the Zj is running rough at idle but smooths out after giving it some...
Showing results 1 to 6 of 6

 
Forum Jump
 
For the best viewing experience please update your browser to Google Chrome