JeepForum.com - Reply to Topic
Thread: 2012 JK Unlimited Sport 6spd, lights flashing on dash . Reply to Thread
Title:
Message:

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
08-20-2021 08:09 AM
SamKline0229 UPDATE 08/20/21 !!
So it was still acting up even having new pads , rotors , calipers on the rear .
And finally a check engine light came on (after resetting itself so many times because my Jeep would die)
The check engine codes (I didn’t write down the code it’s self) were , TRANSMISSION SPEED SENSOR & BRAKE LIGHT SWITCH .
After research they’re easy fixes . But when reading about them it makes sense now .
I have to special order the speed sensor because they don’t make a lot for manual cars . Just automatics .
But that’ll be fixed next week hopefully it’ll be in !
And then the chaos can stop!

Thank you everyone !!
08-05-2021 11:23 AM
cranbiz It passed the dealer inspection because it's a sham. They don't check squat.
08-04-2021 09:35 AM
DocAdams1 Awesome! Hopefully that fixes everything.
08-04-2021 08:54 AM
SamKline0229 HEY GUYS ! UPDATE !

So yesterday I heard the God awful grinding noise of my caliper being stuck . So I took off the rear tires and I found out what it was . My brake pad was metal on metal . And my caliper bracket was seized . (I bought this Jeep in March from a local dealership, i don’t know how it passed inspection if it was metal on metal already) there is a sensor behind the pads . I’m taking a guess that the sensor was warning me everything was going bad. And it was creating a bad connection causing all the lights to come and go on . (ABS , TC , BRAKE light)

I have to wait for the parts to come in . Hopefully once they’re in . All of this will stop .

I will post another update once it is fixed !

Thank you !!
07-22-2021 01:03 PM
SamKline0229 No additional connections that I know of . I’m not sure if they’re stock or not to be honest . I bought it this way from the dealer . Once I do some digging I will definitely post an update !!!!!
Thank you so much !!!!
07-22-2021 10:28 AM
DocAdams1 Ok it looks like there are 2 separate issues that need to be sorted out.

1. The no power issue.
2. The ABS/TC/BRAKE light issue.

For the first issue you are probably right as to the cause of the problem. If you have a rats nest of wires from bad installs that is a good place to start. Are there any additional connections to the battery itself? If so and they are the stock terminal connections where are they connected? What all is currently installed in the jeep that is aftermarket (electrical).

Post any codes or info you find. Where are you located there may be someone local that can give you a hand as well.
07-22-2021 03:49 AM
SamKline0229 * I’m sure I can get one
07-22-2021 03:49 AM
SamKline0229 I can see if we have one of those tools if not I’m use I can get one .

I will lose all power , as in , when I’m driving it is fine the lights will all flash on then go away , but the minute I turn off my Jeep it’s like I have a dead battery .

Typically when you open the door you’ll see the mileage . Well I won’t even see that everything will be blank I’ll put the key in and I won’t have anything .

Then about an hour or so later . It’s fine everything comes back on on the dashboard and it’ll start up again .

The person who had the Jeep before me had wired up pod lights on the push bar and it’s like a rats nest . I’m thinking it’s a bad ground or a bad connection somewhere in there . Because the battery meters at 100% .

We did try to jump start is the one time , we had jumper cables on another running vehicle . Did what we had to do . Even after it being connected for 5 minutes it still didn’t want to start . They lights on my dash (mileage & weather) would pop up . But it wouldn’t want to start. Then after a while when we gave up . It started up again . Like nothing happened .
07-21-2021 08:21 PM
DocAdams1 I tried to post earlier, but had garbage signal. Do you have a scan tool or access to one? Not a code reader, but something that can monitor different data points?

If so I suggest starting with the ABS/TC/BRAKE lights that come and go. This could be as simple as a wheel speed sensor or something easy like a damaged wire. With the scan tool if no codes are there monitor the ABS data and see if everything is making sense. Let us know what you find.

What did you mean by the lose of power?
07-21-2021 03:57 AM
SamKline0229
2012 JK Unlimited Sport 6spd, lights flashing on dash .

Hey guys !
So I recently bought my 2012 Wrangler back in March 2021 . And it was fine just needed a few things . Recently when I was driving home last week my dash board lit up like a tree , ABS, traction control, Brake light . It will ping that they all came on , and they’ll all go away . Meanwhile , as they ping at the same time my speedometer will go crazy . Then in a matter of seconds it’ll all stop and be fine . But once you turn it off , all power dies immediately . And it takes at least an hour or so to come back on . We have checked the battery it’s at 100%, we check all the connections (so we think at least) and everything seems tight nothing seems loose .
Any advice ?
Thank you guys !

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome