JeepForum.com - Reply to Topic
Thread: Liberty wont start Reply to Thread
Title:
Message:

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
02-27-2020 06:55 AM
jtec easy as 1-2-3.
fuses?
12v power at relay 85,86,30?
85 grounding when trying to engage starter?
02-27-2020 03:18 AM
Kcooks12 Hmm... sometimes it's worth $100 diagnostic fee at a shop to save you the headache. Check relays, crank sensor, cam sensor, connections, ignition switch, neutral safety switch, etc. If you want to do it yourself alldatadiy is a good site for a technical data on testing all those things.
02-17-2020 09:18 PM
pshivers Simple checks. Starter relay clicking? 12 volts on the big wire on the starter at all times? 12 volts on the small wire when cranking? Can it start in neutral?

Sent from my Samsung S8+ using Tapatalk
02-17-2020 07:53 AM
hydroferg
Liberty wont start

2006 Sport - automatic transmission
wouldn't turn over....replaced the battery
old starter tested bad....replaced
new starter doing the same...not energizing
???

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome