JeepForum.com - Reply to Topic
Thread: Gas mileage Situation Reply to Thread
Title:
Message:
Post Icons
You may choose an icon for your message from the following list:
 
 
 
   

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
02-14-2020 06:44 PM
Darnice Are you sure you don't have a brake dragging?
02-14-2020 06:04 PM
nick613 Well you definitely should be doing better. I wouldn't rule out a fuel leak even... There are a lot of possibilities, I'm not super familiar with WJs or modern gas engines but figured I'd try to help where I can.

Sent from my LG-H812 using Tapatalk
02-13-2020 07:53 PM
1202diesel
Quote:
Originally Posted by nick613 View Post
What size tires on this sucker? What kind of driving are you doing? You definitely should be able to do 400km to a tank on a healthy stock WJ. My 5.2 ZJ stock will do almost 500km to a tank on a long drive... It has 370k on it and could use a tune up.

Sent from my LG-H812 using Tapatalk
I’ve got 245/75/17 so stock for an upcountry.

Driving like a grandma lately, mostly in traffic bumper to bumper but with trips to hockey on the freeway few times a week about 40km round trip.
02-13-2020 06:26 PM
nick613 What size tires on this sucker? What kind of driving are you doing? You definitely should be able to do 400km to a tank on a healthy stock WJ. My 5.2 ZJ stock will do almost 500km to a tank on a long drive... It has 370k on it and could use a tune up.

Sent from my LG-H812 using Tapatalk
02-13-2020 05:48 PM
1202diesel
Gas mileage Situation

01 WJ 4.7L quadradrive

Started the trip with 144km remaining to empty. Drove 4.9km, now it says 123km to empty. It’s been doing this kind of mileage regularly now for a few weeks.

I’ve noticed I’m getting at best 300km to a tank. That’s without using the computer. That’s real mileage.

This can not possibly be normal.

I’ve changed 02 sensors. But I have an Evap code that shows up sometimes when it gets really cold, but usually disappears. I did repair a few hoses that were cracked. Haven’t seen any other EVAP leak sources visibly. Is there an EVAP delete that’ll let you just exhaust to atmosphere and bypass all the other lines without sacrificing fuel mileage.

Any other thoughts? If I can’t get this thing to be better than 400km/tank I’m gonna sell it. It just guzzles fuel worse than my 5.2L dodge did even with all the HP mods.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome