JeepForum.com - Reply to Topic
Thread: Real Oil Pressure Reply to Thread
Title:
Message:
Post Icons
You may choose an icon for your message from the following list:
 
 
 
   

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
08-16-2019 01:28 AM
Ralph77 Don't know if you guys can get away with this on your Jeeps but on a 4.0 in an '00 XJ it was easy to plumb in some fittings.
I just use them with a mechanical gauge to check. Not to run one all the time.
I did this so I would not have to remove my sensor anytime I wanted to check my oil pressure with a mechanical gauge but
also so I could run both the mechanical gauge and cluster one at the same time to see how they compare to each other.
08-15-2019 10:19 PM
ShinyWJ Not sure about the 04, but my 02 does not report oil pressure through the OBD port. At least it isn't showing as reported through the Torque Pro app.
08-15-2019 11:35 AM
Naapollo11
Quote:
Originally Posted by 99wjtx View Post
Honestly, with respect, that doesn't sound quite right but anyway if it is and you wanted to graft in a real electric oil pressure sending unit to the existing gauge, I think that would be a major hack. I believe it goes through the bus at some point around the instrument cluster for one thing, but also it probably wouldn't be calibrated correctly to the output of the new sending unit. Even trying to hack in a new gauge into the existing cluster would be difficult to pull off without really mangling things.
My money is with you on this. Wonder if anyone with knowledge of the bus system on here will chime in. Anyone ever put a scanner on a WJ and monitored the pressure reading reported? Does it fluctuate? I know when i change the oil it stays at zero for 3-5 seconds on startup and then climbs rapidly. It would be interesting to see if the OBD2 output climbs or snaps to the final reading.
08-15-2019 10:42 AM
99wjtx Honestly, with respect, that doesn't sound quite right but anyway if it is and you wanted to graft in a real electric oil pressure sending unit to the existing gauge, I think that would be a major hack. I believe it goes through the bus at some point around the instrument cluster for one thing, but also it probably wouldn't be calibrated correctly to the output of the new sending unit. Even trying to hack in a new gauge into the existing cluster would be difficult to pull off without really mangling things.

I think you'd be better off plumbing in a mechanical gauge using a T adapter in the existing sending unit hole or replacing the existing sending unit altogether with something else - either a new electric setup (with it's own gauge) or a mechanical gauge. My memory is fuzzy but I believe there's an unused plug somewhere near the oil filter that might be able to be used for a pressure gauge as well.

Whatever you do, be VERY careful with the threads in the sending unit hole. They're delicate and really dislike torque.
08-15-2019 08:21 AM
Naapollo11 I am shocked and appalled. I'm interested to see what other have done as well.
08-15-2019 01:56 AM
JeepHam1
Real Oil Pressure

I was dismayed to find out recently (on this Forum) that, in MY2004, the accountants at Jeep dictated that the Oil Pressure Sensor would simply detect a sufficient level of oil pressure and send a fixed signal to the Oil Pressure Gauge, causing the needle to rest at the exact same spot under all operating conditions. Correct me if I am wrong, but this seems to be no better than an Idiot Light. At least, they should have provided for real oil pressure readings when the WJ was equipped with the High Output 4.7 Power Tech engine. (Don't get me started on why my Overland did not come with twin exhaust pipes.) Anyway, has anyone looked into retrofitting the previous years' two-wire system, so that the gauge reads relative oil pressure? In addition to the sensor, would the actual gauge on the electroluminescent instrument panel need to be replaced (a task which I assume is impossible)? Many thanks for your insights.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome