JeepForum.com - Reply to Topic
Thread: 2008 Jeep Patriot - NEED HELP! Reply to Thread
Title:
Message:

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
04-14-2019 04:45 PM
AprilGolka
2008 Jeep Patriot - NEED HELP!

So, one day my Jeep just suddenly went into limp mode. All the warning lights are on and the engine is running real rough, almost stuttering too. It’s also really hard to start. Here are the steps that have been taken since we hooked it up to my boss’s code reader:

1. Replaced complete throttle body with sensor
2. Replaced the battery
3. Replaced the spark plugs
4. Replaced crankshaft position sensor
5. Had a diagnostic done by a mobile mechanic and he checked replacements and other basic checks as well. Recommended next steps 6-8
6.Replaced the PCM/plug and play (refurbished with VIN number provided for programming it in advance)
7. Replaced the O2 sensors
8. Replaced the accelerator pedal position sensor

Coils are fine, one seemed bad and we replaced it but signal was jumping so it actually didn’t need replacing, this was all prior to PCM. Missed it in above steps.

The car is acting exactly the same. Now what?

Any advice?

Thinking of having AAA take it to a mechanic because we are at a loss! Please help!!!

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome