JeepForum.com - Reply to Topic
Thread: quadra lift nightmare Reply to Thread
Title:
Message:
Post Icons
You may choose an icon for your message from the following list:
 
 
 
   

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
07-23-2021 05:10 PM
Bilko FYI

Most of the effort and associated labor costs required to swap the front struts is taking everything apart including removing the front hub assemblies. So if you are performing this swap it's worth checking a few other things before everything is disassembled.


Axle nuts, for some reason these suffer from bad rust even in dry climates, it's worth replacing these if they are corroded, they only cost few bucks each and will make any future maintenance much easier.


Wheel bearings, there have been reports of wheel bearing wear on these vehicles, I have never seen it but it's worth checking, and if necessary, replace whilst everything is disassembled.
07-23-2021 11:09 AM
southernholly Thanks! We have a great mechanic - he just didn't see the airbags cracks because they weren't fully inflated when he got it. I actually found the front ones from this website and ordered last night. Our mechanic says he can replace them so FINGERS CROSSED. Other than this ongoing issue it's been a great car - so hoping it stays that way and this fixes it!
07-22-2021 05:40 PM
Bilko Unless you really drive your air suspension hard off-road the usual cause of failures is simply old age, anything made of rubber deteriorates as it ages. Just like you and me

If you are confident the problem is isolated to the air springs, you may want to take a look at these guys. It is less than $1,000 for a full set of premounted front struts and rear air springs plus dampers.

The rears are easy to do but the front struts swap it more involved. If you can't do this yourself then a good independent shop should be able to install them in half a day so maybe $500 in shop fees.

If you spend this money you should have many more years of life left in this vehicle.

The same company offers steel spring replacements for air springs but it's not so easy to disable all the fault codes. if you are thinking of doing this, ensure you do research before taking this path.

https://suncoreindustries.com/produc...grand-cherokee
07-22-2021 01:16 PM
southernholly
Airbags were our problem

I know this is an old thread but we've been through this for months now on a 2011 JGC Overland - my daughter bought SUPPOSEDLY 2nd owner (thinking that's a lie but whatever). After getting stranded multiple times and replacing fittings, parts, compressor, you name it - come to find out after replacing almost everything else the airbags have a leak. They have dry rotted according to the dealer here. That's a $3600-$5000 fix at the dealer just for the front airbags. Hoping my mechanic can do it for less. If she had a job right now this car would be getting SOLD.
01-14-2019 09:06 AM
bittner72 I think you need to find a way to monitor the system pressure. I have auto-enginuity and it will do it. This way, you can verify if your leak is internal or external. I think if it is internal then as the system levels out, your pressure should be in the right range and should be consistent day-day. If your pressure is low, first you must correct that because the system will not work right with low pressure. If your pressure is continuing to drop day over day then you have an external leak. If the pressure is ok, then I would guess you have a valve block that is leaking...I know it was replaced.
01-10-2019 07:23 AM
Freddybeach123 still not working. they can't find any leaks?
01-09-2019 05:00 AM
Freddybeach123 Jeep back in this morning. I told them the new compressor works as well as my old compressor. It works lol I told them instead of wasting there time and my money to go and buy a smoke pencil and find the leak. I will keep you updated.
01-08-2019 04:52 PM
ColdCase The valve block mechanically controls the flow of air in the system and maintains the pressure in the reservoir, and in each air spring individually. Valves and solenoids in the valve body open and close to increase or reduce pressure to air lines that connect to each pressurized component (air spring) allowing the system to move each corner of the vehicle up or down as necessary. All wiring connected to the valve block is directly from the Air Suspension Control Module (ASCM) which fully controls the valve body. The ASCM determines pressure from an internal pressure sensor in the valve body.

The compressor runs to maintain air pressure any time the vehicle height is being changed. The valve body controls the direction of air flow, either to the storage tank or to the airbags. When being raised the flow would be out of the tank, lowered into the tank.

There is a relay, controlled by the control module, that provides power to the compressor. If its bad, the compressor probably won't run at all. It switches bat voltage so, in theory, the compressor could be turned on even when the ignition is off.

There are quite a few DTC that could be set and one could envision a valve problem or leak causing the issue.

I've never heard my compressor run after it goes into deep sleep (maybe 20 minutes after closing the door). I think some have reported hearing it.

I think reports here of one end being down overnight turned out to be leaks, but there could have been some with valve problems. Each spring connects directly to the valve body, no taps no Ts. You would think a single leak would affect only one spring.... but from reading here it may not.
01-08-2019 02:01 PM
Freddybeach123 Thanks everyone. They replaced the lines when they replaced the compressor. And the valve block. The jeep has 145,000 km's on it. common sense told me it was a leak somewhere up front. They said that Chrysler recommended 1) replace relay 2) replace module 3) replace compressor. Both sides drop equally when left sitting. This is left in a heated garage so don't see how temperature would be a factor? Compressor does not turn on after the jeep is turned off as I thought it was supposed to?
01-08-2019 01:19 PM
woodsy18 The temps are not that big of an issue as snow and ice freezing to everything. Had to leave my jeep out in a blizzard in Iowa this year. 13 inches of wet blowing snow came in 6hrs and it was frozen. Had to leave it inside for 8hrs inside my heated garage to thaw it out.

Sent from my SM-G950U using Tapatalk
01-08-2019 12:56 PM
ColdCase Sub freezing is not an issue, its when you get -30F for weeks on end
01-08-2019 12:48 PM
smseargeant
Quote:
Originally Posted by ColdCase View Post
Yeah there are thousands of high mileage QL vehicles out there without issue. There are a few that break, however, most notably in the far northern cold climates. They can be expensive to fix right. It helps if the shop's tech staff has experience and knows what they are doing. Many dealer's staff don't have a clue and thats usually when we see bigger issues.
I'm a little worried now. It not uncommon to have sub-freezing and even negative temps for weeks at a time where I'm at.

Sent from my SM-G965U using Tapatalk
01-08-2019 12:45 PM
ColdCase
Quote:
Originally Posted by smseargeant View Post
How many miles? I've got 160k on my 2014. No issues with suspension so far. I'd ask them to fix whatevers left to fix pro-bono and reimburse any extra for selling you a service that you didnt need.

Anyhow, I'd never go straight for the compressor when it's just a leak.

Sent from my SM-G965U using Tapatalk
Yeah there are thousands of high mileage QL vehicles out there without issue. There are a few that break, however, most notably in the far northern cold climates. They can be expensive to fix right. It helps if the shop's tech staff has experience and knows what they are doing. Many dealer's staff don't have a clue and thats usually when we see bigger issues.
01-08-2019 12:37 PM
ColdCase The system is not entirely closed as when the fill drops enough, the compressor will draw in outside air through a desiccant dryer to make up for it. When you have a more than typical leak, moisture eventually soaks the desiccant and makes its way into the valves and compressor where it can corrode and freeze. But the typical failure mode for these is that, when there is a leak, the low duty cycle type german designed compressor will run often and has a tendency to overheat or wear out. This is the main reason we advise to have any suspect leak fixed promptly.
01-08-2019 12:29 PM
ColdCase
Quote:
Originally Posted by Freddybeach123 View Post
Hi everyone. Looking for help. 2011 jeep grand cherokee overland. Air suspension always worked up until 2 months ago. Actually the air suspension works great in all modes; after sitting for approx. 8+ hours the front end sags down. When I start the Jeep it pumps itself up to normal ride level. All levels work even aero mode and exit. Park suv leave 8+ hours front end sagging again. Took to dealer and it asked for a relay. Replace relay didn't work. Was told I needed to replace compressor. They said module looked fine. $2100 and labour. This included new lines and valve block. Just picked it up last night and took it home.($2600 cnd) Parked it in the garage came out this morning and guess what front end sagging down what the heck. Could it be the module. I told the dealer I hope they saved the parts they took off because they were obviously not the problem. Thoughts or ideas???? Anyone experience the same thing????
There is a leak somewhere either in the valve body, air lines, fitting, or air bag, most likely the front. If its been cold, the plastic lines shrink a little and fittings can leak. There is probably a slow leak in one of the lines/fittings they replaced. It may have been fine in their warmer shop, but once outside the hose shrinks enough to leak. It happens to the best of them.

On the other hand, I dunno what relay the dealer initially replaced, but there are none that would cause this problem. That has me suspect that you didn't get a decent tech the first time.

Anyway tell the dealer you are not happy with their work as you have a leak somewhere in all the parts they replaced. They should do a leak test, which is basically soaping down the connections and wiggle them and look for bubbles.

Its not the controller.

Its a leak.
This thread has more than 15 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome