JeepForum.com - Reply to Topic
Thread: Having problems with Jeep Dealers and their Customer service Reply to Thread
Title:
Message:

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
12-22-2018 01:12 PM
jtec what is the issue that you need answered? HOPEFULLY someone here can get you the info you want.
12-22-2018 10:23 AM
RockWoRM Typically they send email surveys to fill out after a service. Stealerships absolutely hate bad reviews.
12-15-2018 10:26 PM
JoonHoss @JeepCares here on Jeepforum


Hoss
12-14-2018 04:51 PM
Trons
Having problems with Jeep Dealers and their Customer service

I've been a Jeep owner for a while. My wife and I bought a new Cherokee in 2016 and have been having difficulty with every dealer I've been to for servicing since then. Without going into detail, I finally called their customer service last Monday. They were supposed to do some research and call me back and I have yet to hear from them. I called back on Wednesday, and was assured a call back but it never came.

I called back in today to some very frustrating responses. 2 different representatives advised me they couldn't transfer me to a supervisor, when I tried to escalate the call. A third opened a ticket to have a supervisor call me back but that hasn't happened yet.

Does anybody have a good way to contact a Jeep Customer Service Supervisor?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

 
For the best viewing experience please update your browser to Google Chrome