JeepForum.com - Reply to Topic
Thread: Losing electrical power Reply to Thread
Title:
Message:

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
08-20-2018 07:01 PM
paskalee Here are some pictures of it. The #11 fuse does seem to be a little loose as I can pull it out with my hand although not easily.
08-17-2018 08:37 PM
Rubi4MyMrs It is also possible that only one of the 2 terminals is loose which may make the fuse feel tight. In that case you could either split a fuse & try each terminal, one at a time or if you have one take a male spade terminal & try inserting it into each of the (female, fuse block) terminals to be sure all are fitting tightly. Or better yet make a jumper wire with 2 spade terminal ends & insert each end into the fuse positions which will bypass the fuse. You can then wiggle away as well as test that both legs fit tightly. Then do the same for the other one. Fuse 11 is the important one as far as engine running & cluster working so figure that one out first if you can.
08-17-2018 06:36 PM
mukluk With the fuse block removed and fuses 11 and 15 removed from their slots, try physically manipulating the wires and terminals going to 11 and 15 to see if they are loose or if they come into contact with anything that they shouldn't. Also take a good look at the wires where they run behind the fuse block to be sure they aren't pinched or have any evidence of damage. If nothing is noted there, check to see if the terminal contacts in the fuse slot are loose or broken, allowing the fuse to not be held very tightly in place when inserted (it should require a fuse puller or pliers to remove the fuses).

Post up some clear pictures of the back side of the fuse block and wiring as well if you can.
08-17-2018 06:24 PM
paskalee Yes, I mean fuse #11 the PDC Coil fuse. I have pulled the fuse block off and did not find anything. Maybe I overlooked it but I didn[t see anything that was loose or broken.
08-17-2018 04:03 PM
mukluk I'm betting he means fuse 11, often labeled as "PDC coils". Since the radio is also having an issue and it just so happens to be powered by fuse 15 right next to the other problem fuse, I'd say chances are good the issue will be found between those two fuses after the fuse block is removed.
08-17-2018 03:45 PM
Rubi4MyMrs Which fuse (number) in the fuse block? You said PDC fuse which is confusing everyone.
08-17-2018 10:32 AM
paskalee I don't think it's my ignition switch has I have replaced it and it still happens.

I will have to pull apart my PDC to check it but it seems like I was losing power at the fuse box behind the glove compartment since all I have to do is touch the fuse to get power back. When I do this I can hear a few clicks as the power comes back. But I have removed it a few times and haven't found anything there.
08-17-2018 06:49 AM
ravenworks
Quote:
Originally Posted by Jonny Jeep View Post
There have been occasions where people have had the crimps go bad at the receptacles in the PDC. You'd need to separate the PDC and look at them from the underside to see if that's what's causing your issues. I don't know how easy it is to get new receptacles to fit the PDC, so cleaning up and soldering the wire might be needed if it is a bad connection there.
^^this^^^
The PDC is notorious for problems of having loose or corroded connections.
I had a dealership royally screw up my realy connections while I was having my AC serviced.
They tried to say they didn't touch the PDC until I showed them the greasy Motorcraft relay.
Long story short my parts guy was the one that told me what was up.
The mechanic working on my vehicle requested a new relay and they didn't have any.
Of course it being late on a Friday evening he admitted to taking a used part out of his toolbox and sticking it in my Jeep.
Of course they charged me for a new one.
If you go through everything in there the fuses and relays should be tight,not moving around.
08-17-2018 06:39 AM
Goatman#1 Sounds like a power continuity problem to me. Most likely an intermitint ground. Or the fuse box itself may be the problem. Look for ANY sign of corrosion in and around each fuse and contact point. But the ground in the ignition switch could do it too.
08-17-2018 03:17 AM
Jonny Jeep There have been occasions where people have had the crimps go bad at the receptacles in the PDC. You'd need to separate the PDC and look at them from the underside to see if that's what's causing your issues. I don't know how easy it is to get new receptacles to fit the PDC, so cleaning up and soldering the wire might be needed if it is a bad connection there.
08-16-2018 09:51 PM
paskalee
Losing electrical power

I have an on going issue with my 1997 TJ that I can't figure out and have not come across anyone else having the same problem.

Sometimes, when I go to start my Jeep there will be no power going to any of the gauges or radio. If I touch the fuse box, on the PDC fuse it will return power. Usually, I have to touch it a few times before power will stay on so I can start my Jeep.

But even after I get it started sometimes I still loose power to my radio. Power will randomly turn on and off to my radio and random intervals.

I have looked for loose and broken wires but have not found anything.

Does anyone have an idea of what is going on? Is it the fuse box itself?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome