JeepForum.com - Reply to Topic
Thread: What did you do to your XJ/MJ today? Reply to Thread
Title:
Message:
Post Icons
You may choose an icon for your message from the following list:
 
 
 
   

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
Yesterday 12:26 PM
Camaro45th
Quote:
Originally Posted by TheBoogieman View Post
Went to the post office with the crazy holiday traffic everywhere. It was pouring rain and while backing up I felt a thump. I get out and see a new Cadillac behind me. OOPS! He was backing out too. I told him I didn't see any damage and we both went on our way. He was very old and didn't seem too concerned anyway. I guess it would have been a no fault accident. I think he was backing out first though.


Sounds like a Christmas Miracle!
Yesterday 11:33 AM
TheBoogieman Went to the post office with the crazy holiday traffic everywhere. It was pouring rain and while backing up I felt a thump. I get out and see a new Cadillac behind me. OOPS! He was backing out too. I told him I didn't see any damage and we both went on our way. He was very old and didn't seem too concerned anyway. I guess it would have been a no fault accident. I think he was backing out first though.
12-12-2019 10:51 AM
Pinoy59
Quote:
Originally Posted by TheBoogieman View Post
Do it and get better tires. I ran those on 2 TJs.
I have really liked the mud claws. They have good traction and haven't chunked almost at all. I wish they had more lugs on the sidewall but i have only punctured one in 5 years.

Sent from my SM-G975U using Tapatalk
12-12-2019 10:48 AM
TheBoogieman
Quote:
Originally Posted by Pinoy59 View Post
Yeah one only has like 500 miles on it. The others are 5 years old. I want to go up to 35's!

Sent from my SM-G975U using Tapatalk
Do it and get better tires. I ran those on 2 TJs.
12-12-2019 07:44 AM
Pinoy59
Quote:
Originally Posted by TheBoogieman View Post
Looks like it's about time for some new mud claws.
Yeah one only has like 500 miles on it. The others are 5 years old. I want to go up to 35's!

Sent from my SM-G975U using Tapatalk
12-12-2019 07:42 AM
TheBoogieman
Quote:
Originally Posted by Pinoy59 View Post
Added C gussets while doing my ball joints. Artec c gussets and synergy ball joints. Finishes off my dana 30 with artec truss with Johnny joints, chromoly shafts, lock right locker, 4.10 gears, LCA skids, one ton steering, Solid diff cover, and Bilstein shocks.

Not sure why my pictures got turned.
Nice setup. Looks like it's about time for some new mud claws.
12-05-2019 02:17 PM
Pinoy59 Added C gussets while doing my ball joints. Artec c gussets and synergy ball joints. Finishes off my dana 30 with artec truss with Johnny joints, chromoly shafts, lock right locker, 4.10 gears, LCA skids, one ton steering, Solid diff cover, and Bilstein shocks.






All back together

Not sure why my pictures got turned.

Sent from my SM-G975U using Tapatalk
12-04-2019 04:36 PM
Ralph77
Quote:
Originally Posted by Camaro45th View Post
I am in NY[emoji24]. I have fixed a Ton of stuff on this thing. Itís my daily for work. I just did the spark plugs last week and it seemed to be running great. I was on my way to the auto parts store to get some coolant to try and flush my heater core again because my heat isnít very hot.
For me it was Walker 52304. Pretty sure for you it would be Walker 81850.
I would double check that I am right about the NY thing.
But sadly pretty sure I am.
12-04-2019 04:24 PM
Camaro45th I am in NY[emoji24]. I have fixed a Ton of stuff on this thing. Itís my daily for work. I just did the spark plugs last week and it seemed to be running great. I was on my way to the auto parts store to get some coolant to try and flush my heater core again because my heat isnít very hot.
12-04-2019 04:17 PM
Ralph77
Quote:
Originally Posted by Camaro45th View Post
2000
Thought so. CA Emission with the dual front cat?
I went through this a few years back with my '00 with CA Emissions.
Theoretically there are few things that could be causing this. Fuel trims, O2 sensors, exhaust leaks, and the like.
I spent a year checking every thing I could to be sure it was the cat.
Jeep seem to run fine all that time though.
I did not mind spending the money but wanted it to be fixed if I did.
Well turned out it was the cat.
Solved my P0432.
As long as you are not in CA or NY you want the cat for a CA Emissions '00 that is not registered in CA or NY.
It is different then the one you need to get if you are and somewhat cheaper.
I used a Walker one.
12-04-2019 04:12 PM
Camaro45th
Quote:
Originally Posted by Ralph77 View Post
What year XJ? I looked at your profile and it is not listed.


2000
12-04-2019 04:12 PM
Ralph77
Quote:
Originally Posted by Camaro45th View Post
Check engine light came back on, P0432. Catalytic Converter.

This thing is becoming a money pit.

Iím not sure if I should replace it or look for a new vehicle. I bought the car in September and have been putting money into it left and right. I canít seem to get 1 week of it not needing something.
What year XJ? I looked at your profile and it is not listed.
12-04-2019 03:56 PM
Camaro45th Check engine light came back on, P0432. Catalytic Converter.

This thing is becoming a money pit.

Iím not sure if I should replace it or look for a new vehicle. I bought the car in September and have been putting money into it left and right. I canít seem to get 1 week of it not needing something.
12-04-2019 12:12 PM
Jeep_XJ Bondo... Had one spot of rust right corner above hatch that always bothered me so i finally got around to fixing it. Got a can of Dupli-Color Chrysler flame red coming from Amazon to finish the job.
12-01-2019 04:10 PM
TheBoogieman
Quote:
Originally Posted by XJ-Buzz View Post
decided on a new set of shoes. 31x10.5/R15......I'll change out to a different set of wheels after the holidays.
It looks really good. I never run over 30 psi for 31s.
p.s. I'm partial to red Jeeps with black wheels.
This thread has more than 15 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome