JeepForum.com - Reply to Topic
Thread: What did you do to your XJ/MJ today? Reply to Thread
Title:
Message:
Post Icons
You may choose an icon for your message from the following list:
 
 
 
   

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
Today 11:22 AM
S8NNG8
Quote:
Originally Posted by retrvrtrainer View Post
Gotta replace the alternator brushes. Intermittent loss of power from the alternator while driving. Charges fine when first started. We'll see...
Possibly a loose belt. Once it's warmed up it's slipping.
Today 08:24 AM
retrvrtrainer Gotta replace the alternator brushes. Intermittent loss of power from the alternator while driving. Charges fine when first started. We'll see...
Today 07:50 AM
kluttsy01
Quote:
Originally Posted by TheBoogieman View Post
I put my XJ adjustable on my TJ. They mount the same on later model (97-01) XJs.
Maybe that's the problem, I got a 96.

Sent from my SM-G973F using Tapatalk
Today 07:47 AM
TheBoogieman
Quote:
Originally Posted by kluttsy01 View Post
Track bar, yes. Track bar mount, no.


Sent from my SM-G973F using Tapatalk
I put my XJ adjustable on my TJ. They mount the same on later model (97-01) XJs.
Today 07:44 AM
kluttsy01
Quote:
Originally Posted by TheBoogieman View Post
TJ and XJ adjustable track bar is the exact same.
Track bar, yes. Track bar mount, no.


Sent from my SM-G973F using Tapatalk
Today 07:42 AM
TheBoogieman
Quote:
Originally Posted by kluttsy01 View Post
Yeah my buddy gave me a rough country adjustable tack bar for his tj thought great, nope didnt think about the tj having a real frame.

Sent from my SM-G973F using Tapatalk
TJ and XJ adjustable track bars are the same.
Yesterday 10:11 PM
katzklaw lookin good..!
Yesterday 07:38 PM
kluttsy01
Quote:
Originally Posted by Pinoy59 View Post
One of the reasons i don't particularly like zone. Their kit doesn't even come with brake lines or most of the other stuff needed when you lift a vehicle...

Sent from my SM-G975U using Tapatalk
Yeah my buddy gave me a rough country adjustable tack bar for his tj thought great, nope didnt think about the tj having a real frame.

Sent from my SM-G973F using Tapatalk
Yesterday 06:12 PM
Pinoy59
Quote:
Originally Posted by TheBoogieman View Post
Lowes, Home Depot, and other places have grade 8/10.9 bolts.



As soon as I installed my lift, I took it for a test ride on some hills and it pulled the rear brake hose loose (way too short) and dumped my brake fluid everywhere. I made it home and bought a longer YJ hose to fix the problem.
One of the reasons i don't particularly like zone. Their kit doesn't even come with brake lines or most of the other stuff needed when you lift a vehicle...

Sent from my SM-G975U using Tapatalk
Yesterday 05:36 PM
kluttsy01
Quote:
Originally Posted by pdcomm View Post
I bet you read that on the internet .
Yeah. Either here on jf, Cherokee forum or naxja. But I just went to tsc and got new ones.

Sent from my SM-G973F using Tapatalk
Yesterday 05:19 PM
kluttsy01 Welp it finally happened.

Sent from my SM-G973F using Tapatalk
Yesterday 03:47 PM
pdcomm
Quote:
Originally Posted by kluttsy01 View Post
I read that they had to be a special bolt from the dealer

Sent from my SM-G973F using Tapatalk
I bet you read that on the internet .
Yesterday 11:12 AM
kluttsy01
Quote:
Originally Posted by TheBoogieman View Post
Lowes, Home Depot, and other places have grade 8/10.9 bolts.



As soon as I installed my lift, I took it for a test ride on some hills and it pulled the rear brake hose loose (way too short) and dumped my brake fluid everywhere. I made it home and bought a longer YJ hose to fix the problem.
I read that they had to be a special bolt from the dealer

Sent from my SM-G973F using Tapatalk
Yesterday 12:34 AM
TheBoogieman
Quote:
Originally Posted by kluttsy01 View Post
and pop goes the track bar bolt... so to the dealer I go in the morning
Lowes, Home Depot, and other places have grade 8/10.9 bolts.

As soon as I installed my lift, I took it for a test ride on some hills and it pulled the rear brake hose loose (way too short) and dumped my brake fluid everywhere. I made it home and bought a longer YJ hose to fix the problem.
02-20-2020 10:47 PM
kluttsy01 Took this bout 6 hours ago, messed around with the break line and shock bolts then took it for a test drive.. found something on the front end loose so went back to the barn and rechecked everything and pop goes the track bar bolt... so to the dealer I go in the morning, so much for a 5-6 hour install time.

Sent from my SM-G973F using Tapatalk
This thread has more than 15 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome