JeepForum.com - Reply to Topic
Thread: Little Red XJ Reply to Thread
Title:
Message:

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
06-28-2020 07:32 AM
RedJeepster1 Took the Jeep out yesterday for the first time in a couple months. First off is the fan setup I guess. It works great. I didnít have any heat soak issues all day even with air temps in the 80ís. I turned on the fan for a couple minutes after shutting the Jeep down and it pushed all the heat right out of the engine bay.

Jeep ran great all day. The hydro steering was great offroad. It makes trail riding so much nicer. Power steering pump didnít overheat so I guess that means I have a big enough steering cooler. I ran the electric fan all the time while wheeling because it pulls air past the steering cooler. Jeep overall did very well. Few new dents and scratches but nothing major. Drove home 2 hours at 75 mph with no real issues afterwards. My oil filter adapter has developed a pretty good leak, but thatís pretty common in these 4.0ís.

Hereís the few pics I got. Everything else was videos.








Sent from my iPhone using Tapatalk Pro
06-26-2020 09:38 AM
cpia84 The fan setup looks good. If you hadnt of said i was going to suggest hood vents. The 4.0L can get a bit toasty and the hood vents do help.
06-26-2020 08:46 AM
RedJeepster1 Installed a fan switch last night to try and help with heat soak when wheeling. The Jeep usually doesnít have trouble staying cool, but when I turn it off in the woods, I do get heat soak pretty bad when I try to start back up. I set the switch up with a relay so when itís turned off, the fan will operate as normal and turn on only when the computer tells it to. But when I flip the switch, I bypass the computer and feed power to the fan without back feeding the computer. This should allow me to run the fan for a few minutes after I turn off the Jeep to help disperse whatever heat is left in the engine bay. If it isnít enough, I also have a set of LaBaron hood vents to install.

Also most of you will probably hate me because I used an extended idle switch as my fan switch... I had one laying around and it fit in the factory spot so I figured why not. Itís nice that it has a light in it so I can easily see when itís turned on. I also wired it to permanent +12V so I can run it when the Jeep is off.

Here's the writeup: Right way to Install a Manual Fan Switch

06-25-2020 10:16 AM
RedJeepster1
Quote:
Originally Posted by cpia84 View Post
I just finished reading your thread and wow. You have done a lot of work to several XJs!! It makes me miss my XJs. And have you linked your rear yet on the XJ? Have you had to use your winch much, if so how did it do? I never did like any big bumper either for how far they stuck out but i really like your winch/bumper setup. Lots of very impressive work!



If you ever want to off load an XJ or 2 feel free to let me know lol.

Hey! Thanks for stopping by. I have not linked the rear yet. When I do I will either go with ORIís or coilovers, and I really need a slightly wider axle to make that work.

Iíve used the winch a few times and it works great. I need to reinforce the D ring mounts so they can handle side loads better, but otherwise the setup is awesome. And most people donít even realize itís there.

On a different note, just installed new longer front shocks the other day. Havenít flexed it out yet but Iím taking it out in the woods again on Saturday.




Sent from my iPhone using Tapatalk Pro
06-24-2020 01:10 PM
cpia84 I just finished reading your thread and wow. You have done a lot of work to several XJs!! It makes me miss my XJs. And have you linked your rear yet on the XJ? Have you had to use your winch much, if so how did it do? I never did like any big bumper either for how far they stuck out but i really like your winch/bumper setup. Lots of very impressive work!

If you ever want to off load an XJ or 2 feel free to let me know lol.
06-21-2020 05:25 AM
RedJeepster1 Ended up getting a 4.5Ē spring for the front, although unfortunately itís still sitting lower than 4Ē of lift. Been driving the wheels off this thing and I love it. Looks like Iíll have it back in the woods for the first time in a long time next weekend.




Sent from my iPhone using Tapatalk Pro
05-11-2020 08:15 AM
RedJeepster1
Little Red XJ

Havenít posted an update here in close to a year. Lots of front end work lately. Redid my whole steering setup and installed a hydro assist ram and a steering cooler. Probably a bunch of other things too that I didnít post here. But the Jeep is driving super well and running great. Almost warm enough to start driving it again. Hereís a quick photo summary of the recent work. Also the Jeep is down to only 3.5Ē of lift now. Things are tight, but nothing touches. I did have to clearance the drivers floor pan for more up travel on the 3rd link. Trying to decide if I should lower the back to match or raise the front back up with a different spring.


















Sent from my iPhone using Tapatalk Pro
08-05-2019 07:32 PM
RedJeepster1 Swapped my hardware on the visor to black button heads and black washers. Also placed an order for some LED lights and some sockets I should be able to make work in the visor. The stock wiring is all shot so Iím going all new.




Sent from my iPhone using Tapatalk Pro
08-02-2019 04:13 AM
RedJeepster1
Little Red XJ

Been driving the wheels off it. Put a new battery in it a week or so ago and I finally installed my visor a couple days ago. Still need to get some different hardware, all I had was hex head bolts at the house. I sunk nutserts into the roof and RTVíd then on install, so hopefully they wonít leak.






Sent from my iPhone using Tapatalk Pro
07-17-2019 12:40 PM
RedJeepster1 I take it back, I did find a couple shots from the last month or two which didnít make it in here.








Sent from my iPhone using Tapatalk Pro
07-17-2019 12:34 PM
RedJeepster1 Hereís a shot parked outside the office building I work in. No fun off-roading recently.




Sent from my iPhone using Tapatalk Pro
07-17-2019 12:32 PM
RedJeepster1 Thanks Luke.

Little update, I had the oil pressure sensor go bad in the Jeep a couple weeks ago and it was causing the Jeep to stall and buck and just run like garbage. Saturday morning I finally took the literally 5 minutes to change the sensor with one off my parts Jeep and it's back up and running like a champ. Battery seems a little weak buy otherwise its going pretty good. About 300 miles on it in 3 days and it's been great. Does 70 on the highway with the cruise control set, smooth can be. I've been driving around with the doors off just enjoying it. Not sure when the next club run is but I'll definitely be taking it out a few more times this season.
07-16-2019 05:16 PM
Luke95
Quote:
Originally Posted by chris87xj View Post
Way to drive that ***** like you stole it and getter dun!
Our entire group killed it that day his jeep works quite well and seems simple yet well put together. It just flat works.
06-16-2019 08:11 PM
Devil15 Looks nice

Sent from my SM-G892U using Tapatalk
06-16-2019 08:00 PM
RedJeepster1 Nothing too crazy, but I had an exhaust hanger break last week so I figured while it was off I should find a way to make it a little quieter in the cabin. Previous setup just dumped under the Jeep. New setup is a side pipe. Deeper sound. Less noisy in the Jeep. I think a little more noisy outside the Jeep. Itís tucked up as high as I could get it. Was going for subtle as far as looks.






Sent from my iPhone using Tapatalk Pro
This thread has more than 15 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

 
For the best viewing experience please update your browser to Google Chrome