JeepForum.com - Reply to Topic
Thread: 92 yj coolant problem!! Help!!! Reply to Thread
Title:
Message:

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
08-22-2012 07:20 PM
Jeepsr4me Pump then. Cheap and easy to do.
08-22-2012 05:58 PM
1SASjeepster If the engine is just cutting off, I tend to agree with you. It may well be electrical. When you pulled your radiator cap off, and your thermostat opened up, did you witness a lot of water movement through the opening? If little, I would say the pump is gone. This may well be a combination problem, where the actual problem is affecting the ECU to cut off everything to protect the engine.

Take care,
08-22-2012 04:09 PM
gunnar92yj im not losing any coolant. no coolant in my oil. ill check my plugs. i know there is a sensor on the thermostat housing that goes to the ECU. i was thinking that the ecu cuts my ignition when the temperature gets too extreme. and would the blown head gasket impede water flow? the motor dies with absolutley no hesitation what so ever, just like you turned the key off. thats why i was leaning towrd a computer driven shut down due to high temp.????
08-22-2012 11:40 AM
1SASjeepster Have you checked your spark plugs yet? Want to see if you have any coolant smell. Have you run a vacuum test yet? It would let you know if you blew a head gasket. A blown water pump or clogged engine block wouldn't make the engine quit. This has to do with the combustion chamber.

Take care.
08-22-2012 03:53 AM
Jeepsr4me water pump.... But then again head gasket. Change the pump and hope for the best.
Highly doubt you could clog the engine up to point no water flowed. When you pull pump you will see why.
08-21-2012 09:07 PM
gunnar92yj
92 yj coolant problem!! Help!!!

92 yj - 2.5 4 banger 5 speed.

driving around the other day and my jeep just fell on its face and quit. got out, checked fuel pressure....good. checked spark...good. got back in, started right up and made it home. took another look and noticed my top radiator hose was HOT and under serious pressure. bottom hose is hard too but cold. ?? so i replaced the t stat. still same symptoms. guys im stumped...maybe a clogged waterjacket in the head.....i hope someone says its not that....god please no. HELP PLEASE!

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome