JeepForum.com - Reply to Topic
Thread: My Dub-P TJ Reply to Thread
Title:
Message:

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
07-09-2012 12:08 PM
tcate23-97 I dropped the rear springs back to the stock ones with 2 in spacer. Thinking about putting OME springs back there or BDS like my front. Havent had that much to update and this isnt a very popular build thread, but I am currently trying to sell my 33" tires to upgrade to 35's.
05-13-2012 08:22 PM
tcate23-97 update picture
05-13-2012 07:38 PM
tcate23-97 replaced my transmission mount today, as my old one was completely torn apart.
05-01-2012 08:41 PM
tcate23-97 So i am ready to move to 35's. The 33's look tiny now with my 3 inch+1.25 lift.
Upgrade List:
ZJ tie rod sway
Axles and gearing- 4.88's regeared and superior axle for rear.
brakes- centric rotos and BM pads.
04-29-2012 10:19 AM
tcate23-97
Quote:
Originally Posted by sjones26573 View Post
Fabric and vinyl paint on plastic. That might be your problem
thanks, got that taken care of. Didnt realize it at first, although it says made for dashboards on the can.
04-29-2012 09:52 AM
sjones26573 Fabric and vinyl paint on plastic. That might be your problem
04-29-2012 09:44 AM
tcate23-97 Also my gas cap is really stressed due to the BL, i tried pull the hoses out a little bit but it didnt move much. Not sure what to do...


And then i sanded, primed and painted my door panels because they were stripping.
04-29-2012 09:42 AM
tcate23-97 Finally installed my replacement antenna mount because the threads were bad.
04-15-2012 09:56 AM
tcate23-97 I'm really not that impressed by the ride, kinda upsetting. I feel every little bump on the rode, not a big difference between the crappy $40 ProComp shocks to the $110 Fox shocks...might get them revalved.
04-15-2012 09:51 AM
tcate23-97 I'm still trying to figure out the bumpstop/jounce bumper situation. I went to the junkyard and got jounce bumpers form a ZJ, i only could find 2. I need to go get bumpstop cups and 2 more jounce bumpers from the yard. Do my spring towers look short in the front? Also need bumpstop extensions... Last post installation observation is the exhaust is very close to the rear shock and is leaving burn marks on it


Also had to put some washers in to drop the tcase a bit unfortunately...
04-15-2012 09:46 AM
tcate23-97 Finally got it all installed and got it aligned. The front is lower than the rear because of the winch and stinger. I currently don't have a back seat in so that's part of it. Still need to get my hands on a stock sway bar since there wasn't one when I bought it.



04-15-2012 09:40 AM
tcate23-97 I really wish I took more pictures during the install but I didn't. The MML was a pain in the *** and two of the body mounts won't screw back in from the BL. Then, I couldn't get the front trackbar off and it delayed the install a day. My dad and I had to grind the trackbar off, huge delay.

04-15-2012 09:36 AM
tcate23-97 I started to save up for my new suspension. Once I had enough and did a lot of research, I ordered the following:
BDS 3" springs
Fox 2.0 Performance Shocks
JKS Front and Rear adjustable trackbars
JKS BL
Browndog MML
04-15-2012 09:32 AM
tcate23-97 I decided to return the winch plate and get a new front bumper and replace the crappy tube bumpers. I looked for a while and decided to try the Metal Cloak, I got a really good deal on it thanks to Matson!



Forgot to mention, I also took off the rear bumper and put a stock one on the my buddy gave me. Sold the tube bumpers on CL.
04-15-2012 09:24 AM
tcate23-97 Was aligning the steering with my dad when installing the new power steering gearbox and broke the clockspring... So had to go pick up a new one.

This thread has more than 15 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

 
For the best viewing experience please update your browser to Google Chrome