JeepForum.com - Reply to Topic
Thread: Flashpaq Superchips F5 doesn't make a difference??? Reply to Thread
Title:
Message:
Post Icons
You may choose an icon for your message from the following list:
 
 
 
   

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
05-14-2021 09:02 AM
jserna From my experience, the mileage setting sucks. It detunes the engine to much for where I live. It did work pretty well in Californina on the highway through the flat country.
05-14-2021 07:06 AM
smokeyyank Lifted or stock? Bigger tires or stock? What PSI your tires at? When's the last time you did a tune up (air filter, plugs, etc) ?
05-13-2021 10:23 PM
xcaliber81 I honestly don't keep track of my fuel mileage I probably should lol. I use the 87 tune I get regular 10 cents cheaper at the card lock I use. A few years ago going from prince george bc to MacKenzie id go there 200 km on a Monday use it back and forth to work for a week and Friday I went home 200 kms again all on 1 tank so roughly 430 ish kms? Usually my fuel light was on by the time I went back to the same card lock. I have a heavy foot too.
05-13-2021 09:20 PM
JoMc67 Well, I have an 01' Durango w/4.7 (HO Manifold & Cams) also use the Stupidchips @87 Octane Summer Gas and getting around 275 per Tank in Town, 350 Highway, and 325 Highway/City Combined...Anyways, somfink like that :-)

Thinking of changing out the Fuel Filter and Regulator in hopes to get even more Mileage.
05-13-2021 12:45 PM
dig4gold
Flashpaq Superchips F5 questions???

I've reprogramed my '04 WJ w/4.7HO a dozen or more times and I'm still getting lousy gas mileage in town. Maybe 200-225 miles per tank. I drive with an egg under my foot and rarely put my foot in it. Fun when I do though!! I've tried clearing it to stock before programming, and re-programming without returning it to stock and no difference. I've also drove it stock for a tank or so and no significant difference. Am I doing something wrong? Or should I just sell the damn thing?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome