JeepForum.com - Reply to Topic
Thread: Jk 2012 3.6 strange loud front noise Reply to Thread
Title:
Message:

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
04-11-2015 08:49 AM
rallyman78 Just solve the problem! Change all 3 idler pulley.
03-07-2015 08:36 AM
jwmbishop
Quote:
Originally Posted by rallyman78 View Post
Tks Paio2012 this is do great to gear! I will try!
Do Maserati idlers increase HP? 😁
03-06-2015 08:25 PM
rallyman78 Tks everybody! I will change the idler pulley and than I will Tell the resulta!
03-06-2015 08:24 PM
rallyman78
Quote:
Originally Posted by Paio2012
Just in case. The Jeep 2012 on pulleys are the same of the Citroen Picasso 2.0. See part number VKM4913. They are much cheaper comparing to the ones provided by Mopar in Brazil.
Tks Paio2012 this is do great to gear! I will try!
03-06-2015 05:26 PM
SlyDawg64
Quote:
Originally Posted by rallyman78 View Post
Did they change only the bearing or the water pump?
They changed out the whole water pump.
03-06-2015 11:19 AM
jwmbishop
Quote:
Originally Posted by rich6700 View Post
There are two idler pulleys, replace them both
DITTO!!! But again - with the belt off you can usually FEEL the bad one...

Quote:
Originally Posted by Paio2012 View Post
Just in case. The Jeep 2012 on pulleys are the same of the Citroen Picasso 2.0. See part number VKM4913. They are much cheaper comparing to the ones provided by Mopar in Brazil.
Thanks - I love interchange info!

Quote:
Originally Posted by Paio2012 View Post
There is no bearing on the water pump. It is a quality issue not solved yet by the factory.
no SERVICEABLE bearings....
03-06-2015 10:56 AM
Paio2012
Quote:
Originally Posted by SlyDawg64 View Post
Myself and a number of friends have had the same problem after dirty/dusty wheeling and found that the water pump bearing was going out. Took it to dealer who replaced it under warranty with no problem.
There is no bearing on the water pump. It is a quality issue not solved yet by the factory.
03-06-2015 10:54 AM
Paio2012
Quote:
Originally Posted by rallyman78 View Post
Went to mechanics shop today and listen With stetoscope to the idler pulley, and we think os one of it. Just order the pulley
Just in case. The Jeep 2012 on pulleys are the same of the Citroen Picasso 2.0. See part number VKM4913. They are much cheaper comparing to the ones provided by Mopar in Brazil.
03-06-2015 10:50 AM
Paio2012 I replaced the three pulleys and the alternator bearing and the noise continued. It was the water pump where the noise was coming from. Replaced yesterday with 49000Km. Looks fine now.
03-05-2015 07:52 PM
rich6700 There are two idler pulleys, replace them both
03-05-2015 07:41 PM
rallyman78 Went to mechanics shop today and listen With stetoscope to the idler pulley, and we think os one of it. Just order the pulley
03-05-2015 07:26 AM
rallyman78
Quote:
Originally Posted by rubicon1000
The issue is a pulley bearing they are not sealed and sand and grit gets in there and destroys them. I had the same issue on my 2012 when I lived in Florida had it changed under-warranty.
Do you know which pulley can be?
03-05-2015 07:21 AM
rallyman78
Quote:
Originally Posted by SlyDawg64
Myself and a number of friends have had the same problem after dirty/dusty wheeling and found that the water pump bearing was going out. Took it to dealer who replaced it under warranty with no problem.
Did they change only the bearing or the water pump?
03-05-2015 07:09 AM
SlyDawg64 Myself and a number of friends have had the same problem after dirty/dusty wheeling and found that the water pump bearing was going out. Took it to dealer who replaced it under warranty with no problem.
03-04-2015 01:20 PM
jwmbishop Not on the JK - but the F250 started sounding like that and 125 miles later (while towing the JK) - the belt shredded and the idler pulley launched...
This thread has more than 15 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome