Manual Transmission SOS - JeepForum.com
 
LinkBack Thread Tools
post #1 of 3 Old 06-16-2021, 02:50 PM Thread Starter
ladyJ33P
Registered User
 
Join Date: Mar 2021
Posts: 1
Manual Transmission SOS

Hey all,

So I’m the owner of a 2010 Compass Sport, 2.4L Manual 5-speed Transmission Jeep.

I’ve had the car since 2018 and so far it’s been a dream!

May 24th, my Jeep was making some loud whirring-propeller like noises when I let the clutch out. This happened both idle and in motion.

I spoke with 2 mechanics and ultimately had to take the car in to the local dealer.

It was diagnosed as there were faulty bearings in the transmission.
Specifically the input shaft and counter shaft bearings were worn down.
The tech replaced both input shaft and counter shaft bearings, resealed and reassembled, test drove the car and it was okay.

I paid $1635 out of pocket to get this fixed.

June 10th I was commuting to work, about 15-20min in, and my stick, OUT OF NOWHERE, popped out of 5th gear straight into neutral.

I gave it one more day to see if the issue would persist. And it did!
FYI I’m driving on a fairly smooth highway at a healthy 70/75mph.

All of my other gears shift into place and stays. It’s only been 5th that has had this issue. Do you guys have any idea what could be the cause of this? Is this indicative of clutch failure?
Is there something that needs to be looked at specifically?
Advice welcomed!

ladyJ33P is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 06-16-2021, 06:47 PM
klaxmaster
Registered User
 
klaxmaster's Avatar
1993 ZJ 
 
Join Date: Nov 2018
Location: San Jose
Posts: 101
Garage
Someone correct me here if I am wrong, but if it was the clutch wouldn't she be just as likely to pop out of any gear, not just fifth gear?

My initial thought was the linkage may have needed adjustment after the bearings were installed, but then I don't know why it would have had a delayed reaction by several days before popping out the first time.



Sent from my LM-G820 using Tapatalk

If it ain't broke, fix it with a larger part.
klaxmaster is offline  
post #3 of 3 Old 06-17-2021, 11:46 PM
klaxmaster
Registered User
 
klaxmaster's Avatar
1993 ZJ 
 
Join Date: Nov 2018
Location: San Jose
Posts: 101
Garage
A little dead in here...

Sent from my LM-G820 using Tapatalk

If it ain't broke, fix it with a larger part.
klaxmaster is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome