Help front brake issue - JeepForum.com
 
LinkBack Thread Tools
post #1 of 1 Old 09-28-2015, 04:22 AM Thread Starter
cwilliams469
Registered User
1995 XJ Cherokee 
 
Join Date: Dec 2009
Location: phelps
Posts: 118
Help front brake issue

I got a 07 patriot and I replaced the front brake passing bolted the pins and set caliper on rotor pryed the old worn pads off I also pryed old rattle clips as the new pads wouldn't fit with them in , so I opened brake reservoir, compressed the caliper piston, lined up the pads slid them in the open slots, and lubed the pins and bolted them down and reassembled each side and put tires on and the tires didn't move just thought the caliper needed to relax and it would be fine after a short drive, drove it around the block and there hanging up and can't get past 3 gear what did I do wrong?? Any ideas none of the calipers hung by the hose or seemed sticky

cwilliams469 is offline  
Reply

Tags
brakes , front brakes , pads

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome