2018 Jeep Compass Limited Uconnect Issue - JeepForum.com
 
LinkBack Thread Tools
post #1 of 6 Old 12-20-2017, 12:35 PM Thread Starter
kjazzy
Registered User
 
Join Date: Dec 2017
Posts: 4
2018 Jeep Compass Limited Uconnect Issue

I have a 2018 Compass Limited. I'm having major issues with the Uconnect and being able to talk on the phone. dealer replaced the radio to a brand new one. I try and make a phone call and I cut in and out or the other person simply can't hear me. They thought issue was fixed by replacing the entire radio system. However, it still isn't. any idea of what could be the issue??

kjazzy is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 12-20-2017, 01:49 PM
JeepCares
FCA Customer Care
 
JeepCares's Avatar
 
Join Date: Jan 2012
Location: MOPAR World Headquarters
Posts: 5,774
Quote:
Originally Posted by kjazzy View Post
I have a 2018 Compass Limited. I'm having major issues with the Uconnect and being able to talk on the phone. dealer replaced the radio to a brand new one. I try and make a phone call and I cut in and out or the other person simply can't hear me. They thought issue was fixed by replacing the entire radio system. However, it still isn't. any idea of what could be the issue??
Hi kjazzy,

This is certainly not the experience we want you to have with a brand new Compass! Is your dealership still currently investigating/diagnosing?

Kori
Jeep Social Care Specialist
JeepCares is online now  
post #3 of 6 Old 12-21-2017, 11:52 AM Thread Starter
kjazzy
Registered User
 
Join Date: Dec 2017
Posts: 4
Hi Kori
they are looking in to this issue. They have not had this before so they are not sure what to do. When I plug into carplay it does the same thing. could it be the microphone in the car? or maybe a wire is lose or there is a short somewhere? Dealer says they hooked their phone up and it worked just fine. However every time I try to call using the hands free option with the car the people get annoyed as they can't hear me and I'm shouting.
kjazzy is offline  
 
post #4 of 6 Old 12-22-2017, 12:54 PM
JeepCares
FCA Customer Care
 
JeepCares's Avatar
 
Join Date: Jan 2012
Location: MOPAR World Headquarters
Posts: 5,774
Quote:
Originally Posted by kjazzy View Post
Hi Kori
they are looking in to this issue. They have not had this before so they are not sure what to do. When I plug into carplay it does the same thing. could it be the microphone in the car? or maybe a wire is lose or there is a short somewhere? Dealer says they hooked their phone up and it worked just fine. However every time I try to call using the hands free option with the car the people get annoyed as they can't hear me and I'm shouting.
Hi kjazzy,

Your local dealership will be in the best position to offer an official diagnosis. If you require further assistance during your appointment please send us a PM with your VIN and let me know!

Andrea
Jeep Social Care Specialist
JeepCares is online now  
post #5 of 6 Old 04-02-2018, 09:20 AM Thread Starter
kjazzy
Registered User
 
Join Date: Dec 2017
Posts: 4
Still. Not working and still no response from dealer. Has there been any connect issues with the 2018 compass?
kjazzy is offline  
post #6 of 6 Old 07-09-2018, 07:58 PM
Jarvis2000
Registered User
 
Join Date: Jul 2018
Posts: 1
We have a 2018 Jeep Compass Limited with 9000k - We have had very similar issues...BUT, it began with the car not turning off even though we tried several times pressing the start/stop button. After about 1/2 hour the car shut off on it's own - later on it began to hum, but don't know how long that remained as it had stopped by morning. The dealership could not duplicate the issue, even though it had happened to us two days in a row. As well, all voice commands worked except the temperature set. They kept the car for about a week. The 'mother computer board' was replaced as it was corroded (the car only had @5000km on it and 5 months old). They told us ~ there was to be an update arriving shortly for the radio/navigation and that would fix the issue of the voice command, but the not turning off remains a mystery. FYI - they checked ALL the compass limiteds on the lot and they had the same voice command temperature set issue.....interesting.?!
The car now has a new issue ~ engine stops (turns off) while I'm driving, emergency brake comes on and the 'D' on the gear box and panel cluster flashes and a message to the effect of 'put the car in park to start'. This new issue happened once on 2 consecutive days, not on the 3rd and then 2ce on the 4th day. I videoed it on the 4th day and this time I caught the 'oil pressure low' flash on then off. I would have missed it had I not been videoing it (I was safe in a very quiet residential area with little to no traffic so videoing it was a good idea). I showed it to the dealer. I am having it towed in this week - the dealership asked I check the oil in the car (it has 9000km on it now and due for a change). WHAT A SURPRISE - oil was practically non-existent and just registering on the twisted base of the stick. No oil in my driveway, or garage where I park it regularly, or at work in my designated parking spot. I'm surprised the engine didn't seize. No message about oil except the 'flash' message I caught on video?
BTW - the update for the radio that will 'fix' the voice command for the temperature is still not available 2.5 months later.
Looking forward to what's wrong with my brand new jeep now!
Jarvis2000 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome