winch problem - JeepForum.com
 1Likes
Reply
 
LinkBack Thread Tools
post #1 of 24 Old 07-15-2019, 02:14 AM Thread Starter
SC20K
Registered User
 
SC20K's Avatar
 
Join Date: Sep 2018
Posts: 44
winch problem

I went wheeling on the weekend and now my winch just makes a clicking sound everytime I press the buttons on the remote. Just one single click for every press. It spooled for about 1 second then just a click when the button is pressed. I didn't go through any deep water or anything. Just tiny puddles and lots of dust. The jeep, engine bay and interior are covered in dried dirt and dust. My under hood light stopped working also. Anyone know what this could be?

Its an 07 jkur.

Damn jeep 😫

SC20K is offline  
Sponsored Links
Advertisement
 
post #2 of 24 Old 07-15-2019, 02:51 AM
Prot
Registered User
 
Prot's Avatar
2014 JK Wrangler 
 
Join Date: Feb 2007
Location: Lafayette
Posts: 8,373
Check the electrical connections. They are likely loose or corroded.

2007 JK did not come with a light under the hood but that problem is probably loose or corroded connections as well.

2014 JKU Copperhead Pearl
Too many mods to list. Too awesome to sell.
Prot is offline  
post #3 of 24 Old 07-15-2019, 03:33 AM Thread Starter
SC20K
Registered User
 
SC20K's Avatar
 
Join Date: Sep 2018
Posts: 44
Yeah, I added the light. I'll have to check the wiring.

I'll have to open up the winch. I've been researching and apparently that click means the solenoid should be good but as youbsaid, the connections could be loose or corroded.
SC20K is offline  
 
post #4 of 24 Old 07-15-2019, 04:12 AM
Prot
Registered User
 
Prot's Avatar
2014 JK Wrangler 
 
Join Date: Feb 2007
Location: Lafayette
Posts: 8,373
It is easier to check the battery side first.

2014 JKU Copperhead Pearl
Too many mods to list. Too awesome to sell.
Prot is offline  
post #5 of 24 Old 07-15-2019, 04:40 AM Thread Starter
SC20K
Registered User
 
SC20K's Avatar
 
Join Date: Sep 2018
Posts: 44
Definitely will check that first
SC20K is offline  
post #6 of 24 Old 07-18-2019, 07:48 AM Thread Starter
SC20K
Registered User
 
SC20K's Avatar
 
Join Date: Sep 2018
Posts: 44
It's an older Champion 10,000 steel cable winch.

If only I could get into it. I contacted Champion, they said to send pics of the wich so they could suggest trouble shooting. I sent pics snd havent heard back. How do you get in? I really would prefer not to have to take it off the bumper if its possible. It's a pain in the ***.
Attached Thumbnails
20190718_063113_1563457701468.jpg   20190718_063106_1563457713103.jpg   20190718_063058_1563457737616.jpg   20190718_063052_1563457749344.jpg   20190718_063047_1563457758751.jpg  

SC20K is offline  
post #7 of 24 Old 07-18-2019, 10:19 PM
Prot
Registered User
 
Prot's Avatar
2014 JK Wrangler 
 
Join Date: Feb 2007
Location: Lafayette
Posts: 8,373
I see several allenhead bolts. Start there.

2014 JKU Copperhead Pearl
Too many mods to list. Too awesome to sell.
Prot is offline  
post #8 of 24 Old 07-19-2019, 08:16 AM Thread Starter
SC20K
Registered User
 
SC20K's Avatar
 
Join Date: Sep 2018
Posts: 44
Ok so I did the bench test and got no motor activation. I then tried the remote again and the motor spooled for half a second and that was it, just more single clicks when I pressed the buttons.

I'm waiting to hear back from Champion about how to open up the winch. I removed the bolts on the sides of tge control box and it won't open.
SC20K is offline  
post #9 of 24 Old 07-19-2019, 03:31 PM Thread Starter
SC20K
Registered User
 
SC20K's Avatar
 
Join Date: Sep 2018
Posts: 44
So, Champion tells me the motir is gone and a new one will cost $160 plus tax and shipping. They suggested that it might be more cost effective to purchase a new one.
SC20K is offline  
post #10 of 24 Old 07-19-2019, 09:58 PM Thread Starter
SC20K
Registered User
 
SC20K's Avatar
 
Join Date: Sep 2018
Posts: 44
Thanks everyone for the suggestions.
SC20K is offline  
post #11 of 24 Old 07-19-2019, 11:02 PM
Prot
Registered User
 
Prot's Avatar
2014 JK Wrangler 
 
Join Date: Feb 2007
Location: Lafayette
Posts: 8,373
There is a sale at quadratec right now and you can get a 9,000 pound winch for $300-$400

That being said I am always of the repair instead of replace mindset.

2014 JKU Copperhead Pearl
Too many mods to list. Too awesome to sell.
Prot is offline  
post #12 of 24 Old 07-20-2019, 01:14 PM Thread Starter
SC20K
Registered User
 
SC20K's Avatar
 
Join Date: Sep 2018
Posts: 44
Yeah true. Thecrepair would be much cheaper. Maybe I'll go that route. Thanks.
SC20K is offline  
post #13 of 24 Old 07-25-2019, 09:11 AM Thread Starter
SC20K
Registered User
 
SC20K's Avatar
 
Join Date: Sep 2018
Posts: 44
So Champion was kind enough to send me a brand new motor for the winch free of cost. I hope once I replace it, that was actually the problem and it works again. Either way, Champion definitely stepped up to the plate. Will update on that once I receive the motor.
SC20K is offline  
post #14 of 24 Old 07-25-2019, 09:26 AM
Prot
Registered User
 
Prot's Avatar
2014 JK Wrangler 
 
Join Date: Feb 2007
Location: Lafayette
Posts: 8,373
My bet is on the solenoid

2014 JKU Copperhead Pearl
Too many mods to list. Too awesome to sell.
Prot is offline  
post #15 of 24 Old 08-01-2019, 06:13 PM Thread Starter
SC20K
Registered User
 
SC20K's Avatar
 
Join Date: Sep 2018
Posts: 44
I'll replace the motor first and if it still doesn't work, I'll definitely look at the solenoid. 👍
SC20K is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome