ABS / Transmission Issues - JeepForum.com
 
LinkBack Thread Tools
post #1 of 1 Old 09-01-2021, 09:04 AM Thread Starter
Matwrangler
Registered User
 
Join Date: Sep 2021
Location: Pittsburgh
Posts: 1
Garage
ABS / Transmission Issues

Hi All,

A few months ago I hit a piece of plastic that detached from a vehicle in front of me and it passed under my front left wheel. The ABS light went on and stayed on for a day or two. I took the wheel down, checked that the ABS cable was not damaged and place the wheel back and the light went away.

However, since that time (and becoming more and more frequent), when I hit the road my abs light suddenly comes on for a short time and my transmission slips as a if I was going through a patch of ice or oily road. Sometimes it does that multiple times in a row and I cannot move forward. If I place the car in reverse though, I can backtrack to my garage.

Any idea of what is going on here and if I should take this to the dealership or can I fix this myself? I own a JK 2-doors 2015.

Thanks!

Matwrangler is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome