2012 JK Unlimited Sport 6spd, lights flashing on dash . - JeepForum.com
 
LinkBack Thread Tools
post #1 of 6 Old 07-21-2021, 03:57 AM Thread Starter
SamKline0229
Registered User
 
SamKline0229's Avatar
 
Join Date: Oct 2020
Posts: 4
2012 JK Unlimited Sport 6spd, lights flashing on dash .

Hey guys !
So I recently bought my 2012 Wrangler back in March 2021 . And it was fine just needed a few things . Recently when I was driving home last week my dash board lit up like a tree , ABS, traction control, Brake light . It will ping that they all came on , and they’ll all go away . Meanwhile , as they ping at the same time my speedometer will go crazy . Then in a matter of seconds it’ll all stop and be fine . But once you turn it off , all power dies immediately . And it takes at least an hour or so to come back on . We have checked the battery it’s at 100%, we check all the connections (so we think at least) and everything seems tight nothing seems loose .
Any advice ?
Thank you guys !

SamKline0229 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 07-21-2021, 08:21 PM
DocAdams1
Registered User
2016 JK Wrangler 
 
Join Date: Dec 2013
Posts: 153
Garage
I tried to post earlier, but had garbage signal. Do you have a scan tool or access to one? Not a code reader, but something that can monitor different data points?

If so I suggest starting with the ABS/TC/BRAKE lights that come and go. This could be as simple as a wheel speed sensor or something easy like a damaged wire. With the scan tool if no codes are there monitor the ABS data and see if everything is making sense. Let us know what you find.

What did you mean by the lose of power?
DocAdams1 is offline  
post #3 of 6 Old 07-22-2021, 03:49 AM Thread Starter
SamKline0229
Registered User
 
SamKline0229's Avatar
 
Join Date: Oct 2020
Posts: 4
I can see if we have one of those tools if not I’m use I can get one .

I will lose all power , as in , when I’m driving it is fine the lights will all flash on then go away , but the minute I turn off my Jeep it’s like I have a dead battery .

Typically when you open the door you’ll see the mileage . Well I won’t even see that everything will be blank I’ll put the key in and I won’t have anything .

Then about an hour or so later . It’s fine everything comes back on on the dashboard and it’ll start up again .

The person who had the Jeep before me had wired up pod lights on the push bar and it’s like a rats nest . I’m thinking it’s a bad ground or a bad connection somewhere in there . Because the battery meters at 100% .

We did try to jump start is the one time , we had jumper cables on another running vehicle . Did what we had to do . Even after it being connected for 5 minutes it still didn’t want to start . They lights on my dash (mileage & weather) would pop up . But it wouldn’t want to start. Then after a while when we gave up . It started up again . Like nothing happened .
SamKline0229 is offline  
 
post #4 of 6 Old 07-22-2021, 03:49 AM Thread Starter
SamKline0229
Registered User
 
SamKline0229's Avatar
 
Join Date: Oct 2020
Posts: 4
* I’m sure I can get one
SamKline0229 is offline  
post #5 of 6 Old 07-22-2021, 10:28 AM
DocAdams1
Registered User
2016 JK Wrangler 
 
Join Date: Dec 2013
Posts: 153
Garage
Ok it looks like there are 2 separate issues that need to be sorted out.

1. The no power issue.
2. The ABS/TC/BRAKE light issue.

For the first issue you are probably right as to the cause of the problem. If you have a rats nest of wires from bad installs that is a good place to start. Are there any additional connections to the battery itself? If so and they are the stock terminal connections where are they connected? What all is currently installed in the jeep that is aftermarket (electrical).

Post any codes or info you find. Where are you located there may be someone local that can give you a hand as well.
DocAdams1 is offline  
post #6 of 6 Old 07-22-2021, 01:03 PM Thread Starter
SamKline0229
Registered User
 
SamKline0229's Avatar
 
Join Date: Oct 2020
Posts: 4
No additional connections that I know of . I’m not sure if they’re stock or not to be honest . I bought it this way from the dealer . Once I do some digging I will definitely post an update !!!!!
Thank you so much !!!!
SamKline0229 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome