Still got popping in front, "New Trac bar?" - JeepForum.com
 
LinkBack Thread Tools
post #1 of 7 Old 07-03-2008, 12:59 AM Thread Starter
wrangler0415
Registered User
 
wrangler0415's Avatar
2004 TJ Wrangler 
 
Join Date: Jun 2008
Location: Minnesota
Posts: 190
Still got popping in front, "New Trac bar?"

I still got the bumping and popping in front of my wrangler..i feel it on my floor, since i have a 2.5 lift should i invest in a new trac bar? i tightened up the bolt from the trac bar and the axle to 55ft lbs but not the castle nut from trac bar and the frame. should i try that even though it doesn't seem loose? The popping just pisses me off cause i just hate the noise and feeling that something is loose. It might not even be my trac bar..what else could it be? I already had my u-joints replaced.

wrangler0415 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 07-03-2008, 02:46 AM
carpekd
Registered User
2000 TJ Wrangler 
 
Join Date: Nov 2007
Location: AL
Posts: 605
Have you checked the ball joints?
carpekd is offline  
post #3 of 7 Old 07-03-2008, 03:17 AM Thread Starter
wrangler0415
Registered User
 
wrangler0415's Avatar
2004 TJ Wrangler 
 
Join Date: Jun 2008
Location: Minnesota
Posts: 190
ya, there's no give when i move them up and down and side to side
wrangler0415 is offline  
 
post #4 of 7 Old 07-03-2008, 03:47 AM
chiefkp
Registered User
2013 JK Wrangler 
 
Join Date: Mar 2007
Location: Connecticut
Posts: 266
Quote:
Originally Posted by wrangler0415 View Post
I still got the bumping and popping in front of my wrangler..i feel it on my floor, since i have a 2.5 lift should i invest in a new trac bar? i tightened up the bolt from the trac bar and the axle to 55ft lbs but not the castle nut from trac bar and the frame. should i try that even though it doesn't seem loose? The popping just pisses me off cause i just hate the noise and feeling that something is loose. It might not even be my trac bar..what else could it be? I already had my u-joints replaced.
You need to retighten the castle nut. chances are it is loose. Mine was, and I had popping until I retighten it.

2013 JK Rubicon, 2.5 BB 35 inch pro comp M/T
chiefkp is offline  
post #5 of 7 Old 07-03-2008, 06:00 AM
Jerky bump
Guest
 
Join Date: Jan 2007
Posts: 1,177
With the tires on the ground and someone cycling the steering, it should become obvious if the problem is in part of the steering (the trackbar is affected when steering). Other than that, did you check the control arms and brackets?
The popping noise I had in mine was the swaybar links. The "ball" would wedge itself in the socket part and only under a hard turn, it would !pop!. I literally had to jump on the bumper to get it to pop to find it.
Jerky bump is offline  
post #6 of 7 Old 07-03-2008, 08:57 AM
UTmike
Registered User
 
UTmike's Avatar
2002 TJ Wrangler 
 
Join Date: Feb 2006
Location: Rochester
Posts: 1,183
I had a similar problem. The below thread has lots of people's suggestions of possible problems. Mine ended up being a loose control arm. Good luck!

https://www.jeepforum.com/forum/showthread.php?t=512851

4.5" RE Long Arm, 37" Mud Grapplers on Beadlocks, OX Locked Dana 60s front and rear
UTmike is offline  
post #7 of 7 Old 07-03-2008, 01:53 PM Thread Starter
wrangler0415
Registered User
 
wrangler0415's Avatar
2004 TJ Wrangler 
 
Join Date: Jun 2008
Location: Minnesota
Posts: 190
thanks guys..i'll take a look
wrangler0415 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Popping in front end? (After 2" lift) tomk864 TJ Wrangler Technical Forum 5 07-03-2008 03:47 PM
Clutch "popping"....coming only from pedal. This is caused by.... Sparty TJ Wrangler Technical Forum 8 09-10-2007 07:32 AM
Strange "popping" sound when starting from a stop DaOne TJ Wrangler Technical Forum 22 07-03-2007 06:28 PM
"Popping" Noise while steering resolved!!!!!!! Mr Ouija TJ Wrangler Technical Forum 0 01-30-2007 03:44 PM
"Popping" Noise in steering Mr Ouija TJ Wrangler Technical Forum 6 01-30-2007 12:01 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome