SpeedoHealer-Issues and Cracked - JeepForum.com
 
LinkBack Thread Tools
post #1 of 7 Old 05-15-2019, 09:36 PM Thread Starter
explorerlyon
Registered User
 
explorerlyon's Avatar
2005 LJ Wrangler 
 
Join Date: Jun 2009
Location: Valencia, CA
Posts: 689
SpeedoHealer-Issues and Cracked

I have had this SpeedoHealer installed since about 2010. Mounted to the firewall next to the ECU. My guess is heat has caused the cracks and the unit to fail. Anyone else see this before? Where have you mounted yours to prevent too much heat? The cables were mounted secure and zip tied to relieve any strain or pulling on the unit as well.

Suggestions for mounting the next one?

Attached Thumbnails
20190515_210250_resized.jpg   20190515_210335_resized.jpg   20190515_210314_resized.jpg  

05 Rubicon Unlimited, Automatic
explorerlyon is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 05-16-2019, 05:30 AM
rikkards
Web Wheeler
 
rikkards's Avatar
1998 TJ Wrangler 
 
Join Date: Jun 2008
Location: Ottawa
Posts: 4,538
Had mine about 5 years and is next to the brake master cylinder. No issues. That is a lot of heat. Have you contacted them?

Machete don't tweet
- Machete
rikkards is offline  
post #3 of 7 Old 05-16-2019, 12:16 PM Thread Starter
explorerlyon
Registered User
 
explorerlyon's Avatar
2005 LJ Wrangler 
 
Join Date: Jun 2009
Location: Valencia, CA
Posts: 689
Quote:
Originally Posted by rikkards View Post
Had mine about 5 years and is next to the brake master cylinder. No issues. That is a lot of heat. Have you contacted them?
I did contact them. First one they have ever seen like this. Definitely not a common problem.

05 Rubicon Unlimited, Automatic
explorerlyon is offline  
 
post #4 of 7 Old 05-17-2019, 05:44 AM
Zeep
Registered User
 
Zeep's Avatar
2005 LJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit rock city
Posts: 1,112
Garage
Mines been next to the ECU, like yours for 4 or so years. No issues yet!

JEEP THE AR-15 OF THE AUTOMOTIVE WORLD
Zeep is offline  
post #5 of 7 Old 05-17-2019, 10:09 AM
TJnBC
Registered User
2006 LJ Wrangler 
 
Join Date: Mar 2010
Location: Vancouver
Posts: 1,928
I have a yellow box healer and I have it routed into my Cab

2006 LJR...the madness begins again
TJnBC is offline  
post #6 of 7 Old 05-17-2019, 10:56 AM
2jhanna
Web Wheeler
2002 TJ Wrangler 
 
Join Date: Jun 2007
Location: Denton County, TX
Posts: 8,904
Quote:
Originally Posted by explorerlyon View Post
I did contact them. First one they have ever seen like this. Definitely not a common problem.
Just courious, are they charging you for a new one ?

I guess 9 years is out of any warranty though.

I am multi-talented, I can talk and piss you off at the same time.

jhanna
denton county, tx
2jhanna is offline  
post #7 of 7 Old 05-20-2019, 07:54 AM Thread Starter
explorerlyon
Registered User
 
explorerlyon's Avatar
2005 LJ Wrangler 
 
Join Date: Jun 2009
Location: Valencia, CA
Posts: 689
Quote:
Originally Posted by 2jhanna View Post
Just courious, are they charging you for a new one ?

I guess 9 years is out of any warranty though.
Yes, I paid full price for a new one.

05 Rubicon Unlimited, Automatic
explorerlyon is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Advice for repair or replace cracked frame islandtracey Jeep CJ Forum 12 11-26-2018 08:48 AM
Aftermarket radiator issues kalpol ZJ Grand Cherokee Forum 10 04-08-2018 09:55 AM
2004 Jeep Liberty Sport Water Pump issues MizMuffy Engines & Drivetrain 0 03-27-2018 05:23 PM
Symptoms of a cracked head? mgar64 XJ Cherokee Technical Forum 4 12-22-2017 01:37 AM
lift kit suspension issues 549913 Jeep MK Compass & Patriot Forum 1 12-08-2017 08:06 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome