Spazzing Left Blinker / Indicator / Turn Signal - JeepForum.com
 
LinkBack Thread Tools
post #1 of 14 Old 06-07-2007, 10:06 AM Thread Starter
rjcarrillo1911
Registered User
2005 TJ Wrangler 
 
Join Date: Mar 2007
Location: SC
Posts: 91
Spazzing Left Blinker / Indicator / Turn Signal

Just started the other night on my 2005 TJ Sport. The left turn signal blinks at double the normal speed. The right one is still functioning properly and the when the hazards are on they both function properly. Its been happening for about 3 days. I'm probably going to try and pull the fuse and put it right back and see if that remedies the problem. Any input? Has anyone else ever experienced this same problem?

It used to happen to me once in a while on my 2000 Ford Explorer, but it would go away after a little while. It would smoke a little bit too right behind the steereing wheel where the button for the hazards was and smell like something was burning (with the explorer). I thought it was from me installing an after market stereo, but that didn't really make any sense.

rjcarrillo1911 is offline  
Sponsored Links
Advertisement
 
post #2 of 14 Old 06-07-2007, 10:09 AM
GW
Registered User
2015 JK Wrangler 
 
Join Date: Apr 2001
Location: Marquette
Posts: 169
From my experience on other cars, that usually an indication that the signal rely is about to go kaput.
GW is offline  
post #3 of 14 Old 06-07-2007, 10:12 AM
njbowhntr
Registered User
2005 TJ Wrangler 
 
Join Date: Apr 2006
Location: Oxford
Posts: 430
One of your blinker lights is out on that side. Of it was both sides then it would be a fuse or your flasher.

Ron
US Navy 1993-'97
njbowhntr is offline  
 
post #4 of 14 Old 06-07-2007, 10:28 AM
skinton
Registered User
1998 TJ Wrangler 
 
Join Date: Nov 2004
Location: central Ohio
Posts: 271
Are all the light on working? Try you hazards. Check grounds.

I had this problem on my 98. I didn't have the tailight grounded properly are I had taken it off to mount light guards.

1998 TJ Sport, 4.0L - 5 sp
2013 JKU Sport, 3.6L - 6 sp
skinton is offline  
post #5 of 14 Old 06-07-2007, 11:01 AM
thejafe
Registered User
 
thejafe's Avatar
2004 TJ Wrangler 
 
Join Date: Oct 2003
Location: Westchester, NY
Posts: 5,594
Quote:
Originally Posted by njbowhntr
One of your blinker lights is out on that side. Of it was both sides then it would be a fuse or your flasher.
Same thing happened to me and yep, needed a bulb.
thejafe is offline  
post #6 of 14 Old 06-07-2007, 12:22 PM
JDEEEWP
Registered User
2001 TJ Wrangler 
 
Join Date: Jan 2003
Location: New Hampshire
Posts: 416
Quote:
Originally Posted by njbowhntr
One of your blinker lights is out on that side.
same here only i also noticed that after the turn when the directional was off. the indicator light stayed on. seemed that it was telling me that my blinker was out on that side. sometimes i think my jeep is smarter then me.

'01 TJ Sport (black), 4.0L, 5speed, Dana44, Flowmaster 50, 2"BB + OME, 32"ATs on 16" alloys.
'01 Suzuki GSX-R750(red), -1T 520 kit.
JDEEEWP is offline  
post #7 of 14 Old 06-09-2007, 08:48 AM Thread Starter
rjcarrillo1911
Registered User
2005 TJ Wrangler 
 
Join Date: Mar 2007
Location: SC
Posts: 91
checked the lights...

...sure enough, rear bulb was out. The manual also mentions the same thing. Thanks for the help! Picked up some new bulbs last night, plan on changing it today.
rjcarrillo1911 is offline  
post #8 of 14 Old 06-09-2007, 11:00 AM
KeithMutiny
Guest
 
Join Date: Mar 2006
Posts: 99
its simple, its the bulb, thats the indicator that one of the functions arent working, have someone check while you test your signals and brake lights, and just swap the bulb.

*edit* - and im too late, hahaha.
KeithMutiny is offline  
post #9 of 14 Old 06-09-2007, 11:20 AM
metfan34
Guest
 
Join Date: Jun 2006
Posts: 158
my left signal will not styay on when i activate it however the lights work nad the right signal will not pop back up after turning when i complete my right turns? any suggetstions?
metfan34 is offline  
post #10 of 14 Old 06-09-2007, 12:01 PM
KeithMutiny
Guest
 
Join Date: Mar 2006
Posts: 99
Quote:
Originally Posted by metfan34
my left signal will not styay on when i activate it however the lights work nad the right signal will not pop back up after turning when i complete my right turns? any suggetstions?
sounds like the multi function switch, which is actually that entire unit comming out of the steering column, but i would check your flasher relays first, just incase.
KeithMutiny is offline  
post #11 of 14 Old 06-09-2007, 12:22 PM
Jonny Jeep
Web Wheeler
 
Jonny Jeep's Avatar
1997 TJ Wrangler 
 
Join Date: Feb 2007
Location: Manchester
Posts: 6,794
Quote:
Originally Posted by metfan34
my left signal will not styay on when i activate it however the lights work nad the right signal will not pop back up after turning when i complete my right turns? any suggetstions?
Repair the multifunction switch if you can get the spring size you need. See this write up I did...

https://www.jeepforum.com/forum/showthread.php?t=421210

or spend $70 on a new switch.
Jonny Jeep is offline  
post #12 of 14 Old 07-06-2021, 03:27 PM
SeaLawyer
Registered User
2003 TJ Wrangler 
 
Join Date: Jun 2021
Posts: 20
Quote:
Originally Posted by GW View Post
From my experience on other cars, that usually an indication that the signal rely is about to go kaput.

My son's '03 is doing this randomly. I replaced the bulb, and it stopped for a few days, but now it's back. I suppose the bulb could have been faulty, but thinking it's something else. Relay?
SeaLawyer is offline  
post #13 of 14 Old 07-25-2021, 07:45 PM
SeaLawyer
Registered User
2003 TJ Wrangler 
 
Join Date: Jun 2021
Posts: 20
Quote:
Originally Posted by SeaLawyer View Post
Quote:
Originally Posted by GW View Post
From my experience on other cars, that usually an indication that the signal rely is about to go kaput.

My son's '03 is doing this randomly. I replaced the bulb, and it stopped for a few days, but now it's back. I suppose the bulb could have been faulty, but thinking it's something else. Relay?
Having the same issue. Anyone have any thoughts?
SeaLawyer is offline  
post #14 of 14 Old 08-01-2021, 09:56 PM
KevinTJ2000
Registered User
2000 TJ Wrangler 
 
Join Date: Jul 2021
Posts: 12
This was a dirty switch stock on my 2000. Spray some electrical contact cleaner straight down into the switch stock through the hazard light activation switch opening on the steering column and cycle the hazard lights on and off. This is now scheduled preventive maintenance on my Jeep every few years. If I new I could find a replacement part as good as the original, I would replace it. Cleaning as prescribed completly solved this issue and the problem has never returned.
KevinTJ2000 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Left turn indicator when I hit the Brake hunter44102 TJ Wrangler Technical Forum 6 04-17-2010 02:38 PM
New turn signal switch, no left signal? sasquachYJ YJ Wrangler Technical Forum 4 01-25-2010 09:07 PM
Fog lights turn off when left blinker is on phxdrumpro TJ Wrangler Technical Forum 4 02-15-2009 07:22 PM
Need to hear turn signal indicator...seriously Obcean2 YJ Wrangler Technical Forum 8 02-06-2008 05:51 PM
Blinker turn signal crapping out Jgw50 TJ Wrangler Technical Forum 6 04-06-2006 12:00 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome