Shouldn't my AC blow colder than 58? - JeepForum.com
 7Likes
Reply
 
LinkBack Thread Tools
post #1 of 26 Old 07-03-2021, 07:28 AM Thread Starter
joeyroe
Registered User
2000 TJ Wrangler 
 
Join Date: Jan 2018
Posts: 145
Shouldn't my AC blow colder than 58?

I've already taken my jeep to 3 different shops, and each time they just evacuate/recharge my system, tell me my pressures are good, BUT nobody can make it blow colder than 58 degrees.

Maybe I'm being too picky, but I think it should blow colder. Assuming I'm right, does anyone have any ideas where the problem lies?

Further details...
  • Heat and defraust work fine
  • Blend door seems to work (I think) because I can turn on/off heat
  • Compressor and fans seem to work fine
  • No evidence of any leaks


joeyroe is offline  
Sponsored Links
Advertisement
 
post #2 of 26 Old 07-03-2021, 07:44 AM
Silverstoneavb
Registered User
2001 TJ Wrangler 
 
Join Date: Dec 2010
Location: tempe
Posts: 28
I'm pretty certain the condenser is what regulates how cool the freon is. Look there if you have problems with temp. I've been experiencing my HVAC not being as cool also but pretty sure that's been due to AZ being 110+. It just can't keep up

Sent from my Pixel 4 using Tapatalk
Silverstoneavb is offline  
post #3 of 26 Old 07-03-2021, 04:28 PM
badmoose
Registered User
2005 TJ Wrangler 
 
Join Date: Jan 2012
Location: valley center
Posts: 149
My old rule of thumb on ag equipment was 40 degrees below ambient temperature.

2005 TJ
Zone 3" suspension lift
General Grabber AT2's 33x12.5x15
badmoose is offline  
 
post #4 of 26 Old 07-03-2021, 07:59 PM
jeep_boy02
Registered User
1934 CJ7 
 
Join Date: Dec 2012
Location: Joplin
Posts: 750
Garage
Quote:
Originally Posted by badmoose View Post
My old rule of thumb on ag equipment was 40 degrees below ambient temperature.
Yes... it depends on ambient air temp and pressures. I believe residential is around 30 cooler so that's a good ballpark.

Did you get a reading printout or a look at the gauges? Compressor could be in the green but on the low side instead of a midzone reading. Working but not working as well as it should you know.

Also double check the condenser fins aren't mashed about. Lowes has a fin straightener for like $8.


Sent from my SM-A015A using Tapatalk
joeyroe likes this.

80 CJ7-304/T176/D300 HEI hdrs-WT D30/D44 4.56s, lockright/spool-SOA YJs W/RE AAL-35 MTRs beadlocks
jeep_boy02 is offline  
post #5 of 26 Old 07-05-2021, 06:05 AM
TheBoogieman
Disturbed Jeepaholic
 
TheBoogieman's Avatar
2003 TJ Wrangler 
 
Join Date: Aug 2006
Location: charlottesHELL
Posts: 41,433
https://drivrzone.com/proper-auto-ac-vent-temperature/
joeyroe likes this.

Quote:
Originally Posted by jeepinmichguy_ View Post
TheBoogieman is a jerk.
2003' Rubicon/Zone 4.25" combo lift with Rancho RS5000X shocks/ Zone hydro shocks/5.13 gears/35" Mickey Thompson MTZ P3 tires/Black Magic brakes. Jeep #17 & 19.
TheBoogieman is offline  
post #6 of 26 Old 07-27-2021, 07:43 AM
henderson49
Registered User
2004 TJ Wrangler 
 
Join Date: Jul 2016
Location: franklin TN
Posts: 44
58 is warmer than it should be. The general rule is 40 below ambient air temp, but mine will reach 45 even when outside temp is 95. Park in the shade, close the side vents and measure temp in the middle air vent on dash-set the blower on second setting (not wide open) and give it 4-5 minutes to reach lowest temp. About a year ago I had to replace compressor/condenser and 2 switches to get it to operate where it had been.
joeyroe likes this.
henderson49 is offline  
post #7 of 26 Old 07-27-2021, 04:57 PM Thread Starter
joeyroe
Registered User
2000 TJ Wrangler 
 
Join Date: Jan 2018
Posts: 145
Related Question...?
Do you think it might help to insulate the Liquid line that runs from the condenser to evaporator?
It seems logical since it's the longest "cold" AC line and it's exposed to scorching engine heat. Unless I'm mistaken, the orifice is on the condenser side of the line which explains why the entire line is cold (albeit, barely after engine is hot).
joeyroe is offline  
post #8 of 26 Old 07-28-2021, 07:30 AM
henderson49
Registered User
2004 TJ Wrangler 
 
Join Date: Jul 2016
Location: franklin TN
Posts: 44
Update on my AC. Noticed yesterday the air from vent seemed warmer with full blower setting. Admittedly it was 90+ degrees outside. Got home and checked the temp, in the shade at second blower speed and side vents closed as recommended. Engine idle at 1500 RPM's. Got 45 degrees at second blower speed and 60 degrees at full blower speed (on recirculate setting). Not sure if the 60 degree rating is because of higher ambient temp or not.
henderson49 is offline  
post #9 of 26 Old 07-28-2021, 08:23 AM
TheBoogieman
Disturbed Jeepaholic
 
TheBoogieman's Avatar
2003 TJ Wrangler 
 
Join Date: Aug 2006
Location: charlottesHELL
Posts: 41,433
I've never had to check AC temps ever. If it's 100 degrees outside (95% or higher humidity regularly) and I'm comfortable with the AC on medium, I'm good. It takes under 10 minutes to check it with a gauge and add R-134 to the system. I buy the stuff with stop leak and oil, just in case.

Quote:
Originally Posted by jeepinmichguy_ View Post
TheBoogieman is a jerk.
2003' Rubicon/Zone 4.25" combo lift with Rancho RS5000X shocks/ Zone hydro shocks/5.13 gears/35" Mickey Thompson MTZ P3 tires/Black Magic brakes. Jeep #17 & 19.
TheBoogieman is offline  
post #10 of 26 Old 08-01-2021, 06:07 PM
aston4
Registered User
 
Join Date: Oct 2016
Posts: 27
I think you should investigate the blend door more thoroughly.

Also make sure the evaporator isn't freezing up. I just went through this issue, it was a combination of a little too much freon and a blocked drain hole.
aston4 is offline  
post #11 of 26 Old 08-03-2021, 03:32 PM
tr21triton
Registered User
1997 TJ Wrangler 
 
Join Date: Dec 2013
Location: Blue Ridge
Posts: 128
my a/c pressure's are low on both the low and high side. i get 30 on the low side and 190 on the high side . vacumed the system and replaced all the o-rings then added freon and it never came up. air was cold but not in the range or pressures in the manual. added more freon and still wouldn't come up.
tr21triton is offline  
post #12 of 26 Old 08-04-2021, 10:14 AM
aston4
Registered User
 
Join Date: Oct 2016
Posts: 27
Quote:
Originally Posted by tr21triton View Post
my a/c pressure's are low on both the low and high side. i get 30 on the low side and 190 on the high side . vacumed the system and replaced all the o-rings then added freon and it never came up. air was cold but not in the range or pressures in the manual. added more freon and still wouldn't come up.
those pressures ought to give you some cold air.

is the low pressure line cold? if it is, it's a venting/blockage issue
aston4 is offline  
post #13 of 26 Old 08-04-2021, 10:50 AM
aston4
Registered User
 
Join Date: Oct 2016
Posts: 27
aston4 is offline  
post #14 of 26 Old 08-04-2021, 10:56 AM
aston4
Registered User
 
Join Date: Oct 2016
Posts: 27
aston4 is offline  
post #15 of 26 Old 08-04-2021, 12:02 PM
tr21triton
Registered User
1997 TJ Wrangler 
 
Join Date: Dec 2013
Location: Blue Ridge
Posts: 128
Quote:
Originally Posted by aston4 View Post
those pressures ought to give you some cold air.

is the low pressure line cold? if it is, it's a venting/blockage issue
it got down to around 50. outside temp was 80 . fsm said i should get 33-44, low side should be 32-41, high side 200-260. i do notice i cant get it to blow out of the defrost vents, but does blow out the dash and floor. are you saying blend door problems, i'll have to check the l/p line....
tr21triton is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome