Rebuild or 4.6? - JeepForum.com
 
LinkBack Thread Tools
post #1 of 7 Old 06-18-2017, 10:37 PM Thread Starter
oceans8alaksa
Registered User
 
Join Date: Jun 2017
Location: visalia
Posts: 1
Garage
Rebuild or 4.6?

Hey i'm brand new here, I bought a jeep TJ back in September of 2016. I love my jeep, but mechanically it isn't sound. After about 3 months of owning it the head gasket blew, and I had to replace that, then I had a over heating issue and replaced the RAD and clutch fan. Now it still overheats when I use the AC, and when I turn off my jeep and come back say 10 minutes later it starts missing, but does not throw any code. On top of all these issues today when I turned it off and turned it back shorty after it just start making a weird lifter tick noise and a putting sound came from the exhaust and made it shake. So now i'm torn between two options, should I rebuild it? Or should I try putting in Golen's 4.6? ATK also makes a 4.7 but I have not heard much from them so I have no idea when it comes to this. Maybe some of you have a better Idea of what I could do, but to me it just sounds like I have a problem engine. I pulled up the car fax a while back it blew the head gasket back in 2009 as well and went in for engine shaking issue back in 2006. What would you do if you were in my position?

oceans8alaksa is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 06-19-2017, 05:53 AM
TheBoogieman
Disturbed Jeepaholic
 
TheBoogieman's Avatar
1999 XJ Cherokee 
 
Join Date: Aug 2006
Location: charlottesHELL
Posts: 39,850
Welcome to JF. Personally I'd just throw in a good used engine from a Junkyard or rebuild the current one. The few people I know with strokers, have had problems with them.
TheBoogieman is offline  
post #3 of 7 Old 06-29-2017, 07:59 PM
BigJake87
Registered User
1999 TJ Wrangler 
 
Join Date: Jun 2009
Location: Orlando, Fl
Posts: 219
My golen 4.6 puts off more heat than a stock 4.0
BigJake87 is offline  
 
post #4 of 7 Old 06-29-2017, 08:05 PM
NashvilleTJ
I miss the snow...
 
NashvilleTJ's Avatar
2004 LJ Wrangler 
 
Join Date: Jul 2010
Location: Nashville
Posts: 3,833
Quote:
Originally Posted by BigJake87 View Post
My golen 4.6 puts off more heat than a stock 4.0
Man, that is saying something - as much heat as the stocker puts out.

Build Thread:

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Swing Away / Swing Down Tire Carrier:

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
NashvilleTJ is offline  
post #5 of 7 Old 06-29-2017, 08:29 PM
BigJake87
Registered User
1999 TJ Wrangler 
 
Join Date: Jun 2009
Location: Orlando, Fl
Posts: 219
I had massive overheating issues which lead to my 4.0 downfall. Replaced with the 4.6 as well as all new cooling system. Finally have my operating temps under control but still have heat soak issues in the fuel rail even with dei wrap and hood vents.
BigJake87 is offline  
post #6 of 7 Old 06-30-2017, 04:32 AM
Athensdawgs81
Registered User
2002 TJ Wrangler 
 
Join Date: Mar 2014
Location: Cumming
Posts: 349
Garage
Quote:
Originally Posted by oceans8alaksa View Post
Hey i'm brand new here, I bought a jeep TJ back in September of 2016. I love my jeep, but mechanically it isn't sound. After about 3 months of owning it the head gasket blew, and I had to replace that, then I had a over heating issue and replaced the RAD and clutch fan. Now it still overheats when I use the AC, and when I turn off my jeep and come back say 10 minutes later it starts missing, but does not throw any code. On top of all these issues today when I turned it off and turned it back shorty after it just start making a weird lifter tick noise and a putting sound came from the exhaust and made it shake. So now i'm torn between two options, should I rebuild it? Or should I try putting in Golen's 4.6? ATK also makes a 4.7 but I have not heard much from them so I have no idea when it comes to this. Maybe some of you have a better Idea of what I could do, but to me it just sounds like I have a problem engine. I pulled up the car fax a while back it blew the head gasket back in 2009 as well and went in for engine shaking issue back in 2006. What would you do if you were in my position?
Most of the problems you describe are common and cheap to fix compared to replacing the motor.

- "10 minutes later it starts missing" There is a TSB for this. It is due to heat soak that causes the fuel to vaporize in an injector (can't remember which one, I think it's #2 or #3) and there is a simple piece of insulation you can get from stealership to fix this. The vaporized fuel causes the "missing" for a few moments after restart when the engine is shut down hot.

- Lifter ticks are quite common with 4.0's and are usually nothing worry about. My 4.0 has had lifter tick off and on for 60,000 miles. If it really bothers you replacing the lifters isn't that hard and much cheaper then new motor.

- rattling exhaust may just be from the missing from the heat soaked injector I mentioned earlier. If your exhaust is bad a new exhaust can be scored for pretty cheap and a bad exhaust doesn't warrant a new motor. My exhaust rattles every now and then but it's not leaking yet so I haven't bothered to replace it and the rattle is no worse then the tranny noise from having an NV3550.

- as for you over heating. Did you use an OEM radiator, change all the hoses, and have you checked/replaced the Tstat? Is it holding coolant or do you keep having to top it off? I tried getting by with just replacing my radiator earlier this year after the PO's non OEM replacement started leaking. Within 4 months of replacing the radiator I have replaced the water pump, Tstat, and all hoses and my 4.0 is finally holding coolant. All this was not cheap for sure but it's was cheaper then a new motor.

IMO the issues you are describing have much cheaper and simpler fixes then rebulding/replacing the motor. How many miles does your motor have?
Athensdawgs81 is offline  
post #7 of 7 Old 06-30-2017, 08:54 AM
TheBoogieman
Disturbed Jeepaholic
 
TheBoogieman's Avatar
1999 XJ Cherokee 
 
Join Date: Aug 2006
Location: charlottesHELL
Posts: 39,850
Quote:
Originally Posted by Athensdawgs81 View Post
Most of the problems you describe are common and cheap to fix compared to replacing the motor.

- "10 minutes later it starts missing" There is a TSB for this. It is due to heat soak that causes the fuel to vaporize in an injector (can't remember which one, I think it's #2 or #3) and there is a simple piece of insulation you can get from stealership to fix this. The vaporized fuel causes the "missing" for a few moments after restart when the engine is shut down hot.

- Lifter ticks are quite common with 4.0's and are usually nothing worry about. My 4.0 has had lifter tick off and on for 60,000 miles. If it really bothers you replacing the lifters isn't that hard and much cheaper then new motor.

- rattling exhaust may just be from the missing from the heat soaked injector I mentioned earlier. If your exhaust is bad a new exhaust can be scored for pretty cheap and a bad exhaust doesn't warrant a new motor. My exhaust rattles every now and then but it's not leaking yet so I haven't bothered to replace it and the rattle is no worse then the tranny noise from having an NV3550.

- as for you over heating. Did you use an OEM radiator, change all the hoses, and have you checked/replaced the Tstat? Is it holding coolant or do you keep having to top it off? I tried getting by with just replacing my radiator earlier this year after the PO's non OEM replacement started leaking. Within 4 months of replacing the radiator I have replaced the water pump, Tstat, and all hoses and my 4.0 is finally holding coolant. All this was not cheap for sure but it's was cheaper then a new motor.

IMO the issues you are describing have much cheaper and simpler fixes then rebulding/replacing the motor. How many miles does your motor have?
His first and only post of JF.
TheBoogieman is offline  
Reply

Tags
engine , motor swap , problem , rebuild

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome