Oil pressure guage - JeepForum.com
 
LinkBack Thread Tools
post #1 of 9 Old 01-27-2011, 12:21 PM Thread Starter
fang_x
Registered User
 
fang_x's Avatar
1998 TJ Wrangler 
 
Join Date: Jun 2009
Location: Montreal, Canada
Posts: 1,254
Oil pressure guage

Recently my oil pressure gauge has been acting up. During idle it will hover in its normal position and for most of my regular driving too.

But when I come to a stop and then accelerate, the pressure guage drops to 0 and the check guages light comes on. it then goes back up to normal.

Ive read a bit and there's two options i have, to either install a mechanical gauge to verify its not a major issue, or replace the sending unit.

can anyone give me more info on this? or has anyone had similar problems?

thanks


'98 TJ Manual -2.5" rcx long arm on 31
'99 Xj, Stock on 30"
'86 Monte Carlo 357 stroker. 450hp.
fang_x is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 01-27-2011, 12:22 PM
JBTJ
Registered User
 
JBTJ's Avatar
2001 TJ Wrangler 
 
Join Date: Mar 2006
Location: Dallas
Posts: 11,639
I would do exactly what you said you need to do. Mine turned out to be the sending unit.
JBTJ is offline  
post #3 of 9 Old 01-27-2011, 12:23 PM
freeskier93
Registered User
1997 TJ Wrangler 
 
Join Date: Oct 2009
Location: Littleton
Posts: 7,250
The dash gauge is a "dummy" gauge. It's just there to show fluctuation or drop to 0 when a problem is detected. Hook a mechanical gauge up to verify. Most likely the pressure sending unit needs to be replaced.
freeskier93 is offline  
 
post #4 of 9 Old 01-27-2011, 01:01 PM
Max-Q
Registered User
1983 CJ7 
 
Join Date: Aug 2009
Location: St. Louis
Posts: 813
Mine has doing that for years. It seems to be very common with the '97 TJ's but I guess yours is close enough. It's the oil sending unit. Your oil pressure is probably fine.

1997 Jeep TJ
1983 Jeep CJ7
2011 JK Unlimited Rubicon
Max-Q is offline  
post #5 of 9 Old 01-27-2011, 06:56 PM
slafferty
Registered User
 
slafferty's Avatar
2000 TJ Wrangler 
 
Join Date: Sep 2008
Location: Kimbolton, Ohio
Posts: 1,450
mine has been running a 0 for the last few months.. If it was true i'm sure the jeep wouldnt be runnin

'00 TJ, 4.0, nv3550 spd, E-lockers Front and Rear, 4.88 gears. Homebuilt Bumpers/ tube doors.. Homebuilt Long Arm in the making... 35 inch MT-R's ordered
Quote:
Originally Posted by RUBtjICON View Post
If you arent scratching it, you arent trying hard enough :tea:
MY BUILD THREAD

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
slafferty is offline  
post #6 of 9 Old 01-27-2011, 09:20 PM Thread Starter
fang_x
Registered User
 
fang_x's Avatar
1998 TJ Wrangler 
 
Join Date: Jun 2009
Location: Montreal, Canada
Posts: 1,254
is there a write up of how to install a mechanical gauge? wouldn't mind giving that a shot.

the jeep does have pretty decent mileage, at 200,000 kms or ~124,000 miles

how much does a new oil sending unit cost?

'98 TJ Manual -2.5" rcx long arm on 31
'99 Xj, Stock on 30"
'86 Monte Carlo 357 stroker. 450hp.
fang_x is offline  
post #7 of 9 Old 01-30-2011, 09:59 PM
Jebenhack
Registered User
1997 TJ Wrangler 
 
Join Date: Jan 2011
Location: Duncan
Posts: 21
Bump. I'm having a similar issue.
Jebenhack is offline  
post #8 of 9 Old 01-30-2011, 11:23 PM Thread Starter
fang_x
Registered User
 
fang_x's Avatar
1998 TJ Wrangler 
 
Join Date: Jun 2009
Location: Montreal, Canada
Posts: 1,254
im going to order a replacement sending unit tomorrow, gonna give it a go and let you know how it goes

'98 TJ Manual -2.5" rcx long arm on 31
'99 Xj, Stock on 30"
'86 Monte Carlo 357 stroker. 450hp.
fang_x is offline  
post #9 of 9 Old 01-31-2011, 01:54 AM
mediumdaddy
Registered User
1997 TJ Wrangler 
 
Join Date: May 2010
Location: The Town
Posts: 955
Mine was acting strange as well. Replacing the sending unit was easy. Cost about 30 bucks if i remember right, and you literally unclip the wiring harness, unscrew the old one, screw in the new one, and hook up the wires. its that simple. BUT it didnt change one thing for me. gauge still doesnt work right, but if there really was no oil pressure, your jeep wouldnt last long, and it would be knocking like there was no tomorrow.

-If you won't stand behind our troops, feel free to stand in front of them!!
Utah Jeepcrew #63
mediumdaddy is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
oil pressure guage....low johnroot01 YJ Wrangler Technical Forum 12 05-06-2009 07:11 AM
oil pressure guage baghdadman TJ Wrangler Technical Forum 1 02-08-2006 01:07 PM
Oil Pressure Guage Five.Ten TJ Wrangler Technical Forum 30 02-15-2005 08:59 PM
Oil Pressure guage yman2or YJ Wrangler Technical Forum 4 10-18-2003 06:33 PM
Oil pressure guage DrEvil TJ Wrangler Technical Forum 1 09-16-2003 10:45 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome