New to Rubicon. 4wd indicator light on dash and locker problems - JeepForum.com
 1Likes
Reply
 
LinkBack Thread Tools
post #1 of 21 Old 01-02-2012, 06:34 PM Thread Starter
ssphoger
Registered User
2004 TJ Wrangler 
 
Join Date: Jan 2012
Location: Williamsport
Posts: 6
New to Rubicon. 4wd indicator light on dash and locker problems

Ok new guy here I just got my 4th Wrangler 04 Rubicon with 60,000 mi.
This is my first Rubicon and so I'm trying out the 4WD and lockers.
First thing no dash lights in 4 Hi or 4LO I know its going in gear though just no indication.
Second the lockers do not seem to work I put it in 4LO pushed the switch nothin pushed it again nothin.
Since the locker is tied in with the transfure case being in 4LO
would it not indicating lock out the axel lock?
Its been cold/wet and I haven't got under it since getting it but I'm taking it to my mechanic soon to put it up on the lift.
Just lookin for what to look for.
Happy I finally joined, plenty more to come.

ssphoger is offline  
Sponsored Links
Advertisement
 
post #2 of 21 Old 01-02-2012, 06:52 PM
bustedknuckle
Registered User
2005 TJ Wrangler 
 
Join Date: Nov 2010
Location: Aurora
Posts: 142
When the locker is engaged the 4wd dash light will blink and then stay on once locked. Hit it once for the rear then one more time for the front. They also only work in 4 low unless you mod the switch.

Can you here the compressor kick on?
bustedknuckle is offline  
post #3 of 21 Old 01-02-2012, 07:08 PM
Sccafire
Registered User
2005 TJ Wrangler 
 
Join Date: Oct 2008
Posts: 1,430
I would think the transfer case position sensor is bad or the wiring to it. The sensor relays what position the trasfer case is in to the PCM. If the PCM is not reading the transfer case in 4lo it will not activate the lockers.

The sensor is not that hard to replace. Could be something simple as the connector not being plugged in.

Scott

"life is good at 2 MPH"
Sccafire is offline  
 
post #4 of 21 Old 01-02-2012, 08:37 PM
Vinman
Registered User
2005 LJ Wrangler 
 
Join Date: Feb 2006
Location: Calgary
Posts: 873
Quote:
Originally Posted by Sccafire View Post
I would think the transfer case position sensor is bad or the wiring to it. The sensor relays what position the trasfer case is in to the PCM. If the PCM is not reading the transfer case in 4lo it will not activate the lockers.

The sensor is not that hard to replace. Could be something simple as the connector not being plugged in.
This.
Vinman is offline  
post #5 of 21 Old 01-02-2012, 10:43 PM
dcope17
Registered User
 
dcope17's Avatar
2006 TJ Wrangler 
 
Join Date: Sep 2008
Location: SoCal
Posts: 2,306
Quote:
Originally Posted by bustedknuckle View Post
When the locker is engaged the 4wd dash light will blink and then stay on once locked. Hit it once for the rear then one more time for the front. They also only work in 4 low unless you mod the switch.

Can you here the compressor kick on?
Not this... 4WD light will not blink... the locker lights will when you push the button to engage but haven't mechanically engaged yet.

.

Life with Christ can be explained like a Jeep...
Being in the Word... grows your tire size.
Prayer... gains more ground clearance.
Fellowship... Is like having a good spotter.

The more of these you have... the easier it is to get over obstacles in your path.
.
.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
dcope17 is offline  
post #6 of 21 Old 01-02-2012, 10:46 PM
bustedknuckle
Registered User
2005 TJ Wrangler 
 
Join Date: Nov 2010
Location: Aurora
Posts: 142
Quote:
Originally Posted by dcope17

Not this... 4WD light will not blink... the locker lights will when you push the button to engage but haven't mechanically engaged yet.
I know I have a rubicon. Sorry if I wrote it misleading.
bustedknuckle is offline  
post #7 of 21 Old 01-02-2012, 11:23 PM
wushaw
Rockin jeep
 
wushaw's Avatar
2000 TJ Wrangler 
 
Join Date: Jan 2007
Location: Texas
Posts: 8,165
And some folks think ARBs have too many components to make em work......
wushaw is offline  
post #8 of 21 Old 01-03-2012, 12:18 AM
SBpunk
Registered User
 
SBpunk's Avatar
2004 WJ 
 
Join Date: May 2011
Location: Enid
Posts: 471
If you put it in 4WL and roll back until it engages then throw it in neutral. Hit the button twice and roll back a little and forward a little. If the lights don't go solid then you have an air leak. If the lights arent coming on at all replace the sensor.

Get under your rig after you engage 4WL and the lockers. See if you can hear the compressors kicking on (they are right behind your transmission and what not on the skid plate. I would chalk your tires too just to be safe. Good luck!

2004 Jeep WJ Overland
1992 Jeep MJ 4x4 5 speed
SBpunk is offline  
post #9 of 21 Old 01-03-2012, 12:20 AM
SBpunk
Registered User
 
SBpunk's Avatar
2004 WJ 
 
Join Date: May 2011
Location: Enid
Posts: 471
Quick question. Do you have a body lift on your jeep? If you do is there a MML? If the shifter wasnt adjusted it might not be engaging correctly causing it not to light up or engage your lockers.

2004 Jeep WJ Overland
1992 Jeep MJ 4x4 5 speed
SBpunk is offline  
post #10 of 21 Old 01-26-2012, 12:51 PM Thread Starter
ssphoger
Registered User
2004 TJ Wrangler 
 
Join Date: Jan 2012
Location: Williamsport
Posts: 6
Well had it on the lift today and replaced the TC position switch (Which was bad) again no light, I put it in gear rolled the wheels a little to make sure it was in gear still nothing { Ran it thru a dash light test and get all but front and rear locked lights, the 4WD light does work}
I get no sound when trying the switch for the lockers.
Anyone know were I can get a wireing and machanical diagram of the locker system?
I bought a Haynes manual but its usless with refrence to the lockers.
Also found the front axle universals need replaced , Don't look to hard but any tips?
Thanks its good to have sights like this.
((PS this is a stock 04 Rubicon no mods. that I know of.))
ssphoger is offline  
post #11 of 21 Old 01-26-2012, 12:59 PM
Keith_C
Registered User
2003 TJ Wrangler 
 
Join Date: Oct 2004
Location: Lake Anna
Posts: 833
Quote:
Originally Posted by ssphoger View Post
Well had it on the lift today and replaced the TC position switch (Which was bad) again no light,
How did you determine the switch was bad?
Keith_C is offline  
post #12 of 21 Old 01-26-2012, 04:07 PM Thread Starter
ssphoger
Registered User
2004 TJ Wrangler 
 
Join Date: Jan 2012
Location: Williamsport
Posts: 6
When I pulled it out the plunger stayed in with no spring tension unlike the new one which moves in and out.
The dealer determined it was bad but would not replace it under the 30 day 3000 mi drive train warranty.(Saying its a switch not part of the drive train BS)
Now I have it 45 days and 35000 mi so guess I'm on my own. ( I know should have checked this out before I said I'll take it but never had a Rubicon and just didn't think of it )

Found a wiring diagram and I may just install some switches and bypass all the BS and make em work when I want.
ssphoger is offline  
post #13 of 21 Old 01-26-2012, 04:11 PM
lope
Member
 
lope's Avatar
2005 TJ Wrangler 
 
Join Date: Oct 2010
Location: Chandler
Posts: 479
Quote:
Originally Posted by ssphoger View Post
Also found the front axle universals need replaced , Don't look to hard but any tips?
Let me introduce you to Stu.
http://www.stu-offroad.com/axle/ujoint1/u-joint-1.htm


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
lope is offline  
post #14 of 21 Old 02-03-2012, 05:56 AM Thread Starter
ssphoger
Registered User
2004 TJ Wrangler 
 
Join Date: Jan 2012
Location: Williamsport
Posts: 6
Very happy to meet Stu!!!! THANKS lope
Did the front universals yesterday in 3 hrs just like Stu said.
Now the Lockers
When I do the dash light test the locker indicators don't come on the 4WD does comes on
I talked to the previous owner and I don't think the lockers were ever used since new, Next nice day I have time I'm going to start tracing things down and maybe jumping out some things just to get the compresors to run and make sure that end works. If that works I'll put in some switches and bypass the old system if I can't get it to work right.
thoughts?
ssphoger is offline  
post #15 of 21 Old 02-03-2012, 06:25 AM
4banged
Registered User
2013 JK Wrangler 
 
Join Date: May 2010
Location: connecticut
Posts: 697
Quote:
Originally Posted by ssphoger
I talked to the previous owner and I don't think the lockers were ever used since new...
That's just wrong...glad you rescued this jeep from that guy...he probably traded it in on a Prius!
4banged is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Dash indicator light problem gerryjeep Wrangler General Discussion 0 08-10-2011 06:49 PM
4X4 dash indicator light JeepJeep01 TJ Wrangler Technical Forum 3 05-10-2010 08:31 PM
Dash Indicator Light Ideas japes YJ Wrangler Technical Forum 10 09-08-2007 06:56 PM
False locker indicator{rubicon} OffCamberTJ TJ Wrangler Technical Forum 6 01-26-2007 08:40 PM
4WD dash indicator light is out TheJeepMan TJ Wrangler Technical Forum 4 01-05-2005 05:46 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome