Need help on oil sending unit - JeepForum.com
 4Likes
Reply
 
LinkBack Thread Tools
post #1 of 17 Old 07-13-2020, 09:32 AM Thread Starter
BlueFl.Wrangler
Supporting Member
 
BlueFl.Wrangler's Avatar
2002 TJ Wrangler 
 
Join Date: Aug 2019
Location: Inglis,Fl.
Posts: 345
Need help on oil sending unit

Fellas
When I bought the jeep ( about 1 year ago ) the oil pressure always stayed pegged. I knew right away that I didnt always have 80 PSI and that it was a indication of a bad sender. So I went down to NAPA and got one there. That fixed it ( or so i thought )-- pressure returned to normal ( aprox 50 psi ). Well that lasted a few months, then it went backed to pegged. Suggestion was made to go the OEM route-- so I did @ TRIPPLE the cost, about $80 if I remember correctly. Pressure returned to normal untill today as its backed to being pegged. Now I know ABSOLUTELY NOTHING about the electrical side of anything, but I am thinking that there is to much voltage going to them and ruining them.

What do you guys think?


Diplomacy is the art of telling people to go to hell in such a way that they ask for directions

Winston Churchill
BlueFl.Wrangler is offline  
Sponsored Links
Advertisement
 
post #2 of 17 Old 07-13-2020, 10:09 AM
jtec
Web Wheeler
 
jtec's Avatar
2014 JK Wrangler 
 
Join Date: Oct 2017
Posts: 8,481
this is a 5v sensor, see attachment.

Are you getting any codes? Might want to scan - do not rely on CEL only.
Is airbag light on?
Attached Files
File Type: pdf 02tje oil press 1.pdf (112.3 KB, 8 views)
BlueFl.Wrangler likes this.

When I see the price of OEM I think aftermarket.
When I see the quality of aftermarket I think OEM.
jtec is offline  
post #3 of 17 Old 07-13-2020, 05:45 PM Thread Starter
BlueFl.Wrangler
Supporting Member
 
BlueFl.Wrangler's Avatar
2002 TJ Wrangler 
 
Join Date: Aug 2019
Location: Inglis,Fl.
Posts: 345
Quote:
Originally Posted by jtec View Post
this is a 5v sensor, see attachment.

Are you getting any codes? Might want to scan - do not rely on CEL only.
Is airbag light on?
Thanks for chiming in

No C.E.L.'s in the dash---- hooked up scan tool , shows no codes

The air bag is lit up "off "

Diplomacy is the art of telling people to go to hell in such a way that they ask for directions

Winston Churchill
BlueFl.Wrangler is offline  
 
post #4 of 17 Old 07-13-2020, 06:04 PM
2jhanna
Web Wheeler
2002 TJ Wrangler 
 
Join Date: Jun 2007
Location: Denton County, TX
Posts: 9,567
With the jeep running, and somebody in the cab watching the gauge, can you move/wiggle the wire lead and harness around
BlueFl.Wrangler likes this.

I am multi-talented, I can talk and piss you off at the same time.

jhanna
denton county, tx
2jhanna is offline  
post #5 of 17 Old 07-13-2020, 06:06 PM Thread Starter
BlueFl.Wrangler
Supporting Member
 
BlueFl.Wrangler's Avatar
2002 TJ Wrangler 
 
Join Date: Aug 2019
Location: Inglis,Fl.
Posts: 345
Quote:
Originally Posted by 2jhanna View Post
With the jeep running, and somebody in the cab watching the gauge, can you move/wiggle the wire lead and harness around
Fixing to give it a try

Diplomacy is the art of telling people to go to hell in such a way that they ask for directions

Winston Churchill
BlueFl.Wrangler is offline  
post #6 of 17 Old 07-13-2020, 06:13 PM Thread Starter
BlueFl.Wrangler
Supporting Member
 
BlueFl.Wrangler's Avatar
2002 TJ Wrangler 
 
Join Date: Aug 2019
Location: Inglis,Fl.
Posts: 345
nothing changed
still pegged

Diplomacy is the art of telling people to go to hell in such a way that they ask for directions

Winston Churchill
BlueFl.Wrangler is offline  
post #7 of 17 Old 07-13-2020, 07:22 PM
2jhanna
Web Wheeler
2002 TJ Wrangler 
 
Join Date: Jun 2007
Location: Denton County, TX
Posts: 9,567
Sorry, worth a try.

I am multi-talented, I can talk and piss you off at the same time.

jhanna
denton county, tx
2jhanna is offline  
post #8 of 17 Old 07-13-2020, 08:10 PM Thread Starter
BlueFl.Wrangler
Supporting Member
 
BlueFl.Wrangler's Avatar
2002 TJ Wrangler 
 
Join Date: Aug 2019
Location: Inglis,Fl.
Posts: 345
Always worth a try
Didnt cost a dime

Diplomacy is the art of telling people to go to hell in such a way that they ask for directions

Winston Churchill
BlueFl.Wrangler is offline  
post #9 of 17 Old 07-13-2020, 11:15 PM
mukluk
Web Wheeler
 
mukluk's Avatar
2000 TJ Wrangler 
 
Join Date: Oct 2010
Location: Clyde
Posts: 6,116
Unplug the connector and give the connector and sender terminals a good shot of spray electrical contact cleaner (maybe the issue is just a bit of schmutz causing headaches). Key off, you should see less than 5 ohms resistance when checking continuity to chassis ground on pin 3 (BK/LB), there should be more than 100 ohms when checking continuity to chassis ground at pin 2 (GY/YL), and more than 100 ohms when checking for continuity from pin 2 to either pin 1 or pin 3 (checking for shorts from wire to wire). Key on and engine not running, you should see between 4.8 and 5.2 volts at pin 1 (VT/OR). If everything checks out, make sure none of the terminals in the connector are loose or recessing, then reconnect the plug and see if the sender works.
BlueFl.Wrangler likes this.

2000 TJ SE
2005 LJ Rubicon
mukluk is offline  
post #10 of 17 Old 07-14-2020, 06:38 AM Thread Starter
BlueFl.Wrangler
Supporting Member
 
BlueFl.Wrangler's Avatar
2002 TJ Wrangler 
 
Join Date: Aug 2019
Location: Inglis,Fl.
Posts: 345
Quote:
Originally Posted by mukluk View Post
Unplug the connector and give the connector and sender terminals a good shot of spray electrical contact cleaner (maybe the issue is just a bit of schmutz causing headaches). Key off, you should see less than 5 ohms resistance when checking continuity to chassis ground on pin 3 (BK/LB), there should be more than 100 ohms when checking continuity to chassis ground at pin 2 (GY/YL), and more than 100 ohms when checking for continuity from pin 2 to either pin 1 or pin 3 (checking for shorts from wire to wire). Key on and engine not running, you should see between 4.8 and 5.2 volts at pin 1 (VT/OR). If everything checks out, make sure none of the terminals in the connector are loose or recessing, then reconnect the plug and see if the sender works.
When you say chassis ground- you dont mean a specific point do you? Just a good clean area on frame or block should do--?

Diplomacy is the art of telling people to go to hell in such a way that they ask for directions

Winston Churchill
BlueFl.Wrangler is offline  
post #11 of 17 Old 07-14-2020, 09:09 AM
mukluk
Web Wheeler
 
mukluk's Avatar
2000 TJ Wrangler 
 
Join Date: Oct 2010
Location: Clyde
Posts: 6,116
Yep, a clean spot on the frame or block should do, the battery negative terminal is also acceptable, just didn't want you using the ground wire in the sender connector as a ground in case it was shorted to another wire.

2000 TJ SE
2005 LJ Rubicon
mukluk is offline  
post #12 of 17 Old 07-14-2020, 10:13 AM
jtec
Web Wheeler
 
jtec's Avatar
2014 JK Wrangler 
 
Join Date: Oct 2017
Posts: 8,481
KOEO - WHAT DOES GAUGE READ?

EXplain (The air bag is lit up "off ") IDK is the light ON or not?
If its on check the ground circuits for stray voltage - advise.

When I see the price of OEM I think aftermarket.
When I see the quality of aftermarket I think OEM.
jtec is offline  
post #13 of 17 Old 07-14-2020, 11:48 AM Thread Starter
BlueFl.Wrangler
Supporting Member
 
BlueFl.Wrangler's Avatar
2002 TJ Wrangler 
 
Join Date: Aug 2019
Location: Inglis,Fl.
Posts: 345
Quote:
Originally Posted by jtec View Post
KOEO - WHAT DOES GAUGE READ?

EXplain (The air bag is lit up "off ") IDK is the light ON or not?
If its on check the ground circuits for stray voltage - advise.
Have some patience here with me
KOEO- is that key on engine off?

Diplomacy is the art of telling people to go to hell in such a way that they ask for directions

Winston Churchill
BlueFl.Wrangler is offline  
post #14 of 17 Old 07-14-2020, 02:01 PM
jtec
Web Wheeler
 
jtec's Avatar
2014 JK Wrangler 
 
Join Date: Oct 2017
Posts: 8,481
yes Key On Eng Off.
A quick look to see if wiring an issue. It should be at 0zero

I really do not understand your answer to AIRBAG light... Is it on?

When I see the price of OEM I think aftermarket.
When I see the quality of aftermarket I think OEM.
jtec is offline  
post #15 of 17 Old 07-14-2020, 04:33 PM Thread Starter
BlueFl.Wrangler
Supporting Member
 
BlueFl.Wrangler's Avatar
2002 TJ Wrangler 
 
Join Date: Aug 2019
Location: Inglis,Fl.
Posts: 345
Nope-- not @ zero- its pegged KOEO
Attached Images
 

Diplomacy is the art of telling people to go to hell in such a way that they ask for directions

Winston Churchill
BlueFl.Wrangler is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome