Metalcloak Duroflex Joint. Anyone have these that can give a review? - JeepForum.com
 
LinkBack Thread Tools
post #1 of 3 Old 08-04-2015, 10:35 AM Thread Starter
jeepjunkie21
Registered User
2004 LJ Wrangler 
 
Join Date: Dec 2013
Location: Oak Forest
Posts: 50
Metalcloak Duroflex Joint. Anyone have these that can give a review?

Im building my own lift and im thinking of going with the the metalcloak duroflex joints for my control arms. Has anyone had any experience with these before?

jeepjunkie21 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 08-04-2015, 10:51 AM
freeskier93
Registered User
1997 TJ Wrangler 
 
Join Date: Oct 2009
Location: Littleton
Posts: 7,435
freeskier93 is offline  
post #3 of 3 Old 08-04-2015, 05:09 PM
Jaminjer
Registered User
2003 TJ Wrangler 
 
Join Date: Jan 2013
Location: Lake Stevens
Posts: 137
been running mine for last 2 years, no problems and lots of flex. The only thing I wish was they had the double adjustable ones then, would be much easier to adjust.
Jaminjer is offline  
Reply

Tags
control arms , duroflex suspension , joint , metalcloak , suspension

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome